LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-18-2003, 04:44 PM   #1
MarcRJacobs
Member
 
Registered: Mar 2003
Location: Las Gatos, Ca USA
Distribution: SUSE 10.0
Posts: 43

Rep: Reputation: 15
Question RedHat Network Updates


I run RedHat 8.0 Professional staright out of the box. A few days after installing it the RHN icon disappeared from the system tray when under KDE. It is there and works fine in GNOME. I can manually run RedHat Network Update, and it works fine, but I would like to get the icon back, as I like KDE better. Can anyone tell me how, keeping in mind that I am very new to Linux?

Thanks,
Marc
 
Old 03-18-2003, 04:59 PM   #2
Zerodark
Member
 
Registered: Mar 2003
Location: Fort Sill, Oklahoma
Distribution: Gentoo
Posts: 192

Rep: Reputation: 30
i don't know how to get the icon back, though you can go to system tools and go to Red Hat Network and it works the same way.
 
Old 03-18-2003, 05:37 PM   #3
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Make sure the redhat network update daemon is running. When logged in to gnome, do a ps ax and look for the daemon, it has a fairly obvious name, if you get stuck ask and i'll check tomorrow when i'm in front of my redhat box.

Then make sure that's being run on kde startup.
 
Old 03-18-2003, 08:06 PM   #4
MarcRJacobs
Member
 
Registered: Mar 2003
Location: Las Gatos, Ca USA
Distribution: SUSE 10.0
Posts: 43

Original Poster
Rep: Reputation: 15
I check ps ax, and found "rhnsd --interval 120". Seemed fine, so I loaded "Server (Server Management)", and found the rhnsd daemon. Stopped, started, and restarted numerous times, but the icon still does not return. Then, I checked the system monitor, and it is running, as root, using 540k, 0% cpu, and on id 1633. All seems fine, but no icon. Any ideas?
 
Old 03-18-2003, 08:14 PM   #5
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Do:

rhn-applet-gui&

Your applet will appear again.
 
Old 03-18-2003, 09:33 PM   #6
MarcRJacobs
Member
 
Registered: Mar 2003
Location: Las Gatos, Ca USA
Distribution: SUSE 10.0
Posts: 43

Original Poster
Rep: Reputation: 15
Thanks, it does indeed put it back, but only until you close the terminal window you typed it into. When that window is closed, or you login next time it doesn't come back. Is there a more permanent solution?
 
Old 03-18-2003, 09:47 PM   #7
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Well it shouldn't go away after you close the terminal as long as you put the & after the rhn-applet-gui command. When you log out you can choose the 'save current session' option so that it is there when you log in again.
 
Old 03-18-2003, 10:11 PM   #8
MarcRJacobs
Member
 
Registered: Mar 2003
Location: Las Gatos, Ca USA
Distribution: SUSE 10.0
Posts: 43

Original Poster
Rep: Reputation: 15
You're correct, I didn't see the space before the &. So, I tried the following:
cd /home/marc
cat>startrhngui
rhn-applet-gui&
^D
chmod +x startrhngui
cd /etc/rc.d/rc5.d
ln -v /home/marc/startrhngui S91rhngui

This created a symbolic link to the file created in my home directory. However, it to did not have the space before the &. Then, I read this last message from you, tried a space, and I'm fixed. But, how do I undo the symbolic link I created?
 
Old 03-18-2003, 10:14 PM   #9
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Can't you just delete the symbolic link you created?
 
Old 03-18-2003, 10:26 PM   #10
MarcRJacobs
Member
 
Registered: Mar 2003
Location: Las Gatos, Ca USA
Distribution: SUSE 10.0
Posts: 43

Original Poster
Rep: Reputation: 15
Yup, worked fine. Deleted the link, the the little startup file, rebooted, and all is still fine. Thanks a lot for all your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
redhat 9 updates Lubricant_Larry Linux - Newbie 1 11-24-2004 02:36 PM
Need Help Applying updates in Redhat 9 jleakey77 Linux - Newbie 4 10-27-2003 03:22 PM
Redhat Updates Mega Man X Linux - General 2 05-17-2003 04:21 PM
RedHat 7.2 updates JoC Linux - General 8 12-09-2002 04:16 PM
Redhat 7.1 Updates Streams Linux - Newbie 9 08-05-2002 04:02 AM


All times are GMT -5. The time now is 05:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration