LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-14-2005, 12:05 PM   #1
trini
LQ Newbie
 
Registered: Feb 2005
Posts: 5

Rep: Reputation: 0
redhat ES


I want to be able to start vnc on bootup...I've learned that put the vncserver in rc.local file on redhat 9.0 to start at boot up...When I try that in ES it doesn't work...

How would I get it to run on bootup...

thanks
 
Old 02-14-2005, 12:47 PM   #2
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
You can put vncserver in /etc/rc.local but why need to? If you want to start it up the Redhat style, then look into 'chkconfig'. That's the command.

-twantrd
 
Old 02-14-2005, 06:08 PM   #3
trini
LQ Newbie
 
Registered: Feb 2005
Posts: 5

Original Poster
Rep: Reputation: 0
sorry I don't understand...will this enable it to start on bootup???

thanks
 
Old 02-14-2005, 08:26 PM   #4
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 59
Quote:
sorry I don't understand...will this enable it to start on bootup???
Yes, it should.

chkconfig --level 345 vncserver on
 
Old 02-14-2005, 08:44 PM   #5
trini
LQ Newbie
 
Registered: Feb 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by homey
Yes, it should.

chkconfig --level 345 vncserver on
I'am typing this in terminal but is says

bash: chkconfig: command not found...

Iam I doing something wrong???

thanks
 
Old 02-14-2005, 08:57 PM   #6
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 59
Type the command: su - and enter the root user password.
Then type the command: chkconfig --level 345 vncserver on
 
Old 02-14-2005, 09:03 PM   #7
trini
LQ Newbie
 
Registered: Feb 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by homey
Type the command: su - and enter the root user password.
Then type the command: chkconfig --level 345 vncserver on
it looked like it did something....

but know my other question is will this be on permently or is this just a temp meaning it will be disable if the box reboots???


ok I tried it but still can't log in connection refused

thanks

Last edited by trini; 02-14-2005 at 09:04 PM.
 
Old 02-14-2005, 09:57 PM   #8
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
Chkconfig will make it a permanent thing. Do a 'man chkconfig' and read what it does. You should know what commands you are typing in to your box .

Quote:
ok I tried it but still can't log in connection refused
'chkconfig' doesn't start vncserver, it just starts it up everytime you reboot. Check to see if in fact vncserver is running. That's most likely your problem.

-twantrd
 
Old 02-14-2005, 10:11 PM   #9
trini
LQ Newbie
 
Registered: Feb 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by twantrd
Chkconfig will make it a permanent thing. Do a 'man chkconfig' and read what it does. You should know what commands you are typing in to your box .


'chkconfig' doesn't start vncserver, it just starts it up everytime you reboot. Check to see if in fact vncserver is running. That's most likely your problem.

-twantrd
is it possible to have it running in the /etc/rc.local file

this is my goal to have it on boot up...I did this in RH 9.0 with no problems...was just wondering if it would work the same way

thanks
 
Old 02-15-2005, 12:36 AM   #10
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
Yes, you can start it in rc.local, however, that is not the traditional way.

-twantrd
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
display horizantly shifted for redhat 9.0, redhat enterprise and fedora core dudely Linux - Enterprise 3 08-13-2005 12:28 PM
display horizantly shifted for redhat 9.0, redhat enterprise and fedora core dudely Linux - Software 3 08-12-2005 10:18 AM
display horizantly shifted for redhat 9.0, redhat enterprise and fedora core dudely Linux - Newbie 1 08-11-2005 04:11 PM
redhat-config-packages error (thinks it is redhat and not fedora) qwijibow Fedora 3 12-17-2003 08:59 PM
installing samba-3.0alpha24-1.i386.rpm into RedHat 8 and RedHat 9 Linh Linux - Newbie 2 06-04-2003 05:50 AM


All times are GMT -5. The time now is 11:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration