LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-09-2004, 06:18 AM   #1
BLazeD
LQ Newbie
 
Registered: Feb 2004
Posts: 8

Rep: Reputation: 0
RedHat Boot Problems.


Tonight I installed Redhat on my PC

I have one 80GB HDD and want to dual boot with Windows XP

I used Partition Magic to create an unallocated partition of 10GB.
I then used the installation program to make the linux partitions boot, swap and /

The linux boot partition exists after about 60GB of the hard disk. I know this will not let me boot into linux with a boot menu or whatever.

So i created a boot disk in the install program, I thought this would let me boot into Linux when I insert it

However all I get is the install menu again. From here I can eventually get to root. But this doesnt mean anything to me (I am a total noob). What I wanted was to be able to boot into linux with a GUI (which I installed as a package).

How can I load up the GUI from root?

And secondly, given that the linux boot parition isnt in the first few cylinders that its need to be in order to come up without a boot disk ( i did install LILO, but in a linux /boot parition which is much later than it should be) is there anyway I can get some sort of boot selection thing going?


Or

Should I delete the installation and the partition, use Partition Magic move my WinXP partition about 100MB from the start and then re-install. This time puttting the linux /boot partition in that 1st 100MB, and the rest later on in the HDD after all my XP files.?

Cheers and remember I dont know jack shit :P
 
Old 02-09-2004, 08:50 AM   #2
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
Don't worry about the location of the /boot partition. Just select "install boot loader to the master boot record" during the install process. The boot loader (lilo or grub) will then control booting and can be configured to allow you to select windows or linux during boot up. The /boot partition contains the linux kernel image and some other files used during boot.

I think redhat defaults to grub as the boot loader. I always use lilo, so I am not that familiar with grub. If you use lilo, you can install lilo to the master boot record without reinstalling linux. Just use your boot disk to get to root. You will need to edit the file: /etc/lilo.conf There is a line in the file starting with "boot=". Make sure it looks like:

boot=/dev/hda

The above will install to the master boot record of the master IDE drive (hda). If it is something like: boot=/dev/hda5, it will install to the hda5 partition (maybe your /boot partition?) Exit the text editor and issue the command "lilo" from a console and reboot without the boot disk. It should boot to linux.
 
Old 02-09-2004, 01:32 PM   #3
BLazeD
LQ Newbie
 
Registered: Feb 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks for the reply

So I get to root, then go:

cd etc
pico lilo.conf
make the change to boot=/dev/hda

What I dont understand is how come I have to issue lilo from console. When I reboot after this I still want the choice of whether to boot WinXP or Linux to come up, it will with this method wont it?


Update:

I made the change, (it was set to hde)

However when I type:

lilo

It just says something like "can't execute, read only file system." However the edit I made seems to have been successful. Also, I do not select read only when mounting the system.

Last edited by BLazeD; 02-09-2004 at 02:00 PM.
 
Old 02-09-2004, 02:45 PM   #4
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
How many hard drives do you have on your computer? It is strange that it is set to hde. For a typical computer with two hard drives and two IDE optical drives, the master hard drive will be hda, the slave hard drive will be hdb, the master optical drive will be hdc, the slave optical drive will be hdd. These are determined by your motherboard and how many drives are installed.

If you try to write to an optical drive, you will get the error above. Make sure you have the correct drive listed in lilo. Also, you can contnue to boot windows after ward, you just have to have a listing for windows in lilo like:

other=/dev/hda1
label="WindowsXP"

That means you can select WindowsXP as an option and boot to it when it is installed on the first partition of hda (hda1).
 
Old 02-09-2004, 02:54 PM   #5
BLazeD
LQ Newbie
 
Registered: Feb 2004
Posts: 8

Original Poster
Rep: Reputation: 0
I have just one 80GB HDD

Before I installed I just resized the Windows XP partition so that there was 15GB unpartitioned.

I then ran the Red Hat CD ROM installer and let it make automatic partition settings so it setup the root, swap and boot automatically…

The drive is a Seagate 80GB connected via a SATA adaptor.

Maybe I should try boot=/dev/hd1 for the linux entry?

Or have you been thinking I’ve had 2 drives the whole time?

BTW, someone in some other forums said I should delete the installation and the partition, use Partition Magic move my WinXP partition about 20MB from the start and then re-install. This time puttting the linux /boot partition in that 1st 20MB, and the rest later on in the HDD after all my XP files

Thanks for your continued help.
 
Old 02-09-2004, 03:07 PM   #6
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
grub setup

Hi!

If you have grub loaded on boot as I think you have if you're a newbie then you need to do the following thing.

login as root
type "grub" (this will do some checking)
when you get into grub command line type in the following:

find /boot/grub/menu.list (this will tell you where the boot loader is)

the result will be like : (hd0,5) where hd0 is the harddisk and 5 is the number of the partition on that disk

then type:

root(hdx,y) (where x and y are the parameters you got from the last command find like root(hd0,1))

setup(hdx) (where x is the same as above)

quit

This will install grub on the MBR (Master Boot Record) and thus made it available on your next boot.

Now reboot your computer and it should present you with a loader. Then you will see if you have both systems in that loader. If you do, then it is OK, if not you will have to play with the menu list of the boot loader GRUB.
 
Old 02-09-2004, 03:08 PM   #7
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
a little error

At the up post there is a little error or maybe not, but I am not sure if the file you are looking for is /boot/grub/menu.list or /boot/grub/menu.lst so you better try both and you will see which one is the right one.
 
Old 02-09-2004, 03:13 PM   #8
BLazeD
LQ Newbie
 
Registered: Feb 2004
Posts: 8

Original Poster
Rep: Reputation: 0
I have LILO installed

I changed to that option in the install process
 
Old 02-09-2004, 04:05 PM   #9
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
There is no need to move your windows partition or locate /boot near the beginning of the disk. In fact, you don't even need to have a separate /boot partition, RedHat just likes it that way. I normally have only two linux partitions, one for "/" the other for "/home" My /boot directory is inside my "/" partition and not placed on a separate partition and all is well. In addition, I have windows installed on a third partition and dual boot using lilo, so this should work. The thing I don't understand is why lilo is not writing to the master boot record as it should. I'm not sure how your boot disk works, but do you have to move root to the hard disk? I have fixed a messed up lilo.conf using a knoppix cd. I boot up and I am running as root from the cd, then type "chroot /mnt/hda5" where /mnt/hda5 is the linux partition so that I am now running as root on the hard drive and when I issue the lilo command, it is applied to the hard drive and not the cd drive. Sorry, I don't know redhat very well. Maybe someone else out there has better suggestions?
 
Old 02-09-2004, 04:09 PM   #10
Whitehat
Senior Member
 
Registered: Feb 2003
Location: The Cold North
Distribution: SuSE 9.1
Posts: 1,289

Rep: Reputation: 46
I just wonder....why would you create a thread with Redhat in the title, and also be having problems with Redhat and not put it in the "Redhat" forum?

Seems sorta like common sense to me.

I of couse realize that you're a new member. I just wondered

-Whitehat

Last edited by Whitehat; 02-09-2004 at 04:13 PM.
 
Old 02-09-2004, 04:26 PM   #11
BLazeD
LQ Newbie
 
Registered: Feb 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Well if you think I would get more response there then can a mod please move the thread

I think I will just reinstall the whole thing, this time making sure to "install boot loader to the master boot record" if there is such an option!
 
Old 02-09-2004, 05:56 PM   #12
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,207

Rep: Reputation: 63
BlazeD,

Sorry what I suggested didn't fix things. If you re-install, just make sure to select install to the MBR (I'm almost certain there is an option for that) and let the redhat installer handle the rest. Your situation (one hard drive dual booting) is very very common and you shouldn't have the issues you did.
 
Old 02-09-2004, 07:20 PM   #13
BLazeD
LQ Newbie
 
Registered: Feb 2004
Posts: 8

Original Poster
Rep: Reputation: 0
No problem man!

Appreciate the help, I will be sure to let you know how it goes when I get home from work.

I think what stuffed me up was some people told me about that /boot thing has to be in the first part of the drive, and that I dont want to over-write the master boot record cause then I lose windows or something.

Total n00b Anyway will let you know how it goes


Edit: Just read some more on some other forums, and one guy mentioned this:

Quote:
/dev/hda = your hard drive (assuming it's the primary master IDE device)
Since my one and only HDD is SATA, and not IDE, cause this be why the names of the partitions etc are all screwed up and it doesnt boot properly?

2nd Edit

Just gonna follow this:

http://www.geocities.com/epark/linux...w2k-HOWTO.html

Last edited by BLazeD; 02-09-2004 at 07:49 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RedHat 9 Boot Problems yushchenko Linux - Software 1 12-23-2004 09:21 PM
Dual boot for Redhat 9 and Solaris 9 boot manager problems steve_2010 Red Hat 1 01-30-2004 10:14 PM
Redhat boot problems chris82 Linux - Newbie 10 10-20-2003 02:42 PM
redhat 9 boot problems filth Linux - Distributions 10 05-11-2003 05:54 AM
Redhat 8.0 boot problems eddcrossman Linux - Newbie 13 02-02-2003 05:59 AM


All times are GMT -5. The time now is 12:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration