LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-11-2003, 06:11 PM   #1
raging potato
LQ Newbie
 
Registered: Oct 2003
Location: Ireland
Distribution: Redhat 9.0
Posts: 12

Rep: Reputation: 0
Angry Redhat 9/XP pro dual boot up not working


Hello!

I am somewhat inexperienced in these matters so I apologise if this is a question that has been asked 1000's of times before.

I have just installed Redhat 9.0 on my computer.

I have 2 hard drives.
A C:/ that is my main drive with Windows XP professional on it, this drive is NTFS.
My other drive, the D:/ is NTFS also, this is where I installed Redhat.

When the computer boots up, it utilises the GRUB facility to enable a dual boot up. I have 2 options to choose from, either run Redhat or DOS.

I can get Redhat to run fine, but when I choose the DOS option the following comes up on the screen:

root noverify (hd0,0)
chain loader +1

and I don't get into windows.

Would anyone have any advice on how to amend this problem.
Be kind, I am new to this computing lark.

Cheers

Peter
 
Old 10-11-2003, 06:15 PM   #2
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
ok, a little thought... linux does not install to ntfs (it can't write to it) so either you ovewrote that ntfs partition or made a new one from it, i don't know

also, the naming convention in linux is not like windows: windows reads drives by assigning letters to them; linux describes them as the partitions that they are

to help you, i need you to post here your /boot/grub/grub.conf files contents and the output of fdisk -l (type this into a terminal)
 
Old 10-11-2003, 06:25 PM   #3
raging potato
LQ Newbie
 
Registered: Oct 2003
Location: Ireland
Distribution: Redhat 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for your reply.
I hope you are a patient person, this may take a little time, as i have literally had 4 hours experience of using Redhat.

Ok first things first.
Do you want me to open up a terminal window?
If so, what exactly do I type into the window?
Will I need to login as the system administrator to do this?

Thanks
 
Old 10-11-2003, 06:34 PM   #4
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
lol, don't worry, we are all here to help

basically, ya, open up a terminal either by selecting from the redhat window under system tools (i believe that is where it is) or just right click and select new terminal

in this terminal u will see namehere@localhost$
here i want you to type fdisk -l
if u get a response saying command not found, type su - and then when prompted for a password, type in the root password u made during install (to backtrack a little, u do not need to login as root in the graphical mode, u should never do this, just do it in the terminal like u are doing now)

then copy the output and paste it here

now u can exit the terminal, double-click home, then in the place where u can type a path, type /boot/grub and then hit enter
double-click grub.conf and post that here as well

it should begin something like
######################
#produced by anaconda

or something similar
 
Old 10-11-2003, 06:51 PM   #5
raging potato
LQ Newbie
 
Registered: Oct 2003
Location: Ireland
Distribution: Redhat 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
Huston we have a problem!

I opened up the terminal as you kindly instructed me.

typed in fdisk - l (this is an small L, yes?)
got the command not found prompt, so I typed in su.
Got prompted for the password, fired it in, and the following came up on the terminal:

[root@localhost pheery] #

I exited the terminal, and found the grub.conf file, doubled clicked on it, but I got the following dialogue box:

Can't display location
Nautilus has no installed viewer capable of displaying /boot/grub/grub.conf

What does it all mean?

I can copy and email the file to you if you want?
 
Old 10-11-2003, 06:56 PM   #6
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
ok, i think u forgot to run fdisk -l as root (yes, this is a small L)
so run that command in the terminal as root and post the output

strange, nautilus should be able to view grub.conf (nautilus is the file manager that allows u to view all your files as graphics and such)

if nautilus really does not want to do so, after your get your fdisk -l posted, do not exit the terminal, and then type gedit /boot/grub/grub.conf and then post the file


*EDIT: i'll be away from my pc for a while now, keep trying and someone will help, but i'll be back

Last edited by TheOneAndOnlySM; 10-11-2003 at 07:15 PM.
 
Old 10-11-2003, 07:37 PM   #7
raging potato
LQ Newbie
 
Registered: Oct 2003
Location: Ireland
Distribution: Redhat 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
Ok, I did what you suggested.

here is what was on the terminal window

[pheery@localhost pheery] $ su
password:
[root@localhost pheery] # fdisk -l
bash: fdisk: command not found
[root@local host pheery] #gedit /boot/grub/grub.conf

(gedit: 3230: GNOMEUI - Warning ** While connecting to session manager: Authentication rejected, reason: None of the authenication protocols specified are supported and host based authenication failed.


The following appeared in a new window.

#grub.conf generated by anaconda
#Note that you do not have to rerun grub after making changes #to this file.
#NOTICE: You have a /boot partition. This means that all kernel
#and initrd paths are relative to /boot/, eg.
#root (hd1,0)
#kernel/vmlinuz-version ro root=/dev/hd/bz initrd/initrd-version.img
#boot=/dev/hdd

default=1
timeout=10
splash image= (hd1,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20 - 8)
kernel/vmlinuz-2.4.20 - 8 rorootLABEL=/hdc=ide-scsi
initrd/initrd.2.4.20 - 8.img
title DOS
rootnoverify (hd0,0)
chainloader +1

Any ideas??
 
Old 10-11-2003, 07:49 PM   #8
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
ok, grub looks alright, gonna have to check partitions (ya, i'm here for a while longer)

ok, fdisk in redhat does not want to be run in a gui
so, press ctrl alt F2 and u should go to a text prompt (if u want to get back to the gui, hit ctrl alt F7)

now, login as root (type root for login name) and enter password
then type fdisk (just that one command) and look at the options you can pass; look for the option that says "print partition table" it could be -l or -p; when u find the switch, type fdisk -switch (whatever the switch letter happens to be, you may have to specifiy a device)
to specify device, do fdisk -switch /dev/hda
then copy that stuff down
then do fdisk -switch /dev/hdb (this is where linux should be, u do not really need this to solve your problem, but it is good info for you too)


what i'm thinking is your problem is that windows is not your first partiton on your first harddrive; where it says under dos (hd0,0) i'm thinking it may be (hd0,1), but we'll see
 
Old 10-11-2003, 07:54 PM   #9
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Quote:
pheery@localhost pheery] $ su
password:
[root@localhost pheery] # fdisk -l
bash: fdisk: command not found
As SM mentioned earlier its

su -

ie "su dash"

not su on its own
 
Old 10-11-2003, 08:08 PM   #10
raging potato
LQ Newbie
 
Registered: Oct 2003
Location: Ireland
Distribution: Redhat 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
i'm stuck.

this is what is on the screen

Redhat Linux release 9 (Shrike)
Kernel 2.4.20 - 8 on an i686

Localhost login: root
password:
[root@localhost root]# fdisk

usage: fdisk[-l] [-b ssz] [-u] device

E.g.: fdisk/dev/hda (for the 1st ide disk)
or: fdisk/dev/sdc (for 3rd SCSI disk)
or: fdisk/dev/eda (for 1st ps/2 ESDI drive)
or: fdisk/dev/rd/c0d0 or: fdisk/dev/ida/c0d0 (for raid devices)
....
[root@localhost root]#

What do i type next?

What a way to spend a saturday night!

Just tried using su - as advised, but still no cigar.

Last edited by raging potato; 10-11-2003 at 08:20 PM.
 
Old 10-12-2003, 03:46 AM   #11
raging potato
LQ Newbie
 
Registered: Oct 2003
Location: Ireland
Distribution: Redhat 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
Unhappy



Can anyone who is strong in the force help this young padowan defeat the darkside?

Please?

Pretty please?



Thanks
 
Old 10-12-2003, 05:43 AM   #12
raging potato
LQ Newbie
 
Registered: Oct 2003
Location: Ireland
Distribution: Redhat 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
Ok, I managed to get the fdisk thing to work via a terminal window. Here is a copy of what was put into the terminal and what was fired back at me.

[pheery@localhost pheery]$ Fdisk
bash: fdisk: command not found
[pheery@localhost pheery]$ su -
password:
[root@localhost root]# fdisk -l

Disk /dev/hda : 41.1GB, 41174138880 bytes
255 heads, 63 bad sectors, 5005 cylinders
units= cylinders of 16065 * 512= 8225280 bytes

Device Boot Start End Blocks ID System
/dev/hda1 * 1 5005 40196488+ 7 HPFS/NTFS

Disk /dev/hdb: 13.0GB, 13022324736 bytes
255 heads, 63 sectors/track, 1583 cylinders
Units= cylinders of 16065 * 512= 8225280 bytes

Device Boot Start End Blocks ID System
/dev/hdb1 * 1 13 104391 83 Linux
/dev/hdb2 14 158 12088912+ 83 Linux
/dev/hdb3 1519 1583 522112+ 82 Linux swap


Does this shed any light on the matter?
 
Old 10-12-2003, 11:52 AM   #13
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
hmm, to tell you the truth, your grub.conf seems to match up with grub...

try reinstalling grub, go into a terminal and do su -, then do grub-install /dev/hda

i hope this will fix the problem


*edit: what u will need to remember to do now is to remember to avoid frustration; you've managed thus far, don't worry all will turn out well

*edit 2: if there are no errors reported (it will tell u in the terminal) reboot your computer and see if windows will load now

Last edited by TheOneAndOnlySM; 10-12-2003 at 11:54 AM.
 
Old 10-13-2003, 11:14 AM   #14
raging potato
LQ Newbie
 
Registered: Oct 2003
Location: Ireland
Distribution: Redhat 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
Question

thanks for your patience.
Mine left the building after 6 hours of trying to sort this out yesterday.

to recap, heres what i have been up to. I have tried to break it up to make it easy to digest.

I got this error message when I originally installed redhat, I originally thought that as there was 2 boot managers to choose from, one would work.

"Warning message. Unable to align partition properly. This probably means that another partitioning tool generated an incorrect partition table, because it didn't have the correct BIOS geometry. It is safe to ignore, but ignoring may cause (fixable) problems with some boot loaders."

(i) So I unistalled redhat and chose lilo as the boot manager the 2nd time around.
I did find the error message a tad odd as I put xp on the C:/ as a clean install and there was no partitions on either of my hard drives. As per the installation previously where i chose grub, Redhat detected dos, and it installed as per normal only using lilo this time.


(ii) After installation I was able to get into Redhat fine, but no joy with xp. So I figured it might be lilo (as per error message previously).

(iii) I unistalled lilo, and the computer reverted back to using grub at boot up,

(iv) so then I reinstalled linux without a boot manager, again no success, couldn't get into dos, and i needed a floppy to boot linux.

(v) So i reinstalled linux with grub this time, grub didn't detect Windows when I was installing Redhat. This concerned me, so I manually added 'WindowsXP' to the list of operation systems during installation.

This is where i am now. Strange things are afoot on my computer.
I think I have lost my old C:/.

Here is my current Grub.conf file for your reference.

default = 1
timeout = 10

splashimage(hd1,0)\grub\splash.xpm.gz

Title Redhat Linux (2.420 - 8)
root(hd1,0)
Kernel\vmlinuz - 2.4.20 - 8 ro root = LABEL = \hdc = ide-scsi
initrd\vmlinuz - 2.4.20 - 8.img

Title WindowsXP
rootnoverify (hd1,0)
chainloader +1


I checked my partitions via a terminal, results below.

[pheery@localhost pheery]$ Fdisk
bash: fdisk: command not found
[pheery@localhost pheery]$ su -
password:
[root@localhost root]# fdisk -l

Disk /dev/hda : 41.1GB, 41174138880 bytes
255 heads, 63 sectors/track, 5005 cylinders
units= cylinders of 16065 * 512= 8225280 bytes

Device Boot Start End Blocks ID System


Disk /dev/hdb: 13.0GB, 13022324736 bytes
255 heads, 63 sectors/track, 1583 cylinders
Units= cylinders of 16065 * 512= 8225280 bytes

Device Boot Start End Blocks ID System

/dev/hdb1 * 1 13 104391 83 Linux
/dev/hdb2 14 158 12088912+ 83 Linux
/dev/hdb3 1519 1583 522112+ 82 Linux swap



I used boot floppys to get into my WindowsXP recovery console, I only had access to C:/ and not C:/windows as the instructions would have me beleive.
here is what it told me when i done the map arc command.

C: FAT16 102mb Multi<0>disk<0>rdisk<1>partition<1>
F: 11806mb Multi<0>disk<0>rdisk<1>partition<2>
G: 510mb Multi<0>disk<0>rdisk<1>partition<3>
A: /Device Floppy
D: /Device CDrom0
E: /Device/CDrom1


So the bottom line for me now is, can I get back my windows files?


Thanks for the email.
I tried to uninstall grub as you advised.
No error messages happen, what it does it go into the grub application, it prompts me with

grub>

when i reboot and I choose 'WindowsXP' from my options I get the following chat from my confusing computer.

Booting 'WindowXP'
rootnoverify (hd1,0)
chainloader +1

NTLDR is missing
press any key to restart

(I press any key at this stage)

Disk boot failure, insert system disk to continue.

(I insert my win xp cd at this point)

then it goes into grub, and so it continues.

Hmm...

confused, you will be.

Last edited by raging potato; 10-13-2003 at 11:33 AM.
 
Old 10-13-2003, 11:37 AM   #15
raging potato
LQ Newbie
 
Registered: Oct 2003
Location: Ireland
Distribution: Redhat 9.0
Posts: 12

Original Poster
Rep: Reputation: 0
I think i might just format both drives.

And put each operating system onto each respective drive.
But not install grub or lilo in this case.

Then when I want to go into each operating system, I can go into my advanced bios options and choose what drive to boot up from.

D:/ for redhat.
C:/ for windows xp pro.

would this be a good course of action?
I am on a damage limitation exercise at the moment.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem, dual boot, xp/redhat, cdtray kept ejecting, del redhat part. wont boot a OS mraym84 Linux - General 2 08-22-2004 02:46 PM
I Want To Change From RedHat to SuSE 9.1 in A WinXP Pro. Dual Boot System Raj_Nair Linux - Newbie 3 06-06-2004 01:28 PM
XP Pro will not boot dual boot Redhat 9 one hard drive mamoose Linux - Newbie 10 03-29-2004 09:28 PM
XP Pro SP1+ Redhat 8.0 dual boot problems kaos Linux - Software 8 05-22-2003 04:45 PM
Dual boot XP Pro & Redhat 9.0 joal1923 Linux - Newbie 4 04-22-2003 11:56 PM


All times are GMT -5. The time now is 09:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration