LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-04-2004, 05:02 AM   #1
karfei00
Member
 
Registered: May 2004
Posts: 54

Rep: Reputation: 15
redhat 9 -> usb0 not found


im using redhat 9 kernel 2.4.26 right now.....i have tried to set up a USB connection with a zaurus-5500...but once i type the command # ifup usb0 --> it says that usbnet usb0 does not seem to be present

then i tried with ifconfig -a , it only shows eth0 and lo ......no usb0 there.....what should i do ?

thanks a lot
 
Old 06-04-2004, 10:45 AM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
Hi,
I hesitate to post this because there may be different ways to do this and you are using an old kernel and i have never used a zaurus keyboard:
(preface with i think -- but might be wrong).
you don't access usb that way and it never shows up in ifconfig.
usb has to be initialized at boot and with the propper modules
pointed to in modprobe.conf.
try looking at /proc/bus/usb
see if you have a devices file ??
i think /proc/bus/usb
should be mounted as usbdevfs
after the modules are loaded by the init script.
for red hat i think it would be in rc.sysinit ??
loading the modules should
cause the usb system to be recognized and if a usb device is found proper modules for that device shoud load as well.
look in kernel boot logs.
the modules for my more modern kernel are
(lines from modprobe.conf)
alias usbdevfs usbcore
alias usb-controller uhci-hcd
alias usb-controller1 ehci-hcd
 
Old 06-09-2004, 01:51 AM   #3
karfei00
Member
 
Registered: May 2004
Posts: 54

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by foo_bar_foo
Hi,
I hesitate to post this because there may be different ways to do this and you are using an old kernel and i have never used a zaurus keyboard:
(preface with i think -- but might be wrong).
you don't access usb that way and it never shows up in ifconfig.
usb has to be initialized at boot and with the propper modules
pointed to in modprobe.conf.
try looking at /proc/bus/usb
see if you have a devices file ??
i think /proc/bus/usb
should be mounted as usbdevfs
after the modules are loaded by the init script.
for red hat i think it would be in rc.sysinit ??
loading the modules should
cause the usb system to be recognized and if a usb device is found proper modules for that device shoud load as well.
look in kernel boot logs.
the modules for my more modern kernel are
(lines from modprobe.conf)
alias usbdevfs usbcore
alias usb-controller uhci-hcd
alias usb-controller1 ehci-hcd
i dont have any single files in the proc.bus/usb directory. What should i do?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev/usb0 missing samac Slackware 10 11-11-2010 11:58 PM
MyODBC not found in RedHat 9? moxieman99 Linux - Software 0 09-03-2005 02:22 PM
ifconfig usb0 produces "Broken pipe" JohnKFT Slackware 0 11-13-2004 04:56 PM
Redhat 8 won't boot, say OS not found PLEASE HELP!!!!!!!!!!! aneikei Linux - Newbie 1 09-20-2003 06:54 AM
redhat cd not found strawberry Linux - Software 2 09-19-2001 03:32 PM


All times are GMT -5. The time now is 01:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration