LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-25-2003, 08:21 AM   #1
PionexUser
Member
 
Registered: Jul 2003
Location: Alaska, USA
Distribution: Red Hat 9
Posts: 179

Rep: Reputation: 30
RedHat 9 Partitions


Dang does the search suck!

I just added a 2nd partiton to my harddrive. I think it is hda2, how do I use it?
 
Old 08-25-2003, 08:46 AM   #2
Andy@DP
Member
 
Registered: Aug 2003
Location: Aberdeen, UK.
Distribution: Debian, Ubuntu
Posts: 208
Blog Entries: 2

Rep: Reputation: 30
To use a partition you need to create a mount point in the /mnt/ directory and mount the drive to it. Code below:

mkdir /mnt/partition
mount /dev/hda2 /mnt/partition

The partition name above can be substituted for any name you like. The partition name (hda2) might be wrong.
I created a logical partition on my second drive (hdb) and it was referenced in linux by /dev/hdb5. Try to create the directory and then mount the drive if that command doesn't work substitute hda5 for hda2.
If the partition is on second drive use hdb.

Hope this helps
 
Old 08-25-2003, 08:49 AM   #3
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
use 'fdisk -l' to see all your partitions.
=======================
you can automount partitions during boot up by editing /etc/fstab file.
 
Old 08-25-2003, 08:50 AM   #4
Andy@DP
Member
 
Registered: Aug 2003
Location: Aberdeen, UK.
Distribution: Debian, Ubuntu
Posts: 208
Blog Entries: 2

Rep: Reputation: 30
OH yeah I forgot to add if you want the drive mounted at boot add the following line to your /etc/fstab file. Remember to be in root when you edit.

/dev/hda2 /mnt/partition vfat defaults,umask=0000 0 0

if the drive is fat or fat32

and

/dev/hda2 /mnt/partition ntfs auto, ro, umask =0222 0 0

if the drive is NTFS.

Thats only if the partitions are windows drives!! Not ext2 or ext3 drives!

These two options work fine on my system (RH9/XPpro). Remember to alter hda and partition names to suit your system!

Last edited by Andy@DP; 08-25-2003 at 08:53 AM.
 
Old 08-25-2003, 08:57 AM   #5
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
you cant mount ntfs that easily.


download and install the rpm for ntfs support.


http://linux-ntfs.sourceforge.net/info/redhat.html
======================
if in doubt,check 'man mount'
 
Old 08-25-2003, 08:59 AM   #6
PionexUser
Member
 
Registered: Jul 2003
Location: Alaska, USA
Distribution: Red Hat 9
Posts: 179

Original Poster
Rep: Reputation: 30
Quote:
[root@localhost hubcaps]# mount /dev/hda2 /mnt/partition
mount: you must specify the filesystem type
??????????
 
Old 08-25-2003, 09:01 AM   #7
Andy@DP
Member
 
Registered: Aug 2003
Location: Aberdeen, UK.
Distribution: Debian, Ubuntu
Posts: 208
Blog Entries: 2

Rep: Reputation: 30
Sorry, I forgot about the rpm! Doh !!
Another post on forum forgot to mention that too and its hardcopy is sitting next to me!
 
Old 08-25-2003, 09:02 AM   #8
PionexUser
Member
 
Registered: Jul 2003
Location: Alaska, USA
Distribution: Red Hat 9
Posts: 179

Original Poster
Rep: Reputation: 30
its a Linux partition not a fat32 or ntfs ..........
 
Old 08-25-2003, 09:02 AM   #9
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
try
mount -t <filesystem type> /dev/(fill this) /mnt/(fill this)
to see the file system type etc.try 'man mount'.
I am saying this cos' you have not mentiones which partition are you going to mount.also,try 'fdisk -l' to see all partitions.
 
Old 08-25-2003, 09:06 AM   #10
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
sorry,i was a bit late in the above post.
===========
if that was a linux partition,try 'cat /proc/partitions' or 'fdisk -l' to see the partition.
and then change directory to the partition.(ie cd <partition name>)
 
Old 08-25-2003, 09:17 AM   #11
PionexUser
Member
 
Registered: Jul 2003
Location: Alaska, USA
Distribution: Red Hat 9
Posts: 179

Original Poster
Rep: Reputation: 30
Filesystem type? Does that mean "system" in fdisk?

Would this work
mount -t linux /dev/hda2 /mnt/partition
 
Old 08-25-2003, 09:22 AM   #12
PionexUser
Member
 
Registered: Jul 2003
Location: Alaska, USA
Distribution: Red Hat 9
Posts: 179

Original Poster
Rep: Reputation: 30
Quote:
[root@localhost hubcaps]# mount -t linux /dev/hda2 /mnt/partition
mount: fs type linux not supported by kernel
WTF is a "FileSystem Type"
 
Old 08-25-2003, 09:29 AM   #13
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
no,try replacing linux with 'ext3' or 'ext2'





======
to explain filesystem types and all,i just hit the google and got the following links. http://www.linuxgeek.net/beginners/node258.html
http://www.linuxplanet.com/linuxplan...orials/3174/8/
=====================





try 'df' to see whether your partition is already mounted.

Last edited by arunshivanandan; 08-25-2003 at 09:31 AM.
 
Old 08-25-2003, 09:42 AM   #14
PionexUser
Member
 
Registered: Jul 2003
Location: Alaska, USA
Distribution: Red Hat 9
Posts: 179

Original Poster
Rep: Reputation: 30
Quote:
[root@localhost hubcaps]# mount -t ext2 /dev/hda2 /mnt/partition
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
or too many mounted file systems
[root@localhost hubcaps]# mount -t ext3 /dev/hda2 /mnt/partition
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
or too many mounted file systems
BUTT CRACK!

What now?
 
Old 08-25-2003, 09:44 AM   #15
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
are you sure that it is /dev/hda2 ??what was the output of 'fdisk -l'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Viewing Windows partitions in Redhat 8 lucid Linux - Distributions 5 06-08-2005 12:16 AM
Reading Windows Partitions on RedHat blahblah2k3 Linux - Hardware 1 03-15-2004 06:10 PM
Troubles with FAT32 partitions in Redhat 9.0 Nychold Linux - Newbie 5 03-04-2004 11:07 AM
Redhat partitions inode100 Linux - Newbie 10 11-21-2003 02:43 PM
Linux Redhat Partitions Hesperuax Linux - General 4 04-07-2003 11:10 PM


All times are GMT -5. The time now is 02:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration