LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-18-2003, 01:22 AM   #1
eastj1974
Member
 
Registered: Feb 2003
Location: Los Angeles
Distribution: Red Hat 8.0
Posts: 68

Rep: Reputation: 15
Unhappy RedHat 8.0 Sound Issue


I'm running Redhat 8.0 and I can't get sound. I running the 2.4.18-24.8.0 linux kernel. I have two sound cards that aren't running properly. I have an onboard soundcard on my asus p4pe (i810_audio). I also have Creative's Audigy2. I installed the audigy2 driver from Creative's open source website (EMU10K1 version .20a). I also confirmed that the soundcore and sound modules were running. They recognized both the i810_audio as well as the audigy cards. I also confirmed that the audigy and i810_audio modules existed using the lsmod command. Sound has never worked on my system --- even before I installed audigy. That makes me think that I have a system issue. Can anyone please help me???????????

Oh ya, i confirmed that /etc/modules.conf has alias for both audigy and i810_audio. I used the dmesg command to find what was recognized on boot up. Both cards were listed. I would greatly appreciate any help. Thanks, J
 
Old 02-18-2003, 01:52 AM   #2
nakkaya
LQ Guru
 
Registered: Jan 2003
Location: Turkey&USA
Distribution: Emacs and linux is its device driver(Slackware,redhat)
Posts: 1,398

Rep: Reputation: 45
maybe you can try removing the cards and try them one by one cause may be they effect each other
 
Old 02-18-2003, 07:25 PM   #3
eastj1974
Member
 
Registered: Feb 2003
Location: Los Angeles
Distribution: Red Hat 8.0
Posts: 68

Original Poster
Rep: Reputation: 15
Ya, I removed the audigy card and it did not work. I don't know how to disable the card built into the motherboard. I did disable its loadable module though and that didn't work either. J
 
Old 02-18-2003, 09:10 PM   #4
japple
LQ Newbie
 
Registered: Jan 2002
Location: North Florida USA
Distribution: Mandrake 9.0, Vector 3.2, Slack 8.1
Posts: 15

Rep: Reputation: 0
I had the same issue with a RH 8.0 machine. Tried everything: updated drivers, swapped sound cards, et. al.

I accidentally plugged the speakers into the wrong outlet on the sound card one night and there it was --sound. This is not the same outlet is used when the machine was running RH 7.2 or way long ago when it had WIN 98.

I wish I could tell you the exact output ( spkr or whatever) but I can't. I use cheap soundblaster cards and buy them in bulk. I don't have a manual.
 
Old 02-18-2003, 11:12 PM   #5
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Is Plug 'n Play disabled in the BIOS? If not, try disabling it. Let us know.
 
Old 02-19-2003, 04:12 AM   #6
subservant
Member
 
Registered: Feb 2003
Location: Portland , Oregon
Distribution: Red Hat 8.0
Posts: 91

Rep: Reputation: 15
what type of speaker settings do you need ? Analog or digital ?

you also want to make shure you have the tool set installed that comes with the emu10k1 drivers
 
Old 02-19-2003, 09:43 PM   #7
WheatPuppet
LQ Newbie
 
Registered: Feb 2003
Location: State, you ask? Denial.
Distribution: Mandrake 9.2
Posts: 23

Rep: Reputation: 15
My bet is with subservant. I thought that my sound was dead until I had the bright thought to plug in some analog headphones. I imagine that Audigy cards are like Creative's Live! cards in that they output digital and analog through the same port, which Linux doesn't support (or so I hear). I guess you're relegated to analog sound until someone figures it out.
 
Old 02-20-2003, 01:35 AM   #8
eastj1974
Member
 
Registered: Feb 2003
Location: Los Angeles
Distribution: Red Hat 8.0
Posts: 68

Original Poster
Rep: Reputation: 15
Ya looked in my bios. Plug and play was already disabled. Thanks, though.
 
Old 02-20-2003, 02:29 AM   #9
eastj1974
Member
 
Registered: Feb 2003
Location: Los Angeles
Distribution: Red Hat 8.0
Posts: 68

Original Poster
Rep: Reputation: 15
i also installed the emu-tools and tried to the tool configuring script "emu-script" It allowed me to specify either analog or digital. I tried both options but I did receive an error. "SOUND_MIXER_PRIVATE3: You're probably using an older incompatible driver: Invalid argument". THe error confused me because I've only installed the latest version of the driver. I'm still a little confused about the difference between analog and digital. I just thought of it as analog -tape, digital -cd. I don't know what analog headphones are unless almost all headphones are analog. If all headphones are, I tried it and it didn't work. I appreciate the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
9.2 Sound issue thesonic1 SUSE / openSUSE 6 10-02-2005 12:36 PM
Sound Issue Savahn Linux - Software 0 01-26-2005 09:31 PM
Another sound issue...10.1 piagetblix Mandriva 3 10-18-2004 07:11 PM
Sound issue Borje Debian 8 09-26-2004 05:39 PM
Redhat 9.0 sound issue iamnamja Linux - Software 18 09-30-2003 12:46 AM


All times are GMT -5. The time now is 02:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration