LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-19-2002, 06:20 PM   #1
Furtzi
LQ Newbie
 
Registered: Feb 2002
Location: Finland/NokiaLand
Distribution: GNU/Linux Redhat 7.2
Posts: 9

Rep: Reputation: 0
Redhat 7.2 + Grub + Windows ME


hello everybody, i am new at this forum. So lets get to bisness

I have Windows Millenium and Linux Redhat 7.2 installed and i got little problem how to get booted with Grub. I have linux on my second hard-disk 40Gb Maxtor, and Windows on my first hard-disk 40Gb Maxtor too, and Windows disks is master. I have read somekind of GRUB howto's from internet and linuxdoc.org but nowhere aint separate hard-disks boot sayd. This text includes lots of mistakes.

Thanks for the people who can help me.
 
Old 02-20-2002, 12:26 AM   #2
xcon
Member
 
Registered: Jan 2002
Location: Ohio
Distribution: Slackware 9.1 (and some 9.0)
Posts: 181

Rep: Reputation: 30
good thing, too. if you had to reinstall winME ever on only one disk with linux partitions, it would probably demand that they be deleted.

it's not too hard, just remember
windows=(hd0) or /dev/hda
linux =(hd1) or /dev/hdb

in grub/grub.conf, you'll see

title Red Hat Linux ## #### (version numbers)
root (hd1,#)/boot/vmlinuz...kernel....params... etc.
initrd.... more stuff.... lots of stuff....

title DOS
rootnoverify (hd#,#)
chainloader +1

so change DOS to say Windows ME or whatever you like, and make sure the rootnoverify has (hd0,0) after it... keep chainloader +1 too

also, there may be a small hidden partition at the beginning of your primary master (winME) disk, that's (hd0,0) so if it doesn't work try (hd0,1) which will be your actual C:\

if that doesn't help, tell us:

do you have separate boot - root - usr - var - home - tmp partitions?

and when you installed grub, did you have it go onto /dev/hda 's MBR or onto /dev/hdb# (#is linux boot) ???
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSE 9.1 and Windows Xp refuse to live in harmony: error loading windows through GRUB sanctumtacete Linux - Newbie 3 10-19-2004 08:47 AM
Dual booting redhat 9 with windows XP using GRUB TechnoBod Linux - Software 2 07-09-2003 07:58 AM
Windows, Redhat, Grub and a Promise card DigitalTygrrr Linux - Newbie 9 04-28-2003 03:28 PM
Redhat / Windows XP / Grub question bmar Linux - General 3 04-07-2003 02:32 PM
Boot windows 98,windows XP and linux by GRUB Swift&Smart Linux - General 6 02-22-2003 10:11 AM


All times are GMT -5. The time now is 10:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration