LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-13-2011, 09:34 AM   #1
sarveshs3
LQ Newbie
 
Registered: Oct 2011
Posts: 4

Rep: Reputation: Disabled
Red Hat Squirrelmail problem


Hiii....I had configured a mail server with squirrelmail 1.4.22.I am able to log in squirrelmail and able to receive mails but when I try to send mails from squirrelmail it appears as the mail is sent but its not delivered to the recipient. Even I am not receiving a "Message Delievery Failed" error nor there are any logs. Any ideas please?
 
Old 10-15-2011, 11:13 AM   #2
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,194
Blog Entries: 4

Rep: Reputation: 221Reputation: 221Reputation: 221
It seems your smtp server is not configure properly

which smtp server are you using?

Are you trying to send mails within your domain or outside?

are you able to send and receive mails in command line?

in squirrel mail you won't receive a mail delivery status message so you will have to use any other mail server on command line to check for error logs.
 
Old 10-15-2011, 11:34 AM   #3
sarveshs3
LQ Newbie
 
Registered: Oct 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Hiii..... I am using Sendmail as SMTP. I have tried both to send mails within my domain as well as outside.I can receive mails from both.But I can send and receive in my outlook.
 
Old 10-15-2011, 12:03 PM   #4
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,194
Blog Entries: 4

Rep: Reputation: 221Reputation: 221Reputation: 221
reply
Code:
I have tried both to send mails within my domain as well as outside.I can receive mails from both.But I can send and receive in my outlook.

sorry I didn't get your problem exactly?
You are saying that you are able to receive mails but unable to send?

what is your imap server?
can you please elaborate?
 
Old 10-15-2011, 12:18 PM   #5
sarveshs3
LQ Newbie
 
Registered: Oct 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
i am trying to send mails to my domain as well as outside my domain. But its not working. For receiving the mails, I dont have any problems. Receiving the mail is not problem only I am not able to send it when I log in my squirrelmail login. Also I have configured the mail account in outlook.In outlook I am able to send and receive mails.
 
Old 10-15-2011, 12:55 PM   #6
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,194
Blog Entries: 4

Rep: Reputation: 221Reputation: 221Reputation: 221
use this command from command line

Code:
#sendmail -v (email-id of sender)
and check the output status and /var/log/messages and post them

also post your sendmail.mc file
 
Old 10-18-2011, 01:35 AM   #7
sarveshs3
LQ Newbie
 
Registered: Oct 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Hey problem is solved.....it just happened some problems in sendmail.mc file
Just checked it and corrected the same, started working.
Thank You very much.
 
Old 10-18-2011, 03:13 AM   #8
linuxwin2
Member
 
Registered: Oct 2011
Posts: 44

Rep: Reputation: Disabled
Good
Please mark this topic are SOLVED in title.
 
Old 10-18-2011, 01:50 PM   #9
rudyh
LQ Newbie
 
Registered: Jul 2009
Posts: 3

Rep: Reputation: 0
Just wanted to make a quick note, I came here with the same problem, different solution. Everything was working, then it stopped sending and would still receive.

Found the DNS server we were using changed to a different IP address and the old server went down. We had the DNS listed as an IP address and not a name. Once the IP was changed in our configs, restarted the network, things started working again.

Simple fix, but still had to find it. All the posts within this forum stimulated the thought process in finding the solution.

In case someone else is searching for the same issues, this could be an alternate cause.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install Squirrelmail in Red Hat anu_here Linux - Software 2 09-17-2008 11:30 PM
Red Hat & Squirrelmail JJX Red Hat 12 08-04-2008 10:02 AM
Red Hat cer 4 squirrelmail issue andre418 Linux - Software 0 06-22-2005 11:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration