LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Red Hat Ent 4 Install to get dual boot w/ Windows XP (http://www.linuxquestions.org/questions/linux-newbie-8/red-hat-ent-4-install-to-get-dual-boot-w-windows-xp-560580/)

raferb 06-10-2007 02:12 AM

Red Hat Ent 4 Install to get dual boot w/ Windows XP
 
I installed RH ENT 4 on a system with XP already installed on a single physical HD, but with 2 partitions (RH going on the second partition).

After the RH install I don't have any option to boot into back into Windows XP. Did I botch something up? What can do I do now?

stzein 06-10-2007 02:33 AM

If your windows partition is still ok, you probably just have to set it in your boot manager. I'll give you a short instruction on how to do this if you run grub, if you have another boot manager (probably lilo then), google yourself some manual.

for grub:
edit the file grub.conf as root (/etc/grub.conf or /boot/grub/grub.conf or whatever... try 'find / -name "grub.conf"')
paste the following on the bottom of the file:

Code:

title=windows
rootnoverify (hd0,0)
makeactive
chainloader +1

then check this line:
Code:

timeout X
The X is the time your boot loader will wait before booting the default, make sure it's an appropriate value.

raferb 06-10-2007 01:57 PM

After adding a 'windows' section to the grub.conf and increasing the timeout to 30 seconds (up from the short 5 it was previously) The boot menu is now giving me 30 seconds but no windows boot option. It just says "Hit any key to enter menu" and that in x seconds it's going to boot into linux. Hitting a key does nothing during the count down, maybe that is my problem. Are the USB drivers not loaded yet during the countdown so that my keyboard isn't recognized, and because of that I've never seen the 'other' boot options yet?

raferb 06-10-2007 02:12 PM

More info....
I set "default=2" (where 2=the line title=windows section) and then successfully booted into windows. So apparently I didn't botch the install to get a dual boot. I probably could have done the same thing prior to adding the windows section to the grub.conf, but pointing 'default' to the "other" section.

So, my problem is invoking the boot options to appear (by hitting any key) because my USB keyboard is not recognized at that stage yet. Any remedy for this?

raferb 06-10-2007 02:38 PM

I found the solution to the keyboard problem on fedoraforum.org "Fedora 7 install - keyboard/mouse doesn't work at Welcome screen" I changed my BIOS setting for USB Keyboard from 'OS' to 'BIOS' and that did the trick.

stzein 06-10-2007 02:39 PM

Quote:

my USB keyboard is not recognized at that stage
The easiest solution for that would be to find a usb-to-PS2 convertor; many usb keyboards and mice come with one by default. Maybe you can steal your mouse's convertor piece? If you don't have PS2 ports this won't help you obviously...
Maybe you could check your bios for more usb support. At such an early stage in the boot process I think that is the only place that really matters.

Also, could you maybe post your grub.conf? I think it possibly can be improved upon still :cool:


EDIT: heh, it seems I was too slow. Happy that your problem is solved :)


All times are GMT -5. The time now is 12:37 PM.