LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-08-2011, 12:20 AM   #1
falmdavis
Member
 
Registered: Jul 2010
Posts: 56

Rep: Reputation: 15
Unhappy Recording sound with PulseAudio from Line-In and Microphone, not working


Would like some help to get sound input to work so that can record from line-in and from microphone using PulseAudio sound server with Gnome Sound Recorder 2.30.0. From installation of Suse 11.3.

Problem recording sound with gnome-sound-recorder 2.30.0. Trying to use both line-in and microphone. Neither shows up as selectable in gnome-sound-recorder. The only choice for device in gnome-sound-recorder is "capture", but it is not recording any sound. Using pulseaudio, and have all installed:

Quote:
pavucontrol, pavumeter, paprefs, paman, pacat, pacmd, pactl, padevchooser, pamon, paplay, parec, parecord.
Also have the pa esd support installed which links /usr/bin/esd to esdcompat.

When connecting a sound source to the line-in of the sound card, get output to the headphone jack. Pulseaudio shows nothing in the meter for pavumeter. Muting volume does not change volume output from line-in to the headphones. Sound output in Banshee is working, and opening a wav file in gnome-sound-recorder gives sound output for the wav file.

Code:
LANG=C pactl list | grep -A2 'Source #' | grep 'Name: ' | cut -d " " -f2
Code:
combined.monitor
alsa_output.pci-0000_00_11.5.analog-stereo.monitor
alsa_input.pci-0000_00_11.5.analog-stereo
Trying the alsa_input as a "PULSE_SOURCE=alsa_input..." to gnome-sound-recorder gives no sound recording from line-in or mic.

From Pulseaudio Volume Control, the recording tab shows "no application is currently recording audio" but will show gnome-sound-recorder when trying to record from it; configuration is set to "analong stereo duplex". Input devices shows: "monitor of source of simultaneous output to internal audio analog stereo" and "monitor of internal audio analog stereo". Both input devices show no sound coming in while sound is connected to line-in and playing on the headphones.

From Pulseaudio FAQ, www.pulseaudio.org, considered audio group 2, which uses HAL and console kit to dynamically give access to currently active user.

Code:
cat /proc/modules | grep snd
Code:
snd_pcm_oss 47613 0 - Live 0xf7c31000
snd_mixer_oss 16751 1 snd_pcm_oss, Live 0xf7bfa000
snd_seq 57343 0 - Live 0xf7be4000
snd_via82xx 22603 3 - Live 0xfacd4000
snd_ac97_codec 106049 1 snd_via82xx, Live 0xfacab000
ac97_bus 1066 1 snd_ac97_codec, Live 0xfa06d000
snd_pcm 87978 4 snd_pcm_oss,snd_via82xx,snd_ac97_codec, Live 0xfa049000
snd_timer 21669 2 snd_seq,snd_pcm, Live 0xfa01d000
snd_page_alloc 8041 2 snd_via82xx,snd_pcm, Live 0xfa00b000
snd_mpu401_uart 6929 1 snd_via82xx, Live 0xf8ffd000
snd_rawmidi 22277 1 snd_mpu401_uart, Live 0xf8fdb000
snd_seq_device 6566 2 snd_seq,snd_rawmidi, Live 0xf877d000
gameport 10289 3 snd_via82xx,ns558, Live 0xf81ec000
snd 65724 15 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_via82xx,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device, Live 0xf8170000
soundcore 7379 1 snd, Live 0xf8030000
 
Old 01-08-2011, 02:56 PM   #2
falmdavis
Member
 
Registered: Jul 2010
Posts: 56

Original Poster
Rep: Reputation: 15
After nearly 30 hours of trying to get line-in and microphone to work with Pulseaudio, I gave up in frustration and sent Pulseaudio to the crapper. It worked for audio output, but failed on audio input. Tried all the settings that I could think of. Tried what pulseaudio web sites said to try. Could have been a simple setting. Really expected sound to work out of the box with Pulseaudio like it did before with alsa.

Went back to alsa. Deleted all Pulseaudio and added alsa and esound for gnome. After 2 hours, it works for line-in. Have not checked microphone yet, but it should be working too. The alsa mixer gui looks like it uses really old graphics. Hasn't it been updated to reflect the newer Linux guis?

But now the speaker icon on the gnome panel has disappeared, that used to allow adjusting the sound level. Right clicking the panel to "add to panel" only has a different "volume adjuster" icon that is deprecated and does nothing if you try to add it. How do I get the original gnome volume control icon back? And, there was a problem with the gnome panel volume control icon, it only went up to 100%, which resulted in low volume, and opening the gnome sound utility allowed adjusting the volume up to 150% with amplifier control, and then the gnome panel would show it as 150% with a pop-up and right clicking it would allow you to either mute the sound or edit sound preferences (where you could adjust it up to 150%).

I would still like to figure out how to get Pulseaudio to work for sound input with line-in and microphone. Have other Linux users been able to get it to work? It could just be a simple setting that I had wrong.
 
Old 01-08-2011, 07:50 PM   #3
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,435

Rep: Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406
Quote:
Originally Posted by falmdavis View Post
The alsa mixer gui looks like it uses really old graphics. Hasn't it been updated to reflect the newer Linux guis?
Alsa uses an ncurses interface. The plus is that you can have the ncurses graphical interface without starting a GUI. For those of us who don't like or need to use a window manager for everything all the time, this means we can configure ALSA easily from the command line.

I consider that a plus.

I have had trouble with pulse on some computers. I don't consider it ready for prime time. I've never had problems with alsa.

There's a difference between cutting edge and over the edge.
 
Old 01-12-2011, 10:32 AM   #4
falmdavis
Member
 
Registered: Jul 2010
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by frankbell View Post
Alsa uses an ncurses interface. The plus is that you can have the ncurses graphical interface without starting a GUI.
You mean running
Code:
$ alsamixer
from the command line. Hadn't thought about it using ncurses. I've used that form of alsamixer, although I was talking about the alsamixer gui application.

Quote:
There's a difference between cutting edge and over the edge.
Pulse audio did have a lot of nice features about it, but if it does not work what good is it, right? Has anyone been able to get PulseAudio to work with Line-in and Microphone? And if so, what settings did you use...it could be I had the wrong settings.

One bad part about Linux sound, is that the volume levels have always seemed very low compared to the same system with windows. Have not found a solution to this. It seems that the sound driver sound levels are mixed up in Linux. While it is not part of this post, I thought that I'd mention it as PulseAudio is supposed to be the next great thing for sound in Linux.
 
Old 03-26-2012, 07:03 PM   #5
jmlm_1970
Member
 
Registered: Nov 2010
Location: Aveiro, Portugal, Europe
Posts: 38
Blog Entries: 1

Rep: Reputation: 1
How to make microphone work!

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).
 
  


Reply

Tags
microphone, pulseaudio


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microphone Working, Sound playing back, Sound Not Recording (Gentoo 2.6.29) kingzog Linux - Software 3 04-23-2009 09:09 PM
Recording sound from a microphone Mickald Dreamlinux 3 12-19-2008 12:51 PM
trying to get microphone working for voip and recording FC6 gimmee Fedora 3 01-30-2007 02:37 AM
Fedora Core 6 not recording sound from microphone Chuong Linux - Software 6 12-05-2006 12:52 PM
No sound recording from microphone ihatejunk1 Linux - Software 1 03-14-2005 02:11 AM


All times are GMT -5. The time now is 11:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration