LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-08-2004, 02:12 AM   #1
david7812
LQ Newbie
 
Registered: Nov 2004
Posts: 4

Rep: Reputation: 0
Reboot on Shutdown


Hi,

I recently did a new installation of SuSE 9.2 Pro on my laptop (Acer Ferrari 3000), which now is a dualboot system (together with Windows XP).

At my very first shutdown a problem emerged which has followed me since -- when trying to shutdown, e.g., by using commands like "shutdown -h now", "halt", "poweroff", or "Logout -- Turn of Computer" from the KDE menu, my system insists on reboot at the end of the process.

To shutdown "correctly" I have to reboot into Windows XP from GRUB, and do it here. It works fine, but still, it's quite annoying.

Anyone who has got a few ideas about how to resolve this? They would be really appreciated!

Regards,
David
 
Old 11-08-2004, 02:51 AM   #2
Frustin
Member
 
Registered: May 2002
Location: Essex, UK
Distribution: Debian, Redhat, AIX 5L
Posts: 512

Rep: Reputation: 30
Quote:
my system insists on reboot at the end of the process.
do you mean it doesnt power off? can you ellaborate please.
 
Old 11-08-2004, 02:53 AM   #3
ror
Member
 
Registered: May 2004
Distribution: Ubuntu
Posts: 583

Rep: Reputation: 33
try disabling APM, you'll actually have to manually power-off but then at least it shouldnt' be rebooting.
 
Old 11-08-2004, 03:08 AM   #4
david7812
LQ Newbie
 
Registered: Nov 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for your replies!

I meant that the computer simply reboots instead of shutdown (the process I mentioned was the "shutdown process").

How do I go about to disable APM? Can I do that from a terminal? A manual power-off is OK, at least if you mean it like typing, e.g., "halt", and then finish off with pressing the power-button.

Regards,
David
 
Old 11-08-2004, 03:13 AM   #5
ror
Member
 
Registered: May 2004
Distribution: Ubuntu
Posts: 583

Rep: Reputation: 33
head over to /etc/rc.d/rc.modules and recomment up
/sbin/modprobe apm
 
Old 11-08-2004, 05:24 AM   #6
david7812
LQ Newbie
 
Registered: Nov 2004
Posts: 4

Original Poster
Rep: Reputation: 0
I found the directory "/etc/rc.d/", but have no subdirectory "rc.modules". Only a number of "rc0.d", "rc1.d", ..., "rc6.d" subdirectories. However, I tried something else, namely giving the "boot options":

apm=off
acpi=off
apm=off acpi=on
apm=on acpi=off

but it's the same story. When the computer is shutting down, at the end I get the message "The system will be halted immediately", but right afterwards it reboots anyway. Giving the line:

apm=off acpi=off

makes the machine hang instead. I get:

The system will be halted immediately
Master Resource Control: runlevel 0 has been: reached
Skipped services in runlevel 0: nfs

and nothing more happens.

Don't know if this information helps anyone to help me... but I hope so! :-)

Regards,
David
 
Old 11-08-2004, 06:07 AM   #7
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Quote:
Originally posted by david7812


apm=off acpi=off

makes the machine hang instead. I get:

The system will be halted immediately
Master Resource Control: runlevel 0 has been: reached
Skipped services in runlevel 0: nfs

When you manually power down at this point, when you reboot does it force a fsck? If not - I think that did it. The machine appears as though it's been shut down. Simply hit the power button. Runlevel 0 is system halt.
 
Old 11-08-2004, 06:17 AM   #8
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 56
rc.modules is a file, not a directory.

Edit the file /etc/rc.d/rc.modules
comment out said entry.
 
Old 11-08-2004, 07:31 AM   #9
david7812
LQ Newbie
 
Registered: Nov 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Again -- thanks for your replies!

No, there is no forced FSCK at boot, at least I can't recognize one. The system starts as usual. Perhaps that did the trick after all? There are no other concerns to disabling APM and ACPI?

There seems to be no such file "rc.modules" in that directory "/etc/rc.d/". At least I can't find one using "ls -la". Is it possible to automate the APM and ACPI disabling in some other way?

Regards,
David
 
Old 11-08-2004, 12:01 PM   #10
ror
Member
 
Registered: May 2004
Distribution: Ubuntu
Posts: 583

Rep: Reputation: 33
locate rc.modules it should be somewhere
 
Old 11-19-2004, 04:14 PM   #11
patch_linams
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
hi!

i had the same problem on my laptop (Acer Ferrari 3000). it's an ACPI bug:

http://bugme.osdl.org/show_bug.cgi?id=3669

There is a patch available:

http://bugme.osdl.org/attachment.cgi...34&action=view

Have fun
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
shutdown but no reboot alma Suse/Novell 2 11-17-2005 11:11 PM
shutdown -h causes reboot obrienj Red Hat 1 09-11-2005 09:52 PM
help with shutdown and reboot Paxmaster Fedora 2 09-26-2004 04:01 PM
reboot + shutdown :( zulik Slackware 12 05-31-2004 01:36 AM
Immediate shutdown/reboot Creep Linux - Hardware 4 03-07-2004 04:56 AM


All times are GMT -5. The time now is 07:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration