LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-16-2010, 07:54 AM   #1
TaoStar50
LQ Newbie
 
Registered: Jun 2010
Posts: 6

Rep: Reputation: 0
reboot low graphics mode screen shut off problem


Okay, the problem is twofold and it's driving me nuts.

To start with, if I don't use the computer for a length of time, the screen goes black and I have to reboot. Now, I've shut off (as far as I know) the screensaver, the power management is set to not shut off the screen but either I've got those settings wrong or I'm missing one? I like to set my puter to watch a video at night to fall asleep to but before the movie is done, it goes black (and I have to reboot).

And that leads to the second problem; when I reboot, 1/2 to 3/4 of the time, I get the dreaded "Ubuntu is in low graphics mode" question.

Except that it's not. If I continue on with that window, I can select one of the options and go on from there. But if I reboot a (random) number of times, my 3D/high graphics comes back and works fine. I'm currently using the 195 driver from the repos.

Running glxinfo when the system boots the way it should, I get:

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
(etc, etc)

I'm running Helena and my system is:

AMD Phenom II Quad Core 3.0 processor
4G DDR3
nVidia GeForce 6600
 
Old 08-16-2010, 05:11 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,770

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
Quote:
To start with, if I don't use the computer for a length of time, the screen goes black and I have to reboot. Now, I've shut off (as far as I know) the screensaver, the power management is set to not shut off the screen but either I've got those settings wrong or I'm missing one? I like to set my puter to watch a video at night to fall asleep to but before the movie is done, it goes black (and I have to reboot).
No. You don't have to reboot. Linux systems are not Micro$oft. You don't have to reboot, except in exceptional occasions such as kernel updates.

You may not have a screensaver selected, in which case the default is a black screen, when the idle time has expired. Go back into the screensaver setup. Look for the option for setting the idle time before the screensaver is activated. Either set the time for a couple of hours, or never (if that option is available).

When the screen goes black, just move the mouse and wait a second or two. The screen should reactivate. If it doesn't, press ctrl+alt+backspace to restart the X server (reboot is definitely NOT required).

On restarting the X server, you will have to log in.

Last edited by bigrigdriver; 08-16-2010 at 05:29 PM.
 
Old 08-17-2010, 09:11 AM   #3
TaoStar50
LQ Newbie
 
Registered: Jun 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Um. I realize it's not Windows.

Anyway, yes, I DO have to reboot. Moving the mouse does nothing. The screen either locks up or I'm unable to access something because moving the mouse doesn't do anything.

I should have said in the orignal post that I've already set the screensaver time for max and changed the performance options. That's my problem. Every option I'm aware of, I've altered and it still shuts off the screen. Ctrl-alt-backspace was deprecated from Linux Mint a while back so that doesn't do me any good.
 
Old 08-17-2010, 09:25 AM   #4
fbobraga
Member
 
Registered: Jul 2010
Location: São Paulo - Brasil
Distribution: Fedora 17 amd64 / Fedora 17 i686 LXDE (w e17)
Posts: 229

Rep: Reputation: 41
Quote:
Originally Posted by TaoStar50 View Post
(...) if I don't use the computer for a length of time, the screen goes black and I have to reboot. (...)
when this occurs, you can access the shell trough Ctrl+F[1-6]?
 
Old 08-17-2010, 12:22 PM   #5
TaoStar50
LQ Newbie
 
Registered: Jun 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Sorry, was afk. I don't know but I'll try it next time it happens. I'm not sure if that would make a difference since the screen is black and I can't see anything either being typed or displayed.
 
Old 08-19-2010, 06:35 AM   #6
TaoStar50
LQ Newbie
 
Registered: Jun 2010
Posts: 6

Original Poster
Rep: Reputation: 0
No, that didn't make any difference. I tried both ctrl+F(1-6) and even alt-ctrl-F(1-6). Nothing happened. What's also frustrating is that afaik, I've shut off every option to disable the screen. Yet, watching a news video last night, it got most of the way through (around 10 minutes or so), then the screen went black again. It came right back when I moved the mouse and everything was okay that time.

So, I'm thinking there's two settings here that aren't right. The first is the one that shuts off the display after 10 minutes or so of non-activity. The second is the one that locks the computer after an hour or so of non-activity. I've had a web site radio station playing while I read and it plays for like an hour or so then "freezes" again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Low graphics mode due to NVIDIA kernel not loading... NiaNok Linux - Hardware 17 06-01-2010 02:22 AM
Running in low graphics mode - nvidia GeForce 7600, Ubuntu 8.04 Loxodonte Linux - Hardware 2 03-04-2010 12:36 PM
Ubuntu is running in low graphics mode vibinlakshman Ubuntu 4 02-23-2010 10:40 AM
I have no Shut Down or Reboot options on screen, only Sleep and Hibernate ddclutch Linux - Newbie 30 12-06-2008 10:25 AM
Black Screen on reboot after enabling graphics Dugon143 Linux - Newbie 11 10-14-2007 12:51 PM


All times are GMT -5. The time now is 02:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration