LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-31-2004, 09:25 AM   #1
tiluu
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Rep: Reputation: 0
reboot error after new kernel compile


I am installing a new kernel of version 2.4.22 on Red Hat 8.0
I did steps make mrproper, make xconfig, make dep, make bzImage, make modules, make modules_install. All went fine.
I copied bzImage to /boot/bzImage-2.4.22 and System.map to
/boot/System.map-2.4.22

My lilo.conf looks like this

=====================================================
Prompt
Timeout = 50
Default = 2.4.18-14.9
boot = /dev/hda
map = /boot/boot.b
message = /boot/message
lba32


image= /boot/bzImage-2.4.22
label = 2.4.22
initrd=/boot/initrd-2.4.22.img
read only
append = “root=/dev/hda2”


image= /boot/bzImage-2.4.18-14
label = linux
initrd=/boot/initrd-2.4.18-14.9.img
read only
append = “root=/dev/hda2”

=====================================================

during reboot I got the following error.

Kernel panic: VFS:Unable to mount root fs on 03:00


BR,
Mani
 
Old 05-31-2004, 11:08 AM   #2
peacebwitchu
Member
 
Registered: Apr 2004
Distribution: Debian
Posts: 185

Rep: Reputation: 30
Did you make the initrd file and place it in /boot?

Last edited by peacebwitchu; 05-31-2004 at 11:09 AM.
 
Old 06-01-2004, 04:32 AM   #3
tiluu
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks for your reply.Yes i did make the initrd image with command

mkinitrd initrd-2.4.22.img 2.4.22

which made the image in /boot.I also mentioned this in my lilo.conf

Is my problem has anything to do with SCSI drivers? Should i try to compile
those drivers a s part of my kernel rather than modules? In that case i wont
need initrd

Thanks in advance

BR,
Tiluu
 
Old 06-01-2004, 05:38 AM   #4
carraya
LQ Newbie
 
Registered: May 2004
Posts: 10

Rep: Reputation: 0
you need to load the SCSI modules before it can use the scsi harddrive, so it would be better if the scsi driver was part of your kernel if you use a scsi drive to boot on...
 
Old 06-01-2004, 11:43 AM   #5
tiluu
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
I made the SCSI options in configuration files as 'y', compile the kernel again but again got the same error.
During the boot process i also got the following error messgae

kmod:failed to exec /sbin/modprobe -s -k scsi-host adopter
 
Old 06-01-2004, 11:59 AM   #6
carraya
LQ Newbie
 
Registered: May 2004
Posts: 10

Rep: Reputation: 0
"2.) Kernel panic: this is because Reiserfs (if you use it) is not enabled by default. Make sure it is enabled under "Filesystems". "

Quote from other thread...
 
Old 06-01-2004, 05:23 PM   #7
peacebwitchu
Member
 
Registered: Apr 2004
Distribution: Debian
Posts: 185

Rep: Reputation: 30
Where did you get the kernel source? Is this the official kernel source from kernel.org? The kernel from kernel.org needs some patches to use cramfs initrd or at least use to. That could be dated now. That may be a Debian specific thing I'll research now

Last edited by peacebwitchu; 06-01-2004 at 05:31 PM.
 
Old 06-01-2004, 05:34 PM   #8
sharper
Member
 
Registered: Aug 2002
Location: MN USA
Distribution: slakware 9.0
Posts: 121

Rep: Reputation: 15
Uhmm, did you rerun lilo? When I install a new kernel and forget to run lilo I seem to get kernel panics.
 
Old 06-02-2004, 12:37 PM   #9
carraya
LQ Newbie
 
Registered: May 2004
Posts: 10

Rep: Reputation: 0
Quote:
Originally posted by sharper
Uhmm, did you rerun lilo? When I install a new kernel and forget to run lilo I seem to get kernel panics.
that would also be a good thing to do
 
Old 06-22-2004, 06:03 AM   #10
tiluu
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
I am still getting error on reboot
Kernel panic:VFS:Unable to mount root fs on 03:00
whether i use initrd image or not.
I am trying fresh kernel 2.4.26 from www.kernel.org. It is written it is latest stable.Does it implies i dont have to apply any patch?
 
Old 06-22-2004, 07:13 AM   #11
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
That's really strange:

The message:
"Kernel panic:VFS:Unable to mount root fs on 03:00"
actually indicates that there was an attempt to mount the root filesystem to
device 03:00 (major 03 minor 00) which normally is /dev/hda

According to your lilo, however,
your root partition is located on /dev/hda2 which shall be 03:02 and not 03:00

Check your /etc/fstab to see if all mountpoints are set correct.

*ALSO* check your Makefile located in /usr/src/linux-2.4.22. There the parameter ROOT_DEV

Also very important: Make sure that when you compile a driver into the kernel
that the same driver does *not* get loaded again as module. This may cause problems.

Check also your partition table!

Last edited by Vlad-A; 06-22-2004 at 05:50 PM.
 
Old 06-22-2004, 12:30 PM   #12
tiluu
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
My fstab looks like

------------------------------------------------------------------------------------------------------------------------
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
------------------------------------------------------------------------------------------------------------------------

While my partition looks like

------------------------------------------------------------------------------------------------------------------------
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/hda2 18611412 6310676 11355312 36% /
/dev/hda1 101089 36672 59198 39% /boot
none 123652 0 123652 0% /dev/shm
------------------------------------------------------------------------------------------------------------------------

The paramter ROOT_DEV in makefile is set to Current i.e,
export ROOT_DEV = Current


My kernel verion is 2.4.26.

I have also tried with new lilo version(2.4.22) but problem stays there.
 
Old 06-22-2004, 05:46 PM   #13
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Can you please try to change the follwoing entries in your /etc/fstab:

From
LABEL=/ / ext3 defaults 1 1
To
/dev/hda2 / ext3 defaults 1 1
also
From
LABEL=/boot /boot ext3 defaults 1 2
To
/dev/hda1 /boot ext3 defaults 1 2

Please also change in your lilo.conf
From
append = “root=/dev/hda2”
To
root=/dev/hda2

Since all your kernels are on /dev/hda2 you may move the root= entry to the global
lilo section.

Prompt
Timeout = 50
boot = /dev/hda
map = /boot/boot.b
root=/dev/hda2
message = /boot/message
lba32


image= /boot/bzImage-2.4.22
label = 2.4.22
initrd=/boot/initrd-2.4.22.img
read only


image= /boot/bzImage-2.4.18-14
label = linux
initrd=/boot/initrd-2.4.18-14.9.img
read only

run now /sbin/lilo after changing the lilo.conf

Last edited by Vlad-A; 06-22-2004 at 06:09 PM.
 
Old 06-23-2004, 12:02 PM   #14
tiluu
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
well now i managed to get past the prvious error but not able to do clean reboot.At end of reboot i m not go to login prompt.Error message "X server cannot be started " pops up in the end.There was also a message named scsi-detection falied during the boot up.I think this has something to do with initrd as there are some messages that modules cannot be loaded.
 
Old 06-23-2004, 01:29 PM   #15
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Can you at least go into init level 3 ? So not going to GUI log in.
Do you have SCSI devices at all ?

It is not necsarry initrd that can not load modules. What makes you think that initrd has some problems loading modules and
not the "normal" boot process ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error:reboot in kernel 2.6.8-2-386 pspec Debian 5 12-05-2005 12:25 AM
kernel panic error on reboot Ken8006 Fedora 2 05-16-2005 02:08 AM
Error trying to compile 2.6.10 kernel. Royle Debian 11 03-12-2005 08:42 PM
Kernel 2.6.9 compile error burn0ut Linux - General 3 12-08-2004 09:05 AM
Kernel 2.6.4 compile error kkiedrowski Slackware 3 04-30-2004 10:37 AM


All times are GMT -5. The time now is 08:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration