LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-30-2009, 12:49 PM   #1
Heriin
LQ Newbie
 
Registered: Jan 2009
Posts: 3

Rep: Reputation: Disabled
Exclamation Realtek RTL8187B Wireless and a few other things


Hey. I've just started using Linux, and I'm trying to get hold of how it's working and how to use commands and what I can do. But doing this, would be a lot easier if I had access to Internet whilst trying things out, which I'm at the moment don't have. (Sitting on an other PC at the moment).

I'm running dual boot with Ubuntu
uname -r
2.6.24-19-generic (Not sure if this is the version of Ubuntu. :-/ )

I have not tried if I can access Internet with a Ethernet cable, but however, that is not of interest to me, since in all the places I need access, wireless is the only option. My Wireless NIC is: Realtek RTL8187B Wireless 802.11b/g 54Mbps USB 2.0 Network Adapter
And I've tried a few things to get it to work, but with no success.
I've read that there can be something wrong with drivers or likewise, or that the card itself isn't compatible with Linux, but I don't know how to look that up. Nor do I know how to install eventual missing drivers or programs that are needed.

My friend tried to help me, also with nu success, and he asked me for this:
laptop:~$ ifconfig
eth0 Link encapthernet HWaddr 00:1e:33:54:01:72
inet addr:192.168.0.155 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:2587299266 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:221 Base address:0xa000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1330 errors:0 dropped:0 overruns:0 frame:0
TX packets:1330 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:66692 (65.1 KB) TX bytes:66692 (65.1 KB)

I'm not sure what it does, or what it says, nor if it's of help, but I figured it might be, since he wanted it.

Then there is another "issue" or rather, a think I want to know.
I've been asked to write a command to remove write permission for group members for all files and all directories (including all sub-directories) in the user’s home directory, and tried a few commands for this:
chmod g-w ./* (Didn't work on the files in the sub-dirs)
also tried this:
find ./ | chmod g-w * (Figured since find looks through and finds all files and directories from where you stand and down the hierarchy, I thought I could use that and pipe it to chmod, but no success there either.)
Also tried a few more lame attempts, but now I'm out of ideas and would gladly appreciate help!

And if there's anything I need to do in order to give you more information for you to help me, please tell me how to as basic and step-based as you can. I'm still only a beginner, but I aim to become better. (Hence why I've tried the last week on my own, without asking. No practice, no gain.)

Thanks in advice,
Heriin

EDIT:
Also, what is Preemption in terms of Linux?

Last edited by Heriin; 01-30-2009 at 01:59 PM.
 
Old 01-30-2009, 02:40 PM   #2
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 919
Blog Entries: 13

Rep: Reputation: 124Reputation: 124
Hi, to change the permissions of a directory, you need to run the chmod command recursively :
Code:
chmod -R g-w ./*
As for your wireless trouble, post the relevant output of lsusb -v and see if a module named RTL8187 is loaded : "lsmod | grep 8187". Also check if the device exists : "iwconfig" or "ifconfig -a" and look for wlan0. In general, as easiest I would suggest an upgrade to the latest kernel (or Ubuntu version if you find that too complicated/time consuming) since the driver you need has been integrated since 2.6.24 (btw : 2.6.24 is your kernel version :-D ). Another option is to look through aptitude for anything with the name RTL8187. Last but not least comes the ndiswrapper workaround : use your windows drivers.

Last edited by serafean; 01-30-2009 at 02:43 PM.
 
Old 01-30-2009, 03:37 PM   #3
GibsoneanNode
Member
 
Registered: Jan 2009
Distribution: Desktop- Debian 4.0
Posts: 43

Rep: Reputation: 16
lsb_release prints distribution-specific information, try the -a option which lists all of a variety of potential information. It would look as follows.

Code:
lsb_release -a
I am not familiar with the meaning of the word preemption as it applies to computer science but a good way to find out such things, at least by context, is to look on one's own on resources such as The Linux Documentation Project.
 
Old 02-01-2009, 07:16 AM   #4
Heriin
LQ Newbie
 
Registered: Jan 2009
Posts: 3

Original Poster
Rep: Reputation: Disabled
laptop:~/Skrivbord$ lsmod | grep 8187
r8187 57352 0
ieee80211_rtl 67844 1 r8187
usbcore 146412 7 usb_storage,libusual,r8187,usbhid,ehci_hcd,uhci_hcd



laptop:~/Skrivbord$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 802.11b/g Mode:Managed Channel=4
Access Point: Not-Associated Bit Rate:11 Mb/s
Retry: on Fragment thr: off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0



laptop:~/Skrivbord$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:1e:33:54:01:72
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:1508007332 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:221 Base address:0x8000

eth0:avahi Link encap:Ethernet HWaddr 00:1e:33:54:01:72
inet addr:169.254.3.191 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
Interrupt:221 Base address:0x8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1240 errors:0 dropped:0 overruns:0 frame:0
TX packets:1240 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:62152 (60.6 KB) TX bytes:62152 (60.6 KB)

wlan0 Link encap:Ethernet HWaddr 00:21:63:24:e2:53
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:12 overruns:0 frame:0
TX packets:656 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:27552 (26.9 KB)



laptop:~/Skrivbord$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 8.04.2
Release: 8.04
Codename: hardy


I also found this:
https://help.ubuntu.com/community/Wi...ealtekRTL8187b
But it didn't help. :-/

Last edited by Heriin; 02-01-2009 at 07:18 AM.
 
Old 02-02-2009, 08:56 AM   #5
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 919
Blog Entries: 13

Rep: Reputation: 124Reputation: 124
Hi, I'd suggest configuring it from console using iwconfig, but first I'd suggest scanning your area for wirless networks :
Code:
ifconfig wlan0 up
iwlist wlan0 scan
On the page you linked to, it is mentioned that the driver you need is present in 2.6.27; try upgrading, or take a look at this thread. Also the lsusb output for your card would make sure that you have what you think you have.
 
Old 02-05-2009, 11:25 AM   #6
Heriin
LQ Newbie
 
Registered: Jan 2009
Posts: 3

Original Poster
Rep: Reputation: Disabled
Lightbulb

I have NO idea what happened. But today suddenly it worked. And the funny thing is, I've done nothing since to try to fix it due to lack of time. And when I did, I rebooted several times, so it can't be that I just forgot that to get it to work. All very weird. But now it works and I'm very happy. And thanks a lot to you who've tried to help me!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot get wireless to work on Toshiba Satellite L350-170 (Wireless card: RTL8187B) TiggerTiggerTigger Linux - Laptop and Netbook 5 01-07-2009 07:33 PM
realtek rtl8187b wireless problems deft Linux - Wireless Networking 11 07-02-2008 09:05 AM
Realtek RTL8187B Wireless install on Slackware 12.1 using ndiswrapper muxsu Linux - Hardware 0 06-04-2008 09:22 PM
Realtek RTL8187B wont show in hardy jessica_lilly Ubuntu 3 03-22-2008 08:30 PM
Mandiva Wireless problem with Realtek RTL8187B jessica_lilly Mandriva 1 03-04-2008 06:00 AM


All times are GMT -5. The time now is 06:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration