LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-29-2005, 05:41 PM   #1
pluk2001
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Rep: Reputation: 0
Angry Realtek Ethernet Card Interrupt Conflict on FC4 and ATI Integrated Sound and Video


Hello everyone,

This is my first post so, bear with me if I post anything wrong! I am currently experiencing a problem in so much that there seems to be an interrupt problem with my Realtek 8139 Ethernet Controller.

I can't seem to get it to connect to the router, I also have no sound as well.

It's an integrated card along with the ATI Sound and Video cards.

Now after trawling as best I can through the forums, I am getting to my wits end and so I've decided to post here, so any help you guys can give would be much appreciated.

Many thanks,

Ant.

PS: I have gathered that I have to post some info regarding my problem, so here are the results:

uname -r:

2.6.11-1.1369_FC4

lspci -b:

00:00.0 Host bridge: ATI Technologies Inc: Unknown device 5a33 (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc: Unknown device 5a3f
00:02.0 PCI bridge: ATI Technologies Inc: Unknown device 5a34
00:04.0 PCI bridge: ATI Technologies Inc: Unknown device 5a36
00:05.0 PCI bridge: ATI Technologies Inc: Unknown device 5a37
00:06.0 PCI bridge: ATI Technologies Inc: Unknown device 5a38
00:07.0 PCI bridge: ATI Technologies Inc: Unknown device 5a39
00:11.0 IDE interface: ATI Technologies Inc ATI 437A Serial ATA Controller
00:12.0 IDE interface: ATI Technologies Inc ATI 4379 Serial ATA Controller
00:13.0 USB Controller: ATI Technologies Inc: Unknown device 4374
00:13.1 USB Controller: ATI Technologies Inc: Unknown device 4375
00:13.2 USB Controller: ATI Technologies Inc: Unknown device 4373
00:14.0 SMBus: ATI Technologies Inc ATI SMBus (rev 10)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller ATI
00:14.3 ISA bridge: ATI Technologies Inc: Unknown device 4377
00:14.4 PCI bridge: ATI Technologies Inc: Unknown device 4371
00:14.5 Multimedia audio controller: ATI Technologies Inc: Unknown device 4370 (rev 01)
01:05.0 VGA compatible controller: ATI Technologies Inc: Unknown device 5a41
07:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
07:0c.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
 
Old 09-29-2005, 06:07 PM   #2
pluk2001
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Looks seemingly like my problem is the bit where it says ATI...
 
Old 10-08-2005, 06:00 PM   #3
linuxkidd
LQ Newbie
 
Registered: Oct 2005
Location: Hampton Roads, VA
Posts: 1

Rep: Reputation: 0
May not be able to help ya with the Network adapter... but the sound..

WELL... for some reason, FC4 ships with a default setting on the sound card which renders it to have no output.

After verifying the PCM and Master volume settings a hundred times, in desperation I started tweaking everything...

It turns out that there's a setting to the far right of 'alsamixer' called 'External', when you highlight it, press 'M', That should change the box above it from 'MM' to 'OO'. Try to play a sound now...

This worked on my Acer Ferrari 4005WLMi.
 
Old 10-08-2005, 09:25 PM   #4
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
certainly don't asume there is a problem with the irq settup
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.0 doesn't detect Ethernet card on nVidia shipset 2, on-board card Realtek 8201 devilpim Linux - Newbie 3 05-27-2006 12:08 AM
TV-out on integrated ATI video johngcarlsson Linux - Laptop and Netbook 1 08-17-2004 07:15 AM
TV-out on integrated ATI video johngcarlsson Linux - Hardware 0 08-17-2004 06:40 AM
VIA sound card and Realtek ethernet card teamstatic84 Linux - Hardware 4 12-31-2003 08:18 AM
somewhat good news for laptop owners with integrated ati video Brain Drop Linux - Laptop and Netbook 0 05-15-2003 09:23 AM


All times are GMT -5. The time now is 10:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration