LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-08-2006, 08:00 AM   #1
chartoin
LQ Newbie
 
Registered: Dec 2006
Posts: 2

Rep: Reputation: 0
Realtek Ac 97 sound driver for fedora core 4


Hello, I am a newbie to linux. I installed fedora core 4. But it does not detect my sound card. I have the Realtek AC 97 sound card. And my PC is quite new. I just bought it 4 months ago. 1 GB RAm, 160 GB harddisk and all. Can anyone help me out? Show me how to make linux detect my soundcard?
 
Old 12-08-2006, 01:56 PM   #2
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
is this actually a realtek PCI sound card or is it integrated? post the output of the command 'lspci' as root user. to run it as 'root' run the command 'su' first, then enter your root password and run lspci. after getting this information for us type 'exit' in your root console so you dont accidently mess anythign up.
also check the HCL at the top of this website in the mean time.
 
Old 12-12-2006, 10:18 AM   #3
LoveKing
LQ Newbie
 
Registered: Dec 2005
Location: Chennai, Tamil Nadu, India
Distribution: Knoppix, Fedora Core 5,6, Fedora 7
Posts: 27

Rep: Reputation: 15
ok i too have to same soundcard an integrated one. i use FC6. mine was working. but something happened and i had to reinstall FC6. now it says no soundcard present. how can i make it detect the soundcard.

the output of /sbin/lspci is as follows

00:00.0 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. K8M800 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:0b.0 Modem: PCTel Inc HSP MicroModem 56 (rev 02)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200LE] (rev a1)

my kernel version is

[root@mysty ~]# uname -r
2.6.18-1.2798.fc6xen

please help me.
 
Old 12-12-2006, 11:39 AM   #4
LoveKing
LQ Newbie
 
Registered: Dec 2005
Location: Chennai, Tamil Nadu, India
Distribution: Knoppix, Fedora Core 5,6, Fedora 7
Posts: 27

Rep: Reputation: 15
ok i don know how it happened. but after a couple of restarts sound came. i have no clue how this happened. i did not install anything. i worked on some documents shutdown my system went for dinner and came back and voila there was sound.
any possible explanations.?
 
Old 04-08-2007, 09:35 AM   #5
chartoin
LQ Newbie
 
Registered: Dec 2006
Posts: 2

Original Poster
Rep: Reputation: 0
it's been along time. but I think I have solved the problem. For this particular soundcard, you need to install ALSA driver 1.6 or something. I got this in a round about way. I installed fc6 and ubuntu and Slax that booted through a CD. All of them had this ALSA driver. So please download it and install it. As for how to install it, I really don't know.

Can some linux guru help? Please.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 5 with Sound Blaster NX USB driver fails to sound maybi7 Linux - Hardware 1 10-26-2006 04:31 PM
problem with sound driver in Fedora Core 5 adam_blackice Linux - Laptop and Netbook 13 09-12-2006 05:58 AM
which sound driver do i use for Realtek ALC882? asilentmurmur *BSD 2 08-08-2006 07:01 AM
Realtek AC97 Audio + Fedora Core 3 furtivefelon Linux - Laptop and Netbook 4 01-05-2006 01:06 PM
What sound driver is on my Fedora Core 1 can564 Linux - Newbie 7 11-22-2004 03:15 PM


All times are GMT -5. The time now is 05:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration