LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2006, 04:24 AM   #1
Evily
LQ Newbie
 
Registered: Jan 2006
Location: Greece, Crete
Distribution: Suse 9.3
Posts: 9

Rep: Reputation: 0
realtek 8139 Suse 9.3 not working internet and network


I use both windows and linux on my pc. I am newbie at Linux and don't undrerstand much.
On windows my internet works normally. When I switch on Linux, it doesn't work at all and there is no network.
Can somebody tell me what is the problem
I receive the following messages:
when I switch on the console at the end the following message appear:
Failed service in runlevel 5: network
Skipped service in runlevel 5: smbfs nfs

When I write ifconfig :
Link encap: Local Loopback
inet addr: 127.0.0.1 mask: 255.0.0.0
inet6 addr: : : 1/128 Scope: Host
UP LOOPBACK RUNNING MTU: 16436 Metric:1
RX packets: 10 errors:0 dropped:0 overruns:0 frames 0
TX packets: 10 errors:0 dropped:0 everruns:0 carrier:0
collisions: 0 txqueuelen: 0
RX bytes: 834 (834.0 b)
TX bytes: 834 (834.0 b)


When writing eth0: unknown interface: No such device

When writing Ismod: command not found

when writing: /etc/init.d/network restart
Shutting down network interface:
Shutting down service network ............. done
Hint: you may set mandatory devices in etc/sysconfig/network/config
Setting up network interfaces:
lo
lo IP address: 127.0.0.1/8 done
ds 10 done
Setting up service network.... done
SuSefirewall2: Warning: ip6 tables does not support state matching. Extened

IPv6 support disabled
SuSefirewall2:setting up rules from etc/sysconfig/Susefirewall2
SuSefirewall2:Warning: no interface active
Firewall rules succesfully set
Susefirewall2:
 
Old 01-17-2006, 03:11 AM   #2
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
Hi, there is lot about this nic card

Just looking at http://www.linuxquestions.org/questi...hreadid=266885 for example

Just to double check, post the part of lspci -v
that is to do with your nic card

as root type lsmod | grep 8139
If nothing comes then the kernel module is not loaded
then try
modprobe rtl8139
This is only the beginning of setting up your connection

If this work, you will have to automate that loading
(possibly in /etc/modprobe.conf or similar)
Then use yast to configure your connection settings

I am a bit surprised it is not working out of the box
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Realtek 8139 not working on debian Ben136 Linux - Hardware 16 12-15-2005 10:37 AM
eth0 not working on realtek 8139 gregorya Linux - Networking 9 03-12-2005 01:46 PM
realtek 8139 slow network splotch Slackware 2 09-29-2004 12:28 PM
Can't get internet working on Slackware 9.1, kernel 2.4.22, realtek 8139 with dhcp ygnas Slackware 6 03-02-2004 12:06 PM
Realtek 8139 + Laptop + Linux = no internet Downy Linux - Hardware 6 02-11-2004 04:20 PM


All times are GMT -5. The time now is 03:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration