LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-02-2005, 09:47 PM   #1
Rojong
LQ Newbie
 
Registered: Dec 2004
Location: UK
Distribution: Slackware 10
Posts: 17

Rep: Reputation: 0
MBR being read instead of /boot


Hi all,

I decided to take windows of my desktop earlier and so re-partitioned my harddrive. I usually use the MBR for booting but this time i decided to create a /boot partition for a change (first time). So now my partitions look like this..

hda1 /boot
hda5 /swap
hda6 /
hda7 /home

I went though all the usual installation stuff and got to configuring lilo. I chose expert mode as usual and this time chose 'Install to Superblock' instead of MBR (wasn't another option apart from 'skip'. Then added /dev/hda1 as the Linux partition. I finally finish the installation and reboot. Problem is i get presented with the lilo boot screen with the dual boot choices from my last install. The /boot partition seems to have an image in it, amongst other things.

I've never booted from a /boot partition before, just though i would give it a try. So my question is how do i use /boot instead of the MBR which has the last installations options in it? Sorry i can't show you a copy of lilo.conf, i am on another computer.

I could easily just use the MBR but i would prefer to find out what the problem is. Maybe i made a wrong choice when configuring lilo. I'm running Slackware 10.

Thanks for your time and any help you can offer..

Cheers

Last edited by Rojong; 01-02-2005 at 10:01 PM.
 
Old 01-02-2005, 10:25 PM   #2
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
Last time you probably used KDE if so! That sort of lilo MBR os created automaticly by KDE. If you have now KDE installed edit this option at control centre. Go to administrator's mode and reedit lilo. Be sure to uncheck checkbox on first tab down. If I recall correctly this checkbox is your current problem because it loads defaults automaticly
 
Old 01-03-2005, 10:04 AM   #3
Rojong
LQ Newbie
 
Registered: Dec 2004
Location: UK
Distribution: Slackware 10
Posts: 17

Original Poster
Rep: Reputation: 0
Hi SlackerLX,

Thanks for the reply. Is there a way i can do this without using KDE? I have to boot from floppy and try to reconfigure from there. During the lilo configuration i tell it to boot /hda1 which is the /boot partition i created during installation. Usually i choose the root partition when using the MBR. Here is my partition layout and lilo.conf file.


hda1 /boot < ==== set to bootable
hda5 /swap
hda6 /
hda7 /home


# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda6
#compact # faster, but won't work on all systems.
#prompt
#timeout = 5
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0 # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda1
label = Linux
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends


Again, thanks for any help or pointers..

Cheers
 
Old 01-03-2005, 10:34 AM   #4
kevinalm
Member
 
Registered: Oct 2003
Location: Iowa
Distribution: LFS 5.0, building 6.3, win98se, multiboot
Posts: 288

Rep: Reputation: 30
You can't boot without _some_ bootloader installed to the mbr. When you install grub's stage1 to a partition instead of the mbr, you have to chainload it from the bootloader in the mbr.

>>edit You're using lilo, but the same thing applies.


Last edited by kevinalm; 01-03-2005 at 10:36 AM.
 
Old 01-03-2005, 10:43 AM   #5
Rojong
LQ Newbie
 
Registered: Dec 2004
Location: UK
Distribution: Slackware 10
Posts: 17

Original Poster
Rep: Reputation: 0
Cheers kevinalm, i'll make the changes and see what happens.

Thanks again
 
Old 01-03-2005, 10:44 AM   #6
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
You need to install a bootloader.
Log in as root and I take the configuration file generated by the slackware install in /etc/lilo.conf.
Open editor and change the boot option to 'boot=/dev/hda1'.
After, run lilo with no switches.
Use the command 'lilo -M /dev/hda' if you want to have MBR

Last edited by SlackerLX; 01-03-2005 at 11:17 AM.
 
Old 01-03-2005, 10:49 AM   #7
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
Almost forgot....
KDE puts nasty backup files that have tendency to restore the changed lilo
Check up on these files too, will you?
They are usually homed in
/var/log/packages
/var/log/scripts
 
Old 01-03-2005, 11:13 AM   #8
Rojong
LQ Newbie
 
Registered: Dec 2004
Location: UK
Distribution: Slackware 10
Posts: 17

Original Poster
Rep: Reputation: 0
Okay i tried doing the things above and no matter what i do i get a kernel panic during the boot messages.


Warning: unable to open initial console.
Kernel panic: no init found. Try passing init= option to kernel.


If you need any other info that might help then let me know..

Thanks alot
 
Old 01-03-2005, 11:48 AM   #9
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
Were you Gentoo user before?. It's only them set separate boot partition. Please, keep in mind that Slackware installed your linux on root partition. Obviously that your boot partition is as empty as a bitch's head, otherwise you'd be turning Slackware to LFS. If you installed Slackware from original CDs that your boot image is in root partition. According to that build your lilo. And it's possible to create MBR with normal partition table, without boot partitions. Just curious, this boot partition of yours, is it 32MB?

Last edited by SlackerLX; 01-03-2005 at 11:53 AM.
 
Old 01-03-2005, 11:49 AM   #10
kevinalm
Member
 
Registered: Oct 2003
Location: Iowa
Distribution: LFS 5.0, building 6.3, win98se, multiboot
Posts: 288

Rep: Reputation: 30
fs support for the / fstype (and /boot) compiled into the kernel?
 
Old 01-03-2005, 12:13 PM   #11
Rojong
LQ Newbie
 
Registered: Dec 2004
Location: UK
Distribution: Slackware 10
Posts: 17

Original Poster
Rep: Reputation: 0
Through hanging around forums alot i have seen many different partition layouts mentioned. Since i was doing a new install i thought what the hell i'll try something different. I am now thinking that is isn't a good idea after all and i should just go back to how i used to do things. I usually dual boot like with XP/Slack and just want Slack on my desktop now. Maybe it's best to go with the /swap, /, /home setup after all. Never used Gentoo, i started with Mandrake a few years ago and then bought Slack, been with it since. I never felt the urge to try anything else after that.

My boot partition is 95M and i installed from the CDs.

Code:
fstab

/dev/hda5        swap             swap        defaults                0   0
/dev/hda6        /                    reiserfs    defaults                1   1
/dev/hda7        /home            reiserfs    defaults                1   2
/dev/hda1        /boot              reiserfs    defaults                1   2
/dev/cdrom      /mnt/cdrom    iso9660    noauto,owner,ro   0   0
/dev/fd0          /mnt/floppy     auto         noauto,owner        0   0
devpts            /dev/pts         devpts      gid=5,mode=620  0   0
proc               /proc               proc        defaults                 0   0

$ df -h

Filesystem            Size  Used Avail Use% Mounted on
/dev/hda6              19G  2.5G   17G  13% /
/dev/hda7              15G   33M   15G   1% /home
/dev/hda1              95M   36M   59M  38% /boot
Cheers
 
Old 01-03-2005, 12:29 PM   #12
kevinalm
Member
 
Registered: Oct 2003
Location: Iowa
Distribution: LFS 5.0, building 6.3, win98se, multiboot
Posts: 288

Rep: Reputation: 30
What's your lilo.conf currently like?
 
Old 01-03-2005, 01:12 PM   #13
Rojong
LQ Newbie
 
Registered: Dec 2004
Location: UK
Distribution: Slackware 10
Posts: 17

Original Poster
Rep: Reputation: 0
My fstab is the same as above with root = /dev/hda1 as pointed out my SlackerLX. It's also been /dev/hda but this still gives a kernel panic aswell. I have also tried changing boot and root within lilo.conf between /hda and /hda1. The /boot directory isn't empty either.


$ ls /boot

README.initrd
System.map
System.map-ide-2.4.26
boot.0300
boot.0301
boot.0306
boot_message.txt
config
config-ide-2.4.26
diag1.img
map
vmlinuz
vmlinuz-ide-2.4.26


Hope that helps a little more...

Thanks again, really appreciated
 
Old 01-03-2005, 02:02 PM   #14
kevinalm
Member
 
Registered: Oct 2003
Location: Iowa
Distribution: LFS 5.0, building 6.3, win98se, multiboot
Posts: 288

Rep: Reputation: 30
I use grub myself so I'm not very familiar with lilo.conf syntax, but looking back over this thread the lilo.conf you posted looks wrong to me. For one thing there should be an append statement passing the / partition with a kernel option root=hda6 (or maybe root=/dev/hda6) and iirc the append should come after the label statement. The root=hda1 before the label may be a necessary global option setting lilo's /boot, not sure. I know with grub one thing that causes problems is confusion between grub's "root" (this is the partition where menu.lst, the stage files, etc, reside) and / . They aren't the same thing, although in some cases they will be.

>>edit Didn't have lilo on my system, so I download the source and installed the man pages. In your previously posted lilo.conf, you are telling lilo to mount /dev/hda1 as root (/). Try changing to:

root=/dev/hda6
boot=/dev/hda1

and run /sbin/lilo


Last edited by kevinalm; 01-03-2005 at 03:17 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! MBR Destoyed, Can't Boot! squeakypants Linux - Newbie 39 02-04-2005 09:54 PM
Boot problems (MBR) french_frogger Linux - General 6 12-20-2004 01:13 PM
/boot as opposed to MBR babyphil Linux - General 5 08-21-2004 11:13 PM
"LI" from boot floppy? Can't load XP or Linux. Damaged MBR or boot sector or ...? SparceMatrix Linux - General 10 09-27-2002 01:20 PM
boot record (MBR) emperor13 Linux - General 1 12-01-2001 11:21 AM


All times are GMT -5. The time now is 03:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration