LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-21-2007, 12:23 PM   #1
meb495
LQ Newbie
 
Registered: Jan 2007
Posts: 7

Rep: Reputation: 0
Reading Files on a CD/DVD-ROM without proper permissions


Very simple problem really, perhaps someone has a simple fix:

I have many burned DVDs with AVI files that I burned using OS X and thus, I suppose, the files on them have Unix-style permissions. When I burned them I didn't much care about permissions because at the time I wasn't a Linux user.

Now I find that I can only read (play, copy, etc) files on these DVDs if the permissions are set to allow people other than the owner to read them - very, very few are.

I tried using the sudo cp command from the terminal to copy the files onto my hard drive using my own root status. This neither worked nor produced an error. Perhaps I did something wrong?

I also added nosuid to the cdrom entry of my fstab at the suggestion of someone on Ubuntu's forums. That didn't work either.

Perhaps I should just blame Apple for letting me burn a DVD with wacky permissions in OS X.

I'm new to Linux and Ubuntu but truly love Ubuntu so far(I'm running Edgy Eft), having used Red Hat, Mandriva, and Linspire in passing. Please, someone, is there simple way around this problem short of using a Windows box or a Mac to access the files?

Thanks,
User with a new Ubuntu desktop
 
Old 01-21-2007, 12:39 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
You could copy the files to your computer and then use chmod to change the permissions on the files to allow everyone to read.
 
Old 01-21-2007, 12:48 PM   #3
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
Also you could create an user in Linux with same UID (501 probably?) as your Mac user had to gain access to those files.
 
Old 02-01-2007, 05:26 PM   #4
meb495
LQ Newbie
 
Registered: Jan 2007
Posts: 7

Original Poster
Rep: Reputation: 0
I tried that, creating a user with the name 501. Ubunutu won't let me create a UID of just 3 numbers. oh well
 
Old 02-01-2007, 05:27 PM   #5
meb495
LQ Newbie
 
Registered: Jan 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Also tried the other suggestion, copying the files and running chmod. I can't do that because I don't have the permissions to copy the files in the first place.
 
Old 02-01-2007, 05:41 PM   #6
Robhogg
Member
 
Registered: Sep 2004
Location: Old York, North Yorks.
Distribution: Debian 7 (mainly)
Posts: 653

Rep: Reputation: 85
What would happen if you added uid=<your uid> to the options in fstab? According to the man page for mount:

Code:
Mount options for iso9660
...
 uid=value and gid=value
              Give all files in the file system the indicated  user  or  group
              id,  possibly overriding the information found in the Rock Ridge
              extensions.  (Default: uid=0,gid=0.)

Edited to add:

There's also a mode=value option listed in the man page, which can set permissions using octal values. Not tried either of these, because I've never needed to, but it may work.

Last edited by Robhogg; 02-01-2007 at 05:46 PM.
 
Old 02-01-2007, 06:33 PM   #7
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,177

Rep: Reputation: Disabled
Quote:
Originally Posted by meb495
I tried that, creating a user with the name 501. Ubunutu won't let me create a UID of just 3 numbers. oh well
It certainly is possible manually. Edit the passwd file if everything else fails.
 
Old 02-01-2007, 06:54 PM   #8
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,238

Rep: Reputation: 121Reputation: 121
"Also tried the other suggestion, copying the files and running chmod. I can't do that because I don't have the permissions to copy the files in the first place."

The root user has permission to do anything.
 
Old 02-01-2007, 09:39 PM   #9
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
And you want a UID of 501, not a username.
 
Old 02-03-2007, 02:18 PM   #10
meb495
LQ Newbie
 
Registered: Jan 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks Robhogg, adding my UID and GID to the fstab entry for my DVD drive worked perfectly! I recommended that as an option for others in a similar situation.

As for my failed attempt to copy the files to my hard drive as root, perhaps I did something wrong there, being a newbie and all. . .I'll try that one again sometime to improve my Linux skills.

For now I'm grateful to have access to all my movies. Thanks.
 
  


Reply

Tags
cd, cdrom, cdrw, dvd, dvdr, dvdrw, files, permissions, unix


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DVD-R, problem reading files beyond 4 GB position vimico Linux - Hardware 4 04-07-2007 05:41 AM
DVD-ROM music only. System not reading? trox Linux - General 1 04-17-2006 02:57 PM
My dvd/cd-rom is not reading as it was supposed to stormrider_may Linux - Newbie 2 02-18-2006 03:55 AM
Changing DVD-ROM/CD-RW permissions tdking19 Slackware 1 02-12-2005 01:38 PM
Proper use of permissions ? wmcase Linux - General 4 02-04-2004 03:41 PM


All times are GMT -5. The time now is 05:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration