LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-21-2013, 06:50 AM   #1
varunb
Member
 
Registered: Mar 2011
Location: Bangalore, INDIA
Distribution: opensuse, fedora
Posts: 135
Blog Entries: 1

Rep: Reputation: 1
Question Read-only file system


Hello,

I am using SUSE Linux Enterprise Server 10

I am not able to create files or delete files.
every time i get the error as Read-only file system.

Code:
observer:~ # touch a
touch: cannot touch `a': Read-only file system
Code:
observer:~ # df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/md0               20G   13G  6.5G  66% /
udev                  990M  156K  989M   1% /dev
/dev/md2               20G  7.8G   11G  42% /home
/dev/md3               20G  5.0G   14G  27% /srv
/dev/md6              510M   44M  441M   9% /tmp
/dev/md1              9.9G  1.1G  8.3G  12% /var
/dev/md4               20G  6.4G   13G  34% /var/lib/mysq
Code:
observer:~ # mount
/dev/md0 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/md2 on /home type ext3 (rw,acl,user_xattr)
/dev/md3 on /srv type ext3 (rw,acl,user_xattr)
/dev/md6 on /tmp type ext3 (rw,acl,user_xattr)
/dev/md1 on /var type ext3 (rw,acl,user_xattr)
/dev/md4 on /var/lib/mysql type ext3 (rw,acl,user_xattr)
securityfs on /sys/kernel/security type securityfs (rw
i did restart, also did fsck manually but still the same issue.
Any suggestions??? please.
 
Old 01-21-2013, 06:56 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Which directory are you in? It's possible that one of the drives has a problem. There is an option mount option errors={continue|remount-ro|panic}. The superblock contains the default if it isn't in /etc/fstab.

Check your kernel messages. If there is a problem mounting, there should be a message about it.
 
Old 01-21-2013, 03:37 PM   #3
goumba
Senior Member
 
Registered: Dec 2009
Location: New Jersey, USA
Distribution: Debian Sid. Arch. In the process of converting to and learning FreeBSD
Posts: 1,023
Blog Entries: 6

Rep: Reputation: 237Reputation: 237Reputation: 237
It looks like he's in /home/observer from the prompt, home being mounted rw. I will second checking dmesg for ny errors while mounting the filesystem, that's the message I got when I had problems with an fs mounting. Usualy however the fs mounted ro and I hadn't noticed.

Also, check permissions on the directory, make sure they're set properly for the user and/or group.
 
Old 01-21-2013, 03:40 PM   #4
goumba
Senior Member
 
Registered: Dec 2009
Location: New Jersey, USA
Distribution: Debian Sid. Arch. In the process of converting to and learning FreeBSD
Posts: 1,023
Blog Entries: 6

Rep: Reputation: 237Reputation: 237Reputation: 237
Two reasons I have gotten this error in the past:

1. The user did not have the proper permissions to write to the filesystem in question. Check your permissions n the directory(ies) involved. I'd check into this.

2. The fs has an error, however usually then it would be mounted ro, but following the suggestion above to check dmesg can't hurt.
 
Old 01-21-2013, 11:44 PM   #5
varunb
Member
 
Registered: Mar 2011
Location: Bangalore, INDIA
Distribution: opensuse, fedora
Posts: 135
Blog Entries: 1

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by jschiwal View Post
Which directory are you in? It's possible that one of the drives has a problem. There is an option mount option errors={continue|remount-ro|panic}. The superblock contains the default if it isn't in /etc/fstab.

Check your kernel messages. If there is a problem mounting, there should be a message about it.
Only for / i.e for /dev/md0

Other directoris are fine.

refering to the below url

http://askubuntu.com/questions/19745...ly-file-system

After running the below two commands, now i am able to create a file or remove.

fsck -Af

shutdown -rF now

I have to keep it under observation. .
Thanks for the reply. .
 
Old 01-22-2013, 01:08 AM   #6
curious95
Member
 
Registered: Oct 2012
Location: /home/v
Distribution: Slackware 14.0
Posts: 83

Rep: Reputation: Disabled
Quote:
Originally Posted by goumba View Post
Two reasons I have gotten this error in the past:

1. The user did not have the proper permissions to write to the filesystem in question. Check your permissions n the directory(ies) involved. I'd check into this.

2. The fs has an error, however usually then it would be mounted ro, but following the suggestion above to check dmesg can't hurt.
I usually get this error after I format a device into a FAT filesystem, it works fine at first then suddenly read-only filesystem.

Last edited by curious95; 01-28-2013 at 12:15 PM.
 
Old 01-28-2013, 11:18 AM   #7
FeyFre
Member
 
Registered: Jun 2010
Location: Ukraine, Vinnitsa
Distribution: Slackware
Posts: 344

Rep: Reputation: 29
@varunb, do you solved your problem?
There is exits another reason for this error: exhausting of inodes. Check it up.
 
Old 01-29-2013, 12:45 AM   #8
varunb
Member
 
Registered: Mar 2011
Location: Bangalore, INDIA
Distribution: opensuse, fedora
Posts: 135
Blog Entries: 1

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by FeyFre View Post
@varunb, do you solved your problem?
There is exits another reason for this error: exhausting of inodes. Check it up.
hey still in observation. .
i had got the same error again, did restart and seems working fine.

But how do you check the exhausting of inodes??? any command ???
 
Old 01-29-2013, 02:31 AM   #9
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
inodes
Code:
df -i
http://linux.die.net/man/1/df
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
chmod: changing permissions of `/usr../bin': Read-only file File System Issue cdhar Linux - Newbie 3 12-31-2012 07:17 AM
Read Only File System? Can't read superblock! haughjd Linux - Software 4 01-15-2008 09:27 AM
web server (fedora core 5) became read-only file system after i upload a file nggs8411 Linux - Server 1 03-26-2007 10:23 AM
How to read .chm file in fedora, can't mount ntfs file system ishti_du Linux - Newbie 12 03-06-2007 04:27 AM
Change from Read only to Read Write File System? justiceisblind Linux - Newbie 3 03-03-2002 08:23 PM


All times are GMT -5. The time now is 02:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration