LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-26-2002, 03:55 PM   #1
tracey
LQ Newbie
 
Registered: Feb 2002
Distribution: RedHat 7.2
Posts: 14

Rep: Reputation: 0
Re-mounting CD-ROM; error in symbolic link...


Hi -

A linux-savvy friend set up my system and mounted my cd-rom drive. It worked fine for a while, but suddenly there seems to be a problem. When I try to look at the files on the cd-rom, I get the error message:

"Could not mount device. Mount point /cdrom is a symbolic link to nowhere"

The relevant line in my /ect/fstab is...

/dev/cdrom /cdrom iso9660 noauto,owner,kudzu,ro 0 0

And when I type "ls -l /" the cdrom directory is red and blinking (seems baaaad) and I see a symbolic link to /mnt/cdrom.

However, I cannot find any /mnt/cdrom directory.

When I type "mount /cdrom" or "mount /dev/cdrom" (which should work, according the manual!) I get the same "symbolic link to nowhere" message"...

I'm trying to learn about mount points and devices and file types and symbolic links all at once -- but I really don't know which aspect is the problem here, or how to solve it.

Any ideas?? Thank you!!!
 
Old 02-26-2002, 07:35 PM   #2
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
Ok here is the solution, remove /cdrom
rmdir /cdrom
now make such directory
mkdir /cdrom
now take a look at /dev directory
cd /dev
ls -l cdrom*
if it lists
cdrom->/dev/hd* or similar (* can be c,d or any other letter depends on how many HD's and cdrom's/cdrw's you have) you're ok if not
create a symlink
ln -s cdrom /dev/hd* (substitute * with appropriate letter a....z). To find the letter you can use a rule of tumb
a-primary master
b-primary slave
c-secondary master
d-secondary slave
All described is for IDE devices without cable select setting, and I guess excluding RAID arrays.
Note: the above is done as root
 
Old 02-27-2002, 09:23 PM   #3
tracey
LQ Newbie
 
Registered: Feb 2002
Distribution: RedHat 7.2
Posts: 14

Original Poster
Rep: Reputation: 0
Neo -

Thank you for the reply! I did as directed, removing /cdrom and recreating it.

When I did "ln -l /dev/cdrom*" I get:

lrwxrwxrwx 1 root root 9 Feb 7 18:43 cdrom -> /dev/scd0

Which seems similar to what you suggested. However, still no luck mounting (though a new error message). It now says "mount: wrong fs type, bad option, bad superbloc on /dev/cdrom, or too many mounted file systems" Not too specific...

What do you think I should do next? I really appreciate your help!!!
 
Old 02-27-2002, 09:51 PM   #4
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
Post the complete /etc/fstab file it is helpful, and it seems you are using either SCSI CD-ROM or ide-scsi emmulation, so the stuff with symlinks I posted can be ignored.

Last edited by neo77777; 02-27-2002 at 09:54 PM.
 
Old 02-27-2002, 09:57 PM   #5
tracey
LQ Newbie
 
Registered: Feb 2002
Distribution: RedHat 7.2
Posts: 14

Original Poster
Rep: Reputation: 0
Hi Neo!

Here's the /etc/fstab file contents:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda6 swap swap defaults 0 0
/dev/fd0 /floppy auto noauto,owner,kudzu 0 0
/dev/cdrom /cdrom iso9660 noauto,owner,kudzu,ro 0 0

Last edited by tracey; 02-27-2002 at 09:58 PM.
 
Old 02-27-2002, 10:12 PM   #6
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
Does the /cdrom directory exists on the system?
another question
is the CD-ROM scsi? Is it a burner?
if /cdrom exists
try as root
mount -tiso9660 /dev/cdrom /cdrom
 
Old 02-27-2002, 10:27 PM   #7
tracey
LQ Newbie
 
Registered: Feb 2002
Distribution: RedHat 7.2
Posts: 14

Original Poster
Rep: Reputation: 0
Hi again,

/cdrom does exist on the system (since I just created it. Before, it was a symbolic link to /mnt/cdrom... which did not exist, hence the original error message "symbolic link to nowhere"... anyway, so I deleted the link /cdrom and replaced it with a new directory /cdrom...as per directions #1)

I don't know what scsi means... how do I find out? It is a burner (R/W).

The command line "mount -tiso9660..." yields the same error message I posted earlier ("wrong fs type, bad option, etc....")

As an aside, I tried this same "mount..." command before I deleted /cdrom (the original link...) and it did not work then. Also, at some point in the remember-able past (like 2 days ago) this all worked fine... or at least reading worked fine, I hadn't tried writing...

But anyway, even though I am quite clueless here, some of these basic setting do have some basis since they worked before the aforementioned symbolic link suddenly evaporated.

A potentially related question: does the file type (iso9660?) depend on the CD? Or just the CD player? Like, if I change CD's might I have to change the file type? Or is it always the same, and if it can read one CD it can read every CD?

Bye!
 
Old 02-27-2002, 10:32 PM   #8
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
ISO9660 is a standard filesystem for data CD-ROM's, by any chance are you trying to mount an audio CD, if so they are not mountable. if you do as root
cdrecord -scanbus
what's the output?
 
Old 02-27-2002, 10:39 PM   #9
tracey
LQ Newbie
 
Registered: Feb 2002
Distribution: RedHat 7.2
Posts: 14

Original Poster
Rep: Reputation: 0
It's a data CD I'm trying to read (written in Windows, but only containing raw text file--sort of an experiment to see if I could write to the CD in windows then read it in linux. Since I don't have my windows partition mounted... which will be another project...)

Anyway this is a cool command! It knows my computer better than I do!

--------------------
Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 Jörg Schilling
Linux sg driver version: 3.1.19
Using libscg version 'schily-0.5'
scsibus0:
0,0,0 0) 'SAMSUNG ' 'CDRW/DVD SN-308B' 'U003' Removable CD-ROM
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *
 
Old 02-27-2002, 10:43 PM   #10
tracey
LQ Newbie
 
Registered: Feb 2002
Distribution: RedHat 7.2
Posts: 14

Original Poster
Rep: Reputation: 0
Oh gosh, you know I'm a bit of an idiot (not a complete one, though... after your saying how audio CD's couldn't be mounted, I'm trying the Linux documentation CD and it mounts perfectly). So, the problem appears to not be the hardware.

But, I do still have the question... how can I write to a CD in windows and read it in Linux?

The problem appears to be a formatting problem instead of hardware.

However, if you're completely sick of me I understand!
 
Old 02-27-2002, 10:50 PM   #11
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
Nope, not a ziltch, I am here to help, I just on and off, recording MTV Music Awards and skipping the commercials, so if you try to mount another CD, any other that you have (games, windows install CD), does it give you the same error?
 
Old 02-27-2002, 10:52 PM   #12
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
Ok, ignore it, I see you mounted linux docs cd, hmm, can it be a faulty CD, does windows read this CD?
 
Old 02-27-2002, 10:57 PM   #13
tracey
LQ Newbie
 
Registered: Feb 2002
Distribution: RedHat 7.2
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks

Yep, windows reads it (and writes to it) without a problem.

Just drawing an analogy with diskettes being formatted for mac vs dos... do CD's have similar format issues? Like, might there be a way to format it in Linux (and see if then Windows would read it?) rather than what appears to be the defaul windows formatting which Linux doesn't like?

Who's winning?
 
Old 02-27-2002, 11:05 PM   #14
TacKat
Member
 
Registered: Jan 2002
Distribution: LFS
Posts: 90

Rep: Reputation: 15
Take a look though this page (it's a related problem, but maybe not exactly I think): http://www.linuxgazette.com/issue65/tag/17.html

Also, can you post your /etc/lilo.conf ?
 
Old 02-27-2002, 11:07 PM   #15
tracey
LQ Newbie
 
Registered: Feb 2002
Distribution: RedHat 7.2
Posts: 14

Original Poster
Rep: Reputation: 0
I'll take a look at that link right now...

In the meantime, the file contents are:

prompt
timeout=50
default=linux
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
message=/boot/message
lba32

image=/boot/vmlinuz-2.4.7-10
label=linux
initrd=/boot/initrd-2.4.7-10.img
read-only
root=/dev/hda5
append="hdb=ide-scsi"

other=/dev/hda2
label=windows
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error 403 Forbidden symbolic link not allowed vree13 Linux - Software 8 02-14-2008 09:58 PM
Bad super block, too many mounted fs error when mounting CD rom Cogvos Linux - Hardware 2 02-18-2005 08:19 AM
cd-rom mounting error DrkSn Linux - Hardware 3 04-10-2004 12:50 AM
FTP Symbolic link error btalton Linux - General 2 12-17-2003 04:24 PM
Symbolic link bwaynej2002 Linux - General 8 08-25-2003 11:06 PM


All times are GMT -5. The time now is 08:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration