LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-01-2006, 06:33 AM   #1
beejayess
Member
 
Registered: May 2006
Distribution: suse 10.0
Posts: 48

Rep: Reputation: 15
re "cant connect to internet using suse10" and "will this work?"


thx everybody for your suggestion,i finally managed to get the connection up using the usb interface(more luck than judgement).I reinstalled and configured from the install menu that seemed to do the trick,but there is a problem.
Since the install the the multi boot screen is ok,but as it loads the resolution is wrong[defalt(screen dark,small etc)]then from the login screen onwards it is the configure to my monitor 800x600@56mhz.
How can i fix this?On my first install(the one where i couldn't connect)I didn't have this problem.
The hard ware infomation in yast shows the defalt res.
I've tried to change it in autoconfig in yast .....but....well NOTHING!

In the words of the immortal beatles HELP I NEED SOMEBODY!!!

thx
BJS
 
Old 07-01-2006, 06:38 AM   #2
dannystaple
Member
 
Registered: Apr 2006
Location: London, Uk
Distribution: Ubuntu on Desktop
Posts: 121

Rep: Reputation: 15
Hi there,

What is the graphics card you are using? Have you configured your xorg.conf properly?

Danny
 
Old 07-01-2006, 10:09 AM   #3
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,138

Rep: Reputation: 49
This isn't terribly helpful... but suse 10.1 has been out for a while. Many things have improved. If all else fails you might want to try a re-install.

Anyhow. This shouldn't happen unless you have a very exotic graphic card. If you have a nvidia card you can:

*install make, gcc, and bison first.
1) leave current session
2) go to the console and log in as root (ctrl-alt-1)
3) type "tinynvdidiainstaller" or "tiny-nvidia-installer"
4) click ok repeatedly
5) type reboot

Last edited by oskar; 07-01-2006 at 10:12 AM.
 
Old 07-01-2006, 10:31 AM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
From your message, I'm not sure if the problem you mentioned is that the x windows resolution is too low or that you want to use a higher resolution on the virtual terminals.

For the first try running sax. Also, for a nvidia card, if you perform a software update, you will be able to install the propriety nvidia driver.

If you are referring to the resolution of VT/1 - VT/6, you can add a boot option to grub.
I use "vga=795" on my laptop which has a 1280x800 LCD monitor. Values of 791 or 794 may work better for you.
You can enter "vga=795" in the boot options when booting up to test it before editing your menu.lst file.
 
Old 07-01-2006, 10:35 PM   #5
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,138

Rep: Reputation: 49
Quote:
Originally Posted by jschiwal
For the first try running sax. Also, for a nvidia card, if you perform a software update, you will be able to install the propriety nvidia driver.
Oh, yes. Sorry, I mixed that up. in 10.0 you can do a software-update and one of the last points at the bottom will be the nvidia driver. check it to install.
The tiny-installer-thing is for 10.1
 
Old 07-02-2006, 03:58 AM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
If you have an nvidia-installer program, you can log out of X windows, and log in to one of the virtual terminals as root. Use "init 3" to turn stop x windows, and then use the "--update" option to download and run the latest version of the installer program. You also need the kernel-source and kernel-syms installed. The kernel-update-tool package might also help.

I did this because the nvidia driver version I was using wouldn't allow me to use the Transparency extention and Blender3d. The updated driver fixed the GL problem.
 
Old 07-02-2006, 12:55 PM   #7
beejayess
Member
 
Registered: May 2006
Distribution: suse 10.0
Posts: 48

Original Poster
Rep: Reputation: 15
The graphics are handled by an on board via km400.My res is ok when i finally boot....by the way the monitor is old and of an unknown make,I use the vesa 800x600@56mhz,24 bit.in yast in the hardware config info it has the monitor as 1024x768@75mhz in windows i run the monitor at 800x600@60mhz and 32 bit and it runs fine......it is after the initial suse multi boot screen and then until the root/user login that the res is too high....after that the res runs as i configured it.....and then again when i shutdown after i logout the res is too high.Is this a problem with the bootloader??I've tried to put the monitor config's in the autoloader but as i don't know what i'm doing i think that i made a real pig's ear of it!
The one thing i didn't tell you was that after I got on line the first thing I did was update with the yast updater.....could this be the problem?
Is there a way of config the boot files seperatly?
Or do I mean the config kernel.......see i am a muppet!!
 
Old 07-04-2006, 04:02 PM   #8
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I don't know where I got the idea that you where using nvidia video. If the resolution is OK when running X but not if you run in init level 3, a different "vga=" value in /boot/grub/menu.lst may resolve the problem. Some the the resolutions will use the frame buffer device. SuSE builds the kernel with fb support. There is also an "fbset" program.

Code:
jschiwal@hpamd64:~> sudo /sbin/fbset -i

mode "1024x768-76"
    # D: 78.653 MHz, H: 59.949 kHz, V: 75.694 Hz
    geometry 1024 768 1024 768 16
    timings 12714 128 32 16 4 128 4
    rgba 5/11,6/5,5/0,0/0
endmode

Frame buffer device information:
    Name        : VESA VGA
    Address     : 0xf0000000
    Size        : 6291456
    Type        : PACKED PIXELS
    Visual      : TRUECOLOR
    XPanStep    : 0
    YPanStep    : 0
    YWrapStep   : 0
    LineLength  : 2048
    Accelerator : No
 
Old 07-05-2006, 01:44 AM   #9
allan_registos
LQ Newbie
 
Registered: Jul 2006
Posts: 1

Rep: Reputation: 0
Internet Connection

I am a newbie linux user.

I am using for the first time fedora core 5 and was able to configure my ethernet card to connect to the internet via a proxy server since I am behind firewall.

My problem is if I will use the terminal, it cannot connect to the internet, for example when I type this at terminal:

yum update

I have errors like "invalid repo"

Any help would be greatly appreciated...
 
Old 07-05-2006, 03:28 AM   #10
beejayess
Member
 
Registered: May 2006
Distribution: suse 10.0
Posts: 48

Original Poster
Rep: Reputation: 15
thx jschiwal i will give it a go,though now it begs the question how to use the fbset program.but i will add it to my growing set of problems........I NEED A MANUAL!!!!!

BJS
 
Old 07-06-2006, 03:37 AM   #11
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You can simply add the value to the boot options.
Such as "vga=794" for a 1024x786 fb console. Your kernel needs frame buffer support, but most distro's including SuSE have support enabled in their stock kernel.

Last edited by jschiwal; 07-07-2006 at 06:28 PM.
 
Old 07-10-2006, 06:12 PM   #12
beejayess
Member
 
Registered: May 2006
Distribution: suse 10.0
Posts: 48

Original Poster
Rep: Reputation: 15
Thx jschiwal
so what id the "vga=" value for 800x600 @56hz?
I've looked at the fbset program do i just type

fbset mode 800x600-56? and then copy the rest of the values from the /etc/fb.modes file???
i dont want to enter anything that gives me an almost black screen as i would find it very hard to get back even if i knew how?

I'm so dense

BJS
 
Old 07-11-2006, 02:16 PM   #13
beejayess
Member
 
Registered: May 2006
Distribution: suse 10.0
Posts: 48

Original Poster
Rep: Reputation: 15
A Big Thank You

THX THX THX jschiwal i final worked it out,your help was much appriciated.My screen is now ok at boot i did it through YAST in the end in the boot loader config,couldn't work out how to with a command line but if it works don't knockit(unless it is a door knocker).My denseness is thinning


NOW.....................

Just kidding

BJS
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Telling people to use "Google," to "RTFM," or "Use the search feature" Ausar General 77 03-21-2010 11:26 AM
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 03:07 PM
Any way to get "Alice"; "Call of Duty" series and "Descent 3" to work? JBailey742 Linux - Games 13 06-23-2006 01:34 PM
"<" ">" Keyboard keys on Toshiba Satellite 1005-s157 dont work RodCas Linux - Laptop and Netbook 1 05-08-2004 04:22 PM
<input type="button" disabled="true" > does not work in ns4.7 or 4.9 cybercop12us Programming 2 11-29-2002 08:31 AM


All times are GMT -5. The time now is 02:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration