LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-08-2011, 02:51 PM   #1
Gener@l
LQ Newbie
 
Registered: Sep 2011
Posts: 11

Rep: Reputation: Disabled
rdesktop geometry


Hello,

I have a thin client I am using in which I am using rdesktop to reach my windows box. I am trying to use the geometry option and it is not working properly.

So before I go into my actual command, let me add that I set up a new alias for rdestop with the options in my bashrc. At one point if I ran the command manually on the command line, it was working, but if I tried to use the alias set in the .bashrc, it didn't work properly. However, now I cannot get it to work properly either way.

Ok, so the command:
Code:
rdesktop -g 1280X1024 -a 16 sound:local -u<myUser> <windowsBoxIP>
so the width I can change and it will adjust just fine, but the height, no matter what I change it to will only give me the height of half my screen size.

So my current work around is to use a percentage instead of setting the height and width, but I don't like this work around (unless I am able to give it two percentages, one for height and one for width which I have not tried).

I want it "full screen" (I don't want to use the full screen option because it to actually cover my linux menus), however, using 100% actually goes beyond the borders of the screen and reducing the percentage to try and get my whole windows "window" to fit causes me to lose a lot of my display real-estate and is a little distracting seeing my MS Windows "window" surrounded by the red linux background.

If anyone knows what is causing this geometry problem or knows a solution, I would appreciate it. I spoke with our sysadmins (for my thin client) here and they don't seem to know.

thanks,

Jeremy
 
Old 09-08-2011, 04:59 PM   #2
ArcLinux
Member
 
Registered: Apr 2005
Location: Fargo, ND
Distribution: Slackware, CentOS
Posts: 87

Rep: Reputation: 20
try using a lowercase "x"

rdesktop -g 1280x1024 -a 16 sound:local -u<myUser> <windowsBoxIP>
instead of
rdesktop -g 1280X1024 -a 16 sound:local -u<myUser> <windowsBoxIP>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting frame buffer geometry to match monitor geometry Skaperen Linux - Desktop 0 03-13-2011 04:27 PM
konsole and --geometry grgoffe Linux - Desktop 2 10-31-2010 12:11 AM
-geometry <geometry> reitzell Linux - Newbie 2 09-10-2005 01:13 PM
geometry software rammstein Linux - Software 2 09-05-2005 12:49 AM
dock geometry Paxmaster Linux - Newbie 1 11-25-2004 07:11 AM


All times are GMT -5. The time now is 02:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration