LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-27-2008, 03:30 PM   #1
Sanford Stein
Member
 
Registered: Jun 2008
Location: Evanston, Illinois
Distribution: RHEL 6.4
Posts: 126

Rep: Reputation: 17
rcp failing


On an RHEL 5 server, I am unable to use rcp for one specific situation.
I moved this server yesterday from my test domain( "TD") to my production domain ("PD"). While in TD, I could rcp to and from anywhere, no problem. In PD, I can rcp to and from other machines in this domain. But I cannot rcp to or from one specific server in the TD (call it "pear"). I can ssh, scp, or ping to and from "pear", but cannot rcp. I CAN rcp from pear to and fromall other server in the PD. All the relevant IP addresses are in my .rhosts files. Can anyone tell me why rcp should fail only for this one server?

Thanks,
Sanford Stein
 
Old 09-27-2008, 04:13 PM   #2
Sanford Stein
Member
 
Registered: Jun 2008
Location: Evanston, Illinois
Distribution: RHEL 6.4
Posts: 126

Original Poster
Rep: Reputation: 17
Or: alernatives

Or, is there an alternative way to transfer a file without having to enter a password? (We need to do it in an overnight script.)
I see the '-B' option on the scp man page, but when I try to use it I am told that I need a public key.

Thanks,
SS
 
Old 09-27-2008, 05:11 PM   #3
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Probably the easiest and most secure way of doing this is to set up SSH host keys and then use SCP. You can use ssh-keygen to generate the keys (read the man page for all the options), and then put the client's public key into the server's ~/.ssh/authorized_keys files. Then passwordless SSH should work.

BTW, are you trying to rcp as root? Sometimes that won't work unless you edit pts/0, pts/1 etc. to the /etc/securetty file (this may only affect rsh though, not sure). One thing to try is putting the IP addresses in /etc/hosts.equiv instead of ~/.rhosts.
 
Old 09-29-2008, 11:26 AM   #4
Sanford Stein
Member
 
Registered: Jun 2008
Location: Evanston, Illinois
Distribution: RHEL 6.4
Posts: 126

Original Poster
Rep: Reputation: 17
Btmiller:

Thanks for your suggestions. Modifying /etc/securetty and /etc/hosts.equiv did not help.

I did find out how to set up scp without a password:
http://www.linuxjournal.com/article/8600
so that's what we're going to go with as a solution.

Thanks,
SS
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trying normal rcp (/usr/bin/rcp) Permission denied. Martin Peter Clarke Linux - Server 5 12-21-2010 11:42 AM
compiz failing, GLcore.so failing to load Schrambo Linux - Desktop 4 02-23-2008 07:13 PM
eth1 failing on boot, IEEE firewire card driver failing, help jackuss_169 Linux - Laptop and Netbook 5 03-05-2005 08:34 AM
LILO install failing, Boot failing, but Installation fine. sramelyk Slackware 9 08-23-2003 03:37 PM
X failing to load; AddScreen/InitScreen failing for driver 0 weblion Linux - Software 1 08-01-2002 07:14 AM


All times are GMT -5. The time now is 10:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration