LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Radeon 9200 proprietary driver w/ RH 9.0 (http://www.linuxquestions.org/questions/linux-newbie-8/radeon-9200-proprietary-driver-w-rh-9-0-a-225492/)

jk21 09-01-2004 09:39 PM

Radeon 9200 proprietary driver w/ RH 9.0
 
I'm running RedHat 9.0 on my computer, and it doesn't seem to like my video card. It is an ATI Radeon 9200. I've read other material on the subject, but nothing I've tried has worked so far. I'm trying to get ATI's proprietary driver to work. I downloaded it, and after I tried to install the rpm package, it said:

########################################### [100%]
########################################### [100%]
*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Error: no kernel module build environment - please consult readme.
Installed: qt3 (gcc 3.2) based control panel application
===
ATI display drivers successfully installed
please run 'fglrxconfig' now
===

Linux made me switch back to the generic VESA driver to run again. ATI's website had some information on it (at http://www.ati.com/support/infobase/4475.html ), but I'm not exactly sure what it's talking about (I'm very new to Linux). Do I need the source code CD's for Redhat?

jk21 09-02-2004 01:14 AM

OK, I need to update this a bit. I realized that in Redhat 9, I could go to the add/remove applications thing to add the kernel source that ATI was talking about. I felt kinda stupid for not seeing that earlier. So, after I installed it, I rebooted my machine to a console (runlevel 3 instead of 5) and tried to install the driver again. I tried to install the fglrx package, but it gave me the same message again:

########################################### [100%]
########################################### [100%]
*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Error: no kernel module build environment - please consult readme.
Installed: qt3 (gcc 3.2) based control panel application
===
ATI display drivers successfully installed
please run 'fglrxconfig' now
===

I ran fglrxconfig, and it let me logon, but I don't have access to 3D acceleration. Is there an easy answer for this one? Or, at least an answer I can understand?

bobwall 09-02-2004 10:41 AM

What happens when you try to build the modules? ("cd /lib/modules/fglrx/build_mod; ./make.sh") If you get the error no such command found, then you probably either don't have gcc or make installed.

If that's the case, install gcc and make and then try to build the modules tailored for your system.

jk21 09-02-2004 12:06 PM

OK, here's what happens when I try to install it. I'll just paste the console contents here:

[root@localhost downloads]# rpm -Uh --force fglrx*
########################################### [100%]
########################################### [100%]
*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
make.sh: line 630: /proc/version: Permission denied
make.sh: line 631: /proc/version: Permission denied
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
patching 'drm_os_linux.h'...
probing for VMA API version...
doing script based build for kernel 2.4.x and similar
compiling './agpgart_be.c'...
compiling './agp3.c'...
compiling './i7505-agp.c'...
compiling './nvidia-agp.c'...
compiling './firegl_public.c'...
linking of fglrx kernel module...
duplicating results into driver repository...
done.
==============================
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.20-31.9/kernel/drivers/char/drm/fglrx.o will t
aint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Sta
rnberg, GERMANY
See http://www.tux.org/lkml/#export-tainted for information about tainted modu
les
Module fglrx loaded, with warnings
done.
Installed: qt3 (gcc 3.2) based control panel application
===
ATI display drivers successfully installed
please run 'fglrxconfig' now
===










At this point, I went into my file browser and set the permissions on make.sh and make_install.sh to execute. For some reason, that is not set automatically, and it was necessary to run the scripts. Then, I went back to the console:

[root@localhost downloads]# cd /lib/modules
[root@localhost modules]# ls
2.4.20-31.9 2.4.20-8 fglrx
[root@localhost modules]# cd fglrx
[root@localhost fglrx]# cd build_mod
[root@localhost build_mod]# ls
2.6.x agpgart.h i7505-agp.c make.sh
agp3.c agp.h i7505-agp.o nvidia-agp.c
agp3.o fglrx.o libfglrx_ip.a nvidia-agp.o
agp_backend.h firegl_public.c libfglrx_ip.a.GCC2 patch
agpgart_be.c firegl_public.h libfglrx_ip.a.GCC3
agpgart_be.o firegl_public.o make.log
[root@localhost build_mod]# ./make.sh
ATI module generator V 2.0
==========================
initializing...
./make.sh: line 630: /proc/version: Permission denied
./make.sh: line 631: /proc/version: Permission denied
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
patching 'drm_os_linux.h'...
probing for VMA API version...
doing script based build for kernel 2.4.x and similar
compiling './agpgart_be.c'...
compiling './agp3.c'...
compiling './i7505-agp.c'...
compiling './nvidia-agp.c'...
compiling './firegl_public.c'...
linking of fglrx kernel module...
duplicating results into driver repository...
done.
==============================
You must change your working directory to /lib/modules/fglrx
and then call ./make_install.sh in order to install the built module.
==============================
[root@localhost build_mod]# cd ..
[root@localhost fglrx]# ./make_install.sh
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.20-31.9/kernel/drivers/char/drm/fglrx.o will t
aint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Sta
rnberg, GERMANY
See http://www.tux.org/lkml/#export-tainted for information about tainted modu
les
Module fglrx loaded, with warnings
done.




After all that, I ran fglrxinfo, and it said:

display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4

The 3D rendering option is still disabled in the display settings box.

bobwall 09-02-2004 01:12 PM

That message about proc/version being not accessible is not a good sign. Without being able tell what kernel version you're using, the ati module won't be able to build properly. Try to make sure the /proc/version file is readable ("cat /proc/version"). If you get a permission error, give it read permission ("chmod a+r /proc/version" as root). You also might want to heed the knowledgebase article from ATI: go to /usr/src and make sure there is a linux directory with files inside. If not make a sybolic link named linux to whatever directory contains the kernel sources (i.e. "ln -s linux-2.4.25 linux").

Then go back and try to rebuild the fglrx module.

jk21 09-02-2004 02:48 PM

OK, I tried making the symbolic link (I went to /usr/src and typed ln -s kernel-source-4.3.0 linux), then tried to install the driver again, but exacly the same thing happened. I was concerned about the /proc/version thing, so I checked. The permisions are set such that anyone can read it, but write and execute permissions are not enabled. Additionally, I can't seem to enable them. I tried chmod a+rwx /proc/version, and it said:

chmod: changing permissions of `/proc/version' (requested: 0777, actual: 0444): Operation not permitted

bobwall 09-02-2004 03:07 PM

You should only need read permissions for /proc/version. You also might want to see
http://users.actrix.co.nz/michael/radeon9200.html


Other than that, you might want to consider using the regular dri/drm drivers which I have done (there's no way I'm downgrading to XF86 4.3 just to use ATI's drivers). To do this, goto http://www.freedesktop.org/~dri/snapshots/ and download the latest r200*.bz2 and common*.bz2. Then untar them ("tar -jxf r200*.bz2 common*.bz2"). The "cd dripkg" and execute the installation script "./install.sh". The script will replace some files in /usr/X11R6 and save them with extension .dri.old (something like that) in case you're paranoid about deleting them (like me).

jk21 09-03-2004 09:16 PM

OK - this is not going so well. I downloaded the DRI drivers, and tried to install them (I rebooted to runlevel 3 and ran the install script from the command line). It said:

ERROR: Kernel modules did not compile

The DRI drivers can not be installed without the latest kernel modules. Installation will be aborted. See dri.log file for information on what went wrong.

the dri.log file says:

cc -o .o
cc: no input files
make: *** [.o] Error 1

So, I figured maybe the problem was with the current drivers. The website you directed me to (http://users.actrix.co.nz/michael/radeon9200.html) suggested that I run rpm --install --force /mnt/cdrom/RedHat/RPMS/XFree86-4.3.0-2.i386.rpm, so I did. It then generated the following error:

error: Failed dependencies:
XFree86-libs = 4.3.0-2 is needed by XFree86-4.3.0-2
XFree86-xfs = 4.3.0-2 is needed by XFree86-4.3.0-2

I'm totally confused now. It seems like everything I do generates some sort of error, so I'm really wondering what the deal is. I wanted to take the second suggestion on the website I mentioned earlier and use the rawhide driver, but I have no idea what that is or where I can find it. Again, everyone's help is very appreciated.


All times are GMT -5. The time now is 06:54 AM.