LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-01-2002, 07:18 AM   #1
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Rep: Reputation: 30
quick questions for rh 7.3


i just installed rh 7.3 and i just want to know how do you mount windows on it???....i have looked everywhere, i know how to do it on mandrake, but on the latest version of KDE, its not there.....and the other question is i accidently set my kPPP to use wizard all the time and the wizard doesnt have my ISP so i cant setup an account, can i take off this wizard?
 
Old 09-01-2002, 07:27 AM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
KPPP, I have no idea....

Do it from the command line, assuming you have fat32:
mount -t vfat /dev/hdX /mnt/winbloze

replace X with the correct letter and number of the device.

If you want to always be able to mount it, and easier, place this line in your /etc/fstab file:
/dev/hdX /mnt/winbloze vfat default 0 0

If it's NTFS, a search on this site will unvail a plethora of options.

Here's pretty close though:
/dev/hdX /mnt/winbloze ntfs users,user,noauto,ro,umask=022 0 0

Or something like that.

Cool
 
Old 09-01-2002, 07:42 AM   #3
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
thanks masterC!...anyone have ideas about kppp, maybe i got to delete/install again....sounds like windows lol
 
Old 09-01-2002, 08:05 AM   #4
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
No problem
 
Old 09-01-2002, 10:42 AM   #5
dwd
Member
 
Registered: Aug 2002
Distribution: RedHat / Debian / Ubuntu
Posts: 35

Rep: Reputation: 15
(Hello MasterC...)

I've no idea about KDE at all, either. But, as a general set of rules to try to fix something:

1) rpm -qc kppp
- Tells you what configuration files are included in the package.
- This can give hints as to what files might be worth editing to remove the Wizard. MasterC will tell you that wizards are evil, and to be fair, he's right if they don't offer an option to get rid of them.

2) rpm -qd kppp
- Tells you what documentation is included with the package.
- Generally this is a good place to start.

3) If all else fails, don't bother reinstallingthe whole system unless that's the only method. Try: rpm -e kppp (Remove the damn thing) and then reinstall the *package*. Default configuration files will probably then be put in place, although probably with an ".rpmnew" suffix.
 
Old 09-03-2002, 06:02 AM   #6
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
i tried mounting windows from the command line exactly how u did it but i get a 'mount point does not exists' or something along those lines, and when i just do /mnt instead of /mnt/windows for the directory, it mounts, BUT, my floppy and cd-rom drives etc. aren't there, it's just all my windows folders in /mnt, anyone can help ?
 
Old 09-03-2002, 06:29 AM   #7
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
for kppp, login or su to root and delete this file:

/root/.kde/share/config/kppprc
 
Old 09-03-2002, 06:33 AM   #8
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
uhhhmm for the windows mount point - you need to create the mount point first:

mkdir /mnt/windows

Then retry mounting the partition:

mount -t vfat /dev/hdXY /mnt/windows

/dev/XY is your windows partition as seen by fdisk -l

If it is ntfs - you'll need to have the ntfs module first. In RHL 7.3, you need to recompile it. You can try searching google.com/linux for an ntfs.o module and load it using modprobe:

modprobe /tmp/ntfs.o

Then mount it using this:

mount -t ntfs /dev/hdXY /mnt/windows
 
Old 09-03-2002, 09:26 AM   #9
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Quote:
Originally posted by dwd
(Hello MasterC...)

I've no idea about KDE at all, either. But, as a general set of rules to try to fix something:

1) rpm -qc kppp
- Tells you what configuration files are included in the package.
- This can give hints as to what files might be worth editing to remove the Wizard. MasterC will tell you that wizards are evil, and to be fair, he's right if they don't offer an option to get rid of them.

2) rpm -qd kppp
- Tells you what documentation is included with the package.
- Generally this is a good place to start.

3) If all else fails, don't bother reinstallingthe whole system unless that's the only method. Try: rpm -e kppp (Remove the damn thing) and then reinstall the *package*. Default configuration files will probably then be put in place, although probably with an ".rpmnew" suffix.
Hi, he he he Not all wizards are evil, but if they don't work, then it's a good idea to know where to go. For example, take Voldemort, he is an EVIL wizard. But say, Albus Dumbledore, well now, then that's a good wizard

As for setting up dial up, I just had no idea, and would probably vote for the wizard as well.

Very good explaination btw, and that goes for almost all of your responses on here, thanks

Cool
 
Old 09-04-2002, 06:51 AM   #10
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
ok people, really thanks for your help but just couple things are not happenin for me, one when i try puttin that line in to mount windows automatically i get a 'no final line' or something like that and yeh i think thats my last problem.....
 
Old 09-04-2002, 09:10 AM   #11
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Quote:
Originally posted by MasterC
KPPP, I have no idea....

Do it from the command line, assuming you have fat32:
mount -t vfat /dev/hdX /mnt/winbloze

replace X with the correct letter and number of the device.

If you want to always be able to mount it, and easier, place this line in your /etc/fstab file:
/dev/hdX /mnt/winbloze vfat default 0 0

If it's NTFS, a search on this site will unvail a plethora of options.

Here's pretty close though:
/dev/hdX /mnt/winbloze ntfs users,user,noauto,ro,umask=022 0 0

Or something like that.

Cool
If you are talking to me, I have an edit from the line above. You don't need both 'user' and 'users' entry, either one.
users = the ability for any user to umount a drive mounted by any user.
user = The ability for a user to mount a drive, but only the user who mounted can umount it.

Those definitions are from my skull, so if you see some other differences, by all means, add/correct them.

Ok, so you might want to check and see if you actually have a line after the last entry in fstab. This would probably be the source of your problem. Since I am not on Linux I can't check to see if there should be one or not. Either way, do the opposite. If you have an extra line, backspace up until you are the very end of the last entry, no further lines. If you don't have one, go the last entry, and then press return to create a "blank" line.

If you still have problems, go ahead and post your /etc/fstab file here and someone can probably easily fix it.

Cool
 
Old 09-05-2002, 04:41 AM   #12
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
i'm currently not on linux too, but i have tried the method of allowing an extra line and deleting one, and it has not solved my problem.....i tired moving the windows mount line to another spot eg. in the middle of all the other lines (if that made sense) and the same error returned....
 
Old 09-07-2002, 03:51 AM   #13
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Go ahead and post /etc/fstab then. Let's see if it's something with that.

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
three quick questions... honda_ricer Linux - Newbie 9 11-30-2005 08:53 AM
Quick Questions. byteframe Slackware 2 10-16-2005 04:04 PM
Quick questions Nylex Slackware 4 09-21-2003 08:16 AM
quick questions yocompia Slackware 5 06-20-2003 05:34 PM
2 Quick Questions sonikntails Slackware 2 05-03-2002 05:31 PM


All times are GMT -5. The time now is 08:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration