LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 07-02-2013, 12:23 PM   #1
karthik-naren
LQ Newbie
 
Registered: Jun 2013
Posts: 16

Rep: Reputation: 0
question about setting ACL


/dev/sda8 is permanently mounted on /a.

As apply ACL for user sam on /a.

# setfacl -m u:sam:rwx /a
setfacl: /a: Operation not supported.

Here is the steps I followed..



1 useradd sam
2 passwd sam
3 mkdir /a

Code:
# fdisk /dev/sda

The number of cylinders for this disk is set to 5221.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): n
First cylinder (3842-5221, default 3842): 
Using default value 3842
Last cylinder or +size or +sizeM or +sizeK (3842-5221, default 5221): +200M

Command (m for help): w
The partition table has been altered!

Calling ioctl() to re-read partition table.

WARNING: Re-reading the partition table failed with error 16: Device or resource busy.
The kernel still uses the old table.
The new table will be used at the next reboot.
Syncing disks.

# partprobe
# mkfs.ext3 /dev/sda8
# mount  /dev/sda8 /a
Code:
# mount
/dev/sda2 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda6 on /home type ext3 (rw)
/dev/sda5 on /var type ext3 (rw)
/dev/sda3 on /usr type ext3 (rw)
/dev/sda1 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
none on /proc/fs/vmblock/mountPoint type vmblock (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
/dev/sda8 on /a type ext3 (rw)
Code:
# vi /etc/fstab 

LABEL=/                 /                       ext3    defaults        1 1
LABEL=/home             /home                   ext3    defaults        1 2
LABEL=/var              /var                    ext3    defaults        1 2
LABEL=/usr              /usr                    ext3    defaults        1 2
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
LABEL=SWAP-sda7         swap                    swap    defaults        0 0
/dev/sda8               /a                      ext3    defaults        1 2
Code:
# ls -ld
drwxr-x--- 15 root root 4096 Jun 21 23:34
Now as I try to apply ACL this is what the message am getting

Code:
# setfacl -m u:sam:rwx /a
setfacl: /a: Operation not supported

Last edited by karthik-naren; 07-02-2013 at 12:27 PM.
 
Old 07-02-2013, 12:52 PM   #2
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 3,410
Blog Entries: 1

Rep: Reputation: 1115Reputation: 1115Reputation: 1115Reputation: 1115Reputation: 1115Reputation: 1115Reputation: 1115Reputation: 1115Reputation: 1115
acl has to be enabled on the mount

Code:
mount -o remount,acl /a
 
1 members found this post helpful.
Old 07-02-2013, 12:56 PM   #3
karthik-naren
LQ Newbie
 
Registered: Jun 2013
Posts: 16

Original Poster
Rep: Reputation: 0
if i try to change the permissions of /a

they wont change


# chmod o=rwx /a

# ls -ld
drwxr-x--- 15 root root 4096 Jun 21 23:34 .
 
Old 07-02-2013, 12:58 PM   #4
smeuth
LQ Newbie
 
Registered: May 2012
Location: Colorado
Distribution: RHEL, Slackware
Posts: 6

Rep: Reputation: Disabled
ACL Additions

In order to add acl level permissions to a file system, you need to add it to your /etc/fstab file. Select the file system using your favorite editor and then add ",acl" to the listing.

For example:
/dev/sda8 /a ext3 defaults,acl 1 2

Then bounce the system and you should be good to go. Bouncing of the system might be optional depending on the type of linux you are running, you might be able to get by with the remount command either ran as root or using sudo level permissions.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
setting ACL recursively amar.sree Linux - Newbie 4 11-06-2012 07:05 AM
operation not supported while setting ACL manoj.linux Linux - Enterprise 3 10-08-2010 08:15 PM
question setting acl's. extendedping Linux - Software 1 01-25-2008 05:59 AM
setting acl in aix manoj.linux AIX 0 10-08-2007 11:31 PM
Need help setting up an ACL flibby Linux - Security 3 01-17-2006 11:21 PM


All times are GMT -5. The time now is 07:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration