LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-23-2007, 11:03 PM   #1
undnyc
LQ Newbie
 
Registered: Jan 2007
Posts: 9

Rep: Reputation: 0
question about apache2


Hello im a newbie but im getting hang of linux little by little.
Im running Suse 10.1 Apache2 php server.....
What im trying to do is i have a domain pointed to one of the /home/user/public_html folder....what i want to do is i want to point /home/another_user/public_html under the same domain name so my outcome would be http://www.mydomain.com/another_user....
Can someone help me out????
thanx in advance....
 
Old 01-24-2007, 12:20 AM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Typically you just save an index.html in /home/another_user/public_html and then do www.mydomain.com/~another_user (notice the ~). Sometimes this needs to be enabled in one of the apache config files. I don't use Suse, so I'm not sure where that lives. In Debian it's in the /etc/apache2 directory...
 
Old 01-24-2007, 08:33 AM   #3
undnyc
LQ Newbie
 
Registered: Jan 2007
Posts: 9

Original Poster
Rep: Reputation: 0
how do i enable that????
my apace is int same path /etc/apache2/
 
Old 01-24-2007, 12:56 PM   #4
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
In my apache2.conf file there's a section that says
Code:
#UserDir is now a module
UserDir public_html
UserDir disabled root

<Directory /home/*/public_html>
     AllowOverride FileInfo AuthConfig Limit
     Options Indexes SymLinksIfOwnerMatch IncludesNoExec
</Directory>
Suse might use the http.conf file.

Also, in Debian, the way to make sure this is being loaded is to put a symlink in /etc/apache2/mods-enabled for files userdir.conf and userdir.load. The actual files are in /etc/apache2/mods-available. So you would cd /etc/apache2/mods-enabled and then ln -s /etc/apache2/mods-available/userdir.load userdir.load and the same for userdir.conf. They might already be there...
 
Old 01-24-2007, 01:11 PM   #5
undnyc
LQ Newbie
 
Registered: Jan 2007
Posts: 9

Original Poster
Rep: Reputation: 0
hey thanx alot that worked...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache2 Question carlosinfl Linux - Server 2 10-06-2006 10:58 AM
Apache2 question sdmike6 Linux - Software 4 06-05-2006 09:45 PM
Apache2 Vhost question EnigmaX Linux - Software 3 01-11-2006 01:32 PM
Apache2 Question gamehack Debian 2 10-16-2004 03:38 PM
Hi Everyone, quick apache2 question wolfwolf Linux - Networking 4 04-15-2003 12:22 PM


All times are GMT -5. The time now is 09:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration