LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-12-2003, 06:48 AM   #1
Trinity22
Member
 
Registered: Jul 2003
Location: oregon coast
Distribution: Fedora Core 3
Posts: 280

Rep: Reputation: 30
qt-library. help, i'm confused.


i've unleashed hell trying to install the slicker theme for kde. *sigh*. but I want that theme, so i'm determined to try to work through the massive issues. can anyone help me? i barely know what I'm doing.

I try to ./configure the theme and get the error
Quote:
checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (library qt-mt) n ot found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
so i think, maybe i have an outdated qt. i know i have some version of qt installed. so i get the rpm for the qt library. try to install that.
Quote:
[trinity@dhcp-1648-7 trinity]$ su
Password:
[root@dhcp-1648-7 trinity]# rpm -Uvh qt-3.1.2-14.i386.rpm
error: Failed dependencies:
libdesigner.so.1 is needed by (installed) qt-designer-3.1.2-1.1.9
libeditor.so.1 is needed by (installed) qt-designer-3.1.2-1.1.9
libqassistantclient.so.1 is needed by (installed) qt-designer-3.1.2-1.1.9
qt = 1:3.1.2-1.1.9 is needed by (installed) qt-devel-3.1.2-1.1.9
and now I can't even find the libdesigner.so.1 files and the like. I'm so incredibly confused. can anyone figure out where everything went to hell? or how i can get the proper files? or what files i need at all.


thanks in advance for any help,
trinity
 
Old 08-12-2003, 10:40 PM   #2
vexer
Member
 
Registered: Jan 2003
Location: Sudbury Ontario, Canada
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
What distrobution?

Also, try first uninstalling the old qt,
and reinstalling the new one.



-vexer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
adding a bulit in library to my library lg3 Linux - Software 1 10-17-2004 09:19 AM
howto compile bin with my library using all-static and shared linked standart library stpg Programming 4 06-29-2004 05:20 AM
what is the function library of the basic graphics library in rethat9.0? zerwolve Red Hat 0 04-29-2004 10:18 PM
Very confused... MoriyaMinakata Linux - Newbie 5 04-14-2003 10:36 AM
Confused pilotgi Linux - Newbie 9 04-20-2002 01:06 AM


All times are GMT -5. The time now is 04:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration