LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-25-2011, 10:25 AM   #1
Skyer
Member
 
Registered: Aug 2011
Posts: 113

Rep: Reputation: 6
QT applications - can't write international letters


Hello,
I am Gnome user, and I have few QT applications installed. QT overall works seamlessly, but there is one irritating problem related to it.

I cannot write letters like čď, etc., everything which has ˇ symbol in it. I am not sure if this is caused by QT applications themselves, but this problem occurs for all QT apps for me.

Please note that I can write characters like , or use shift/ctrl to use secondary characters or to capitalize text.

Also, international characters are displayed correctly, so this problem is associated with input only.


Thanks,

Skyer
 
Old 09-25-2011, 12:35 PM   #2
gary185
Member
 
Registered: Jul 2011
Posts: 113

Rep: Reputation: Disabled
QT uses utf-8 (unicode 4.0) internally so you need to use utf-8 fonts (if they contain the characters you need)
generally QT ignores locale setting and simply does utf-8 I/O
programatically you can change this but the developer would have to write the switching into the menus or hardcode for a specific char set.
 
Old 09-25-2011, 12:40 PM   #3
Skyer
Member
 
Registered: Aug 2011
Posts: 113

Original Poster
Rep: Reputation: 6
Oh yes I see,
it's not an input problem. Sorry for misleading you. I can input the characters using different keys, but I cannot use the key combination I am used to. The combination is: Shift + ˇ + letter. It works without any problems in Gnome applications and also for Gnome in general.

Is there any way to make QT accept this way to input those characters?


Thanks,

Skyer
 
Old 09-25-2011, 05:15 PM   #4
gary185
Member
 
Registered: Jul 2011
Posts: 113

Rep: Reputation: Disabled
Qt doesn't implement anything in the way of keyboard mapping so it just uses Xorg (XIM).
GTK+ uses ISO 14755 (i think)

might be able to set this with
xmodmap

first thing to try is to set xorg.conf to use "us(intl)" instead of just "us" (if that's what you are using?)
you can specify multilingual keyboard with two entries like this
Code:
        Option "XkbLayout" "us,il"
        Option "XkbOptions" "grp:alt_shift_toggle"
there is a new way too xkb not sure how to use it but you can google

if you search around on the internet you can find xmodmap files for all kinds of layouts like Dvorak or whatever.

you can even get different keymaps at the terminal with loadkeys

easiest way might be from within kde controll "kcontrol" center too as a setting that will persist when not in KDE
there is a fairly large set of choices under region accessability keyboard layout.
like i said earlier these are actualy built in xorg choices not kde implemented.
 
Old 10-01-2011, 03:26 AM   #5
Skyer
Member
 
Registered: Aug 2011
Posts: 113

Original Poster
Rep: Reputation: 6
Thank you for your reply,
well this input method works without any problems for all gnome applications.
I have xorg.conf set to my local layout already, so I'm not sure where would the problem be.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
read/write,write/write lock with smbclient fails swatidas11 Linux - Networking 1 03-10-2010 12:27 PM
Mozilla Firefox 3.0.4; few applications in 'applications' tab of 'preferences'; SW12. mitchellray Linux - Newbie 1 03-27-2009 08:56 PM
Blury taskbar letters of minimized applications ?? memo007 Linux - General 1 02-01-2007 08:17 AM
international cd over_clock Linux - Newbie 3 11-17-2003 06:14 PM
Write makefiles for QT applications without tmake Paulo Ges Programming 2 04-29-2003 12:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration