LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-03-2008, 01:27 PM   #1
shogun1234
Member
 
Registered: May 2004
Posts: 176

Rep: Reputation: 15
qemu host mode problem


I try http://qemu-forum.ipi.fi/viewtopic.php?t=1963 to setup qemu host network, but no luck. Seems like there are a few things not too clear to me. Hope someone can give me advice.

My understanding is in host (my host running suse 11.0 with nic iwl4965agn):
1.) create tap1
2.) setup bridge (e.g. br1)
3.) attach network to bridge (e.g. attach wlan0 to br1)

in guest (qemu with debian kernel 2.6.25):
1.) create tap2
2.) config network to use the same ip network as host
3.)

The scripts i use are as below (and it is executed orderly):
create_host_tap.sh
Code:
sudo tunctl -t tap1 -u neo
sudo /sbin/ifconfig tap1 up
bridge_up.sh
Code:
sudo /sbin/brctl addbr br1
sudo /sbin/brctl addif br1 tap1
create_guest_tap.sh
Code:
sudo tunctl -t tap2 -u neo
sudo /sbin/ifconfig tap2 up
start_qemu.sh
Code:
qemu -hda c.img -m 512 -net nic -net tap -localtime
however, I suppose this is incorrect because each time when executing these scripts, the network hangs (no longer I am able to connect to the internet.)

How can I solve this problem in order to use network as host in qemu?

Thank you very much,
 
Old 08-04-2008, 08:06 AM   #2
ordealbyfire83
Member
 
Registered: Oct 2006
Location: Leiden, Netherlands
Distribution: LFS, Ubuntu Hardy
Posts: 184

Rep: Reputation: 29
It's been quite a while since I used qemu, and I never could a "bridge" working successfully. I'm not sure what you need to do with your virtual machine in terms of networking, but if you're just looking for a "quick and dirty" means of getting it connected at all, then you could try something like

qemu [options] -redir tcp:5555::80 -redir tcp:5556::445

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
qemu problem afreitascs Slackware 4 07-08-2008 12:03 AM
Virtualizing FreeBSD in qemu on an opensuse host inspiron_Droid *BSD 1 04-16-2008 04:55 PM
Qemu mangling memory in host royceH Linux - Desktop 3 01-09-2007 02:40 PM
Change/Setting Host Video Mode MSwal2846 Linux - Newbie 1 06-20-2006 08:51 PM
qemu: qemu stopped right after command exec bitpicker Linux - Software 1 03-05-2005 12:25 AM


All times are GMT -5. The time now is 12:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration