LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-11-2011, 07:03 AM   #1
jmp007
LQ Newbie
 
Registered: Jan 2011
Posts: 1

Rep: Reputation: 0
Python 2.6 dependencies error installing python-sqlite2-2.5.5-1.1.i586.rpm


Hi

Im trying to install vodafone mobile connect 2.10 (noarch.rpm) but keep getting a python = 2.6 is needed by python-sq*.

I had Python 2.6 installed and upgraded to 2.6.6, but still got the error.

What could i be doing wrong or what repositories are short on my openSuse 11.0 to have the installation work.

I downloaded the correct version of vodafone for my system.

Regards
 
Old 02-11-2011, 11:05 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,947

Rep: Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602
Welcome to LQ.

Suse 11 has python 2.5.2 installed by default.
Please try this command : rpm -qa | grep python


When you install a package with # rpm -Uvh <package>.rpm :
'rpm' will look in the rpm data base to know what's installed.
A manual install of a different python will not be known by rpm.

If you are absolutely sure, you have the correct dependencies,
then the "--nodeps" option can be used :
# rpm -Uvh --nodeps <package>.rpm

.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Python Installed; bash command: python base.py. gets syntax error in base.py cre84j Linux - Software 4 01-23-2011 04:46 PM
Error message while installing rpm in python janarthananefx Linux - Newbie 3 04-21-2010 10:50 PM
Error whie creating rpm in python!! lampamp Programming 1 09-28-2009 06:35 PM
LXer: Python Python Python (aka Python 3) LXer Syndicated Linux News 0 08-05-2009 08:30 PM
installing python library's (Python Numeric) Four Linux - Newbie 1 10-16-2005 02:31 PM


All times are GMT -5. The time now is 01:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration