LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Python 2.6 dependencies error installing python-sqlite2-2.5.5-1.1.i586.rpm (http://www.linuxquestions.org/questions/linux-newbie-8/python-2-6-dependencies-error-installing-python-sqlite2-2-5-5-1-1-i586-rpm-862035/)

jmp007 02-11-2011 07:03 AM

Python 2.6 dependencies error installing python-sqlite2-2.5.5-1.1.i586.rpm
 
Hi

Im trying to install vodafone mobile connect 2.10 (noarch.rpm) but keep getting a python = 2.6 is needed by python-sq*.

I had Python 2.6 installed and upgraded to 2.6.6, but still got the error.

What could i be doing wrong or what repositories are short on my openSuse 11.0 to have the installation work.

I downloaded the correct version of vodafone for my system.

Regards

knudfl 02-11-2011 11:05 AM

Welcome to LQ.

Suse 11 has python 2.5.2 installed by default.
Please try this command : rpm -qa | grep python


When you install a package with # rpm -Uvh <package>.rpm :
'rpm' will look in the rpm data base to know what's installed.
A manual install of a different python will not be known by rpm.

If you are absolutely sure, you have the correct dependencies,
then the "--nodeps" option can be used :
# rpm -Uvh --nodeps <package>.rpm

.


All times are GMT -5. The time now is 05:28 PM.