LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 08-12-2008, 07:43 AM   #1
hocheetiong
Member
 
Registered: Jul 2007
Location: Penang , Malaysia.
Distribution: red hat linux
Posts: 133

Rep: Reputation: 15
Smile putty to connect to my linux server, the keyboard(keypad=number:1,2,3...)cannot use?


Hi, I having one problem regarding i am using putty from winxp pc to connect to my linux server, than i found a problem is i can press the keypad number like 1,2,3,4... on normal, but when i am using command vim to edit the file than all the keypad number key when i press than not come out 1,2,3,4 correct key, just come out A,B,D,F... why? I have try to change the setting on keyboard from putty, but still same. How to solve this problem? thank you very much.
 
Old 08-12-2008, 11:34 AM   #2
briealeida
Member
 
Registered: Jun 2007
Location: PA
Distribution: FreeBSD, Ubuntu, Knoppix,
Posts: 41

Rep: Reputation: 16
Is NumLock on?

Also:
3.3.5 Controlling Application Keypad mode
Application Keypad mode is a way for the server to change the behaviour of the numeric keypad.

In normal mode, the keypad behaves like a normal Windows keypad: with NumLock on, the number keys generate numbers, and with NumLock off they act like the arrow keys and Home, End etc.

In application mode, all the keypad keys send special control sequences, including Num Lock. Num Lock stops behaving like Num Lock and becomes another function key.

Depending on which version of Windows you run, you may find the Num Lock light still flashes on and off every time you press Num Lock, even when application mode is active and Num Lock is acting like a function key. This is unavoidable.

Application keypad mode can be turned on and off by the server, depending on the application. PuTTY allows you to configure the initial state, and also allows you to disable application mode completely.

Are you using Application Keypad mode?
 
Old 08-12-2008, 12:15 PM   #3
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Rep: Reputation: 35
I'm not the OP but I would like to know how to tell if you are in Application Mode?
 
Old 08-13-2008, 06:17 AM   #4
briealeida
Member
 
Registered: Jun 2007
Location: PA
Distribution: FreeBSD, Ubuntu, Knoppix,
Posts: 41

Rep: Reputation: 16
PuTTY allows you to configure the initial state, and also allows you to disable application mode completely.

^ from the PuTTY website.

To check your Application keypad mode, open PuTTY, expand 'Terminal', left-click 'Keyboard'. There is a whole box titled 'Application keypad settings'.
 
Old 08-13-2008, 11:52 AM   #5
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Rep: Reputation: 35
Thank you! Don't know about the OP, but that resolved the issue for me.
 
  


Reply

Tags
keyboard, numlock, putty


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Numeric keypad on keyboard not responding dayers Ubuntu 9 10-10-2010 04:42 AM
putty and trying hard to connect to a linux server nass Linux - Networking 1 03-14-2008 05:26 PM
Putty problems - cannot connect with server TuXspow Linux - Newbie 1 04-11-2005 02:59 PM
Need my keypad ALT-number characters / Redhat 9 quadmore Linux - Newbie 9 07-01-2004 01:38 AM
Keyboard/Keypad problems LinuxQuest01 Linux - Hardware 1 07-10-2002 02:03 PM


All times are GMT -5. The time now is 08:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration