LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-29-2003, 01:31 PM   #1
Robin01
Member
 
Registered: Aug 2003
Posts: 104

Rep: Reputation: 15
putty and openssh issue


Hello every

not able to connect to openssh using putty.

clicked on putty, to start the connection but nothing happens...
I get the black bakground with curser at top left cor. and nothing else appears.

Tried using the telnet option in ptty and i get the connection.. in this case the user id and pwd is asked but when i enter the password it fails...

has anyone run in to this problem before...

-the sshd_conf
port set at 23
listenadress--> is set to the local ip address..
ps -af|grep sshd appears and and sshd seem to be runing
mandrake 9.2

since, telenet worked to some degree by displaying ther user id and pwd... i'm assuming the port is configured and alive...
- the putty is installed on my win2000 machine and to access the openssh i enter the public ip address which i have configured or pointing to my linux box which also servers as a webserver.

what am i missing...
 
Old 11-29-2003, 04:53 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Try to connect using ssh from the Linux server to the Linux server. I mean, log in and run
ssh yourlogin@yourIP
Check if everything goes correctly.
Do you get an error message? Is it the same you get using putty?
 
Old 11-30-2003, 10:25 PM   #3
Robin01
Member
 
Registered: Aug 2003
Posts: 104

Original Poster
Rep: Reputation: 15
tried what u suggested and received the following:

[root@voyager /]# ssh anselmr@localhost
ssh: connect to host localhost port 22: Connection refused
[root@voyager /]# ssh anselmr@192.168.2.4
ssh_exchange_identification: Connection closed by remote host
[root@voyager /]# ssh anselmr@voyager
ssh_exchange_identification: Connection closed by remote host
[root@voyager /]#

any idea for a fix
 
Old 11-30-2003, 10:39 PM   #4
miyake
LQ Newbie
 
Registered: Nov 2003
Location: Socal
Distribution: Slackware, RedHat
Posts: 13

Rep: Reputation: 0
I think you got "connect to host localhost port 22: Connection refused" is because in your sshd_config, you have port 23, so sshd is listening on 23. the default port for ssh is 22. make sure it works locally prior to testing it from the outside world.
 
Old 12-01-2003, 07:11 PM   #5
Robin01
Member
 
Registered: Aug 2003
Posts: 104

Original Poster
Rep: Reputation: 15
tried that to and still not able to connect... found a command that seem to display more info but i'm not able to determin how to fix this problem:
looks like the port is blocked somehow... i checked the config file and its set to 22

[root@voyager /]# ssh -v localhost

OpenSSH_3.6.1p2, SSH protocols 1.5/2.0, OpenSSL 0x0090703f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: connect to address 127.0.0.1 port 22: Connection refused
ssh: connect to host localhost port 22: Connection refused
[root@voyager /]# anselmr@127.0.0.1
bash: anselmr@127.0.0.1: command not found
[root@voyager /]# ssh anselmr@127.0.0.1
ssh: connect to host 127.0.0.1 port 22: Connection refused
[root@voyager /]#
 
Old 12-02-2003, 04:59 PM   #6
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Try
ssh -p 23 anselmr@127.0.0.1
-p option specified the port you connect to. If you're ruinning SSHD on port 23 (as you wrote before) it should work.
 
Old 12-02-2003, 07:32 PM   #7
frogman
Member
 
Registered: Sep 2003
Distribution: Mandrake, Slack, Debian and PicoBSD
Posts: 181

Rep: Reputation: 30
I assume you've set up /etc/hosts.allow ?

i.e insert:

sshd:<ip_of _the_machine_you're_connecting_from>


You've set-up & swapped your keys between the two machines?

Putty isn't allowed to connect on my boxes unless it has access to a local copy of my private key.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue with sshd (openssh 3.5p1-6) eid Linux - Security 3 11-21-2005 08:10 AM
sshd (openssh) issue. The_mystiC Linux - Software 3 11-03-2005 09:06 AM
Breaking Firewalls with OpenSSH and Putty mchirico LinuxQuestions.org Member Success Stories 0 03-27-2005 04:03 PM
openssh and putty configuration help johnson407 Mandriva 2 12-16-2004 12:11 AM
Seting up a secure OpenSSH / Putty Connection... Help :) MrCarl Linux - Software 2 09-23-2003 10:27 AM


All times are GMT -5. The time now is 11:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration