LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-18-2003, 12:44 AM   #1
Ghostmaster
LQ Newbie
 
Registered: Nov 2003
Location: Third rock from the sun.
Distribution: Mandrake 9.1
Posts: 21

Rep: Reputation: 15
put in a file


I am suppose to put:

[Dialer Defaults]
modem = /dev/modem
Baud = 115200
Initl = ATZ
Init2 = ATQO V1 E1 SO=0 &C1 &D2 +FCLASS=0
ISDN = 0
Phone = <type here>
username = <type here>
Password = <type here>

This is for a file called wvdial.conf


first of all do I leave the "<>" around the phone #, username, and password? second of all it won't let me paste and save to this file even though my instructions tell me to do so. How do I do this? These files are under a username because the instructions said I needed to only be in home. It is not saying I have to be under root to do this. Please understand I am a newbie, and could you point me nicely in the right direction? I am trying to get my connection set up. Under the test, ./checkout it said I was almost ready and just a couple things left to do and I can go online.

Thank you!
WeeBit
 
Old 11-18-2003, 12:55 AM   #2
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Yes, leave out the < > things.

The reason you're not able to paste to the file is that you don't have write permissions on it. Since this is a settings file, you might want to switch to root to edit it.
 
Old 11-18-2003, 01:09 AM   #3
Ghostmaster
LQ Newbie
 
Registered: Nov 2003
Location: Third rock from the sun.
Distribution: Mandrake 9.1
Posts: 21

Original Poster
Rep: Reputation: 15
How am I going to change to root if I am under another user and that file is under that user? I changed to root. But the file wasn't there. None of the files i made under that user are there. Is there a way under root to bring up those files? Sorry but i am a very very newbie. Been trying to set my modem up for almost 8 hours now. I am Trying honest!
 
Old 11-18-2003, 02:09 AM   #4
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Chill man, take it slow...

Where is this file located? Full path... something like /home/yourname/filename.conf

You don't need to log in as root to do root stuff. Open up a console and type su... enter root password when prompted. Then invoke your favourite editor to edit the file.

eg. vi /path/to/file or kwrite /path/to/file

The important thing is to get the location of your file correct, everything after that is a breeze.
 
Old 11-18-2003, 02:19 AM   #5
Ghostmaster
LQ Newbie
 
Registered: Nov 2003
Location: Third rock from the sun.
Distribution: Mandrake 9.1
Posts: 21

Original Poster
Rep: Reputation: 15
I think the file path is /home/myusername/ltmodem-8.26a9/wvdial.conf

So what you are saying is to su enter then
kwrite /home/myusername/ltmodem-8.26a9/wvdial.conf

This will bring up the editor right? Does this look right?
 
Old 11-18-2003, 02:52 AM   #6
Ghostmaster
LQ Newbie
 
Registered: Nov 2003
Location: Third rock from the sun.
Distribution: Mandrake 9.1
Posts: 21

Original Poster
Rep: Reputation: 15
ok I did this the editor came up I typed it all in. Then I saved. But when i went to home and then went to the file it wasn't there. On the konsole it had "Mutex destroy failure: Device or resource busy

What did I do now?
 
Old 11-18-2003, 03:55 AM   #7
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,655

Rep: Reputation: Disabled
Do you truly need wvdial?

MDK 9.1 comes with KDE (afaik). There you will see in the lower task bar something like an (electrical) appliance connector. Click on that -- and whoee you will be duly connected ... that is, if you set up your Modem during install of your distro.
 
Old 11-18-2003, 05:02 AM   #8
Ghostmaster
LQ Newbie
 
Registered: Nov 2003
Location: Third rock from the sun.
Distribution: Mandrake 9.1
Posts: 21

Original Poster
Rep: Reputation: 15
Nope!
 
Old 11-18-2003, 05:17 AM   #9
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,655

Rep: Reputation: Disabled
Nope what?

You don't need wvdial?
You don't have KDE?
You don't have the plug-symbol?
You don't get connected?
You didn't set up your modem?

Or what?
Please specify, so we can try to help you.
 
Old 11-18-2003, 05:45 AM   #10
Ghostmaster
LQ Newbie
 
Registered: Nov 2003
Location: Third rock from the sun.
Distribution: Mandrake 9.1
Posts: 21

Original Poster
Rep: Reputation: 15
I need wvdial
Instructions said that I do

I have KDE I have Gnome too.

I don't have the plug-symbol No where on my desktop <<<-----Nope!

It didn't set up my modem It didn't detect a modem at set up. Only thing I can think of as to why I don't have it.
 
Old 11-18-2003, 05:58 AM   #11
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,655

Rep: Reputation: Disabled
Aha. So. If you just want to set up your connection, you don't need wvdial -- that's just one way to do it. I'd suggest easiest is to go into drak-control(?) and make up on the modem setup.

If you want to follow instructions (whose, btw.?) I'd suggest you first make sure the directory and file (wvdial.config) are exactly where they are supposed to be -- in other words, since you wrote I think the file path is /home/myusername/ltmodem-8.26a9/wvdial.conf you are not sure? If/When you found it run ls -l (thats small Ls -L) on it to see the permissions as to make sure that they are the issue.

Post results and we will try from there.

Last edited by JZL240I-U; 11-18-2003 at 06:07 AM.
 
Old 11-18-2003, 06:48 AM   #12
Ghostmaster
LQ Newbie
 
Registered: Nov 2003
Location: Third rock from the sun.
Distribution: Mandrake 9.1
Posts: 21

Original Poster
Rep: Reputation: 15
sheesh how do you mount and unmount and write to a floppy in the konsole? It seems as though I can't do that either. I was going to transfer the file to my pc that is online and paste it to here but i don't have write permission on the floppy either under user. I should be able to change that. Sheesh! It is a good thing to know I will be laughing at all of this a year from now.

*Hides hammer*

Have you hugged your pc today?
 
Old 11-18-2003, 06:57 AM   #13
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,655

Rep: Reputation: Disabled
Btw. you might want to use an other editor (like Kate) to make sure the error doesn't stem from that source.

[Change of Topic]

If you have problems to mount a floppy have a look at /etc/fstab. Somewhere in there is a line like:
Code:
/dev/fd0  /mnt/floppy  auto  rw,user  0  0
Make sure the fourth column has the user option. Else only root has permission to manipulate devices. Oh yes, if you edít /etc/fstab you have to
Code:
mount -a
or to restart the system.

Last edited by JZL240I-U; 11-18-2003 at 06:59 AM.
 
Old 11-18-2003, 07:24 AM   #14
Ghostmaster
LQ Newbie
 
Registered: Nov 2003
Location: Third rock from the sun.
Distribution: Mandrake 9.1
Posts: 21

Original Poster
Rep: Reputation: 15
kate says I don't have write permission. How do I get to /etc/fstab?

Talk about lockdown!
 
Old 11-18-2003, 07:32 AM   #15
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,655

Rep: Reputation: Disabled
Oh, I meant Kate for wvdial.config, but you can use it here as well, of course.

Ah, well. You do graphical login? If so type into the field user "root" (without the "'s) and at password ... well you might guess. Then you are logged in as root and the hassle is over.

WARNING: From here you can kill your system. Get out of root as soon as possible. Don't do anything you don't know exactly what the consequences are.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to put file 4GB file INSIDE iso saravkrish Linux - Software 2 03-23-2005 03:41 PM
hi i just want to know where to put the .dll file Paxmaster Linux - Software 1 10-20-2004 04:54 PM
where to put path to include file bonosa Linux - Newbie 1 05-25-2004 08:27 AM
Which rc.d file should I put 'adsl-start'? scatterbrain Linux - Newbie 1 03-27-2004 01:18 PM
Where does the Mozilla put the downloaded file? duzhenhuan Linux - Software 1 02-24-2004 05:23 AM


All times are GMT -5. The time now is 07:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration