LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-12-2004, 01:05 PM   #1
dominant
Member
 
Registered: Jan 2004
Posts: 409

Rep: Reputation: 30
pure-ftpd seem that has a bug


I run a pure-ftpd server.

Every client can connect to that server but when he gives LS or DIR he cannot see anything.

Code:
ftp> bin
200 TYPE is now 8-bit binary
ftp> put wc
local: wc remote: wc
229 Extended Passive mode OK (|||27180|)
......and then hangs

Do you know if this is a know problem or something?
 
Old 11-12-2004, 06:02 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Are you trying to connect go through a NAT firewall? FTP has problems with that (I made a post on this a month or so ago -- if you search, you can probably find it). If so, try using the pasv command (or however you enter passive mode) into your FTP client.
 
Old 11-13-2004, 07:46 AM   #3
dominant
Member
 
Registered: Jan 2004
Posts: 409

Original Poster
Rep: Reputation: 30
No there is not NAT in the firewall of the server.
Could be a passive or active handling of the connection on the server side or client side respectively?

How can turn to the PASSIVE when i use the DOS ftp client or something?
 
Old 11-13-2004, 02:12 PM   #4
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
I think you just type "passive" in the DOS FTP client. If there's no NAT between client and server, it's possible that a firewall on the client and server is causing this difficulty, which seems to occur when FTP tries to open a second connection (the protocol uses two connections, one for commands and the other for data) and is unable to do so.
 
Old 11-14-2004, 05:44 AM   #5
dominant
Member
 
Registered: Jan 2004
Posts: 409

Original Poster
Rep: Reputation: 30
Server's firewall has 20 and 21 port opened. Is that what you mean?
 
Old 11-15-2004, 11:20 AM   #6
dominant
Member
 
Registered: Jan 2004
Posts: 409

Original Poster
Rep: Reputation: 30
I flushed all the server's firewall rules and then i could ftp the server properly.

So what should i add to my iptables script and let the passive mode of ftp?

Thanks in advance
 
Old 11-20-2004, 11:25 AM   #7
Neochubbz
LQ Newbie
 
Registered: Apr 2004
Location: Teh Pi Vault
Distribution: Red Hat WS ver. 3
Posts: 6

Rep: Reputation: 0
Yeah, I'm having the same problem, except I'm using a TLS encryption layer over the communication port. For a client, I'm using SmartFTP, which was recommended on the pure-ftpd site. I have problems when it successfully connects and then the server times out when the client issues a LIST command.
Thank you in advance.

-Chubbz
 
Old 11-20-2004, 12:49 PM   #8
dominant
Member
 
Registered: Jan 2004
Posts: 409

Original Poster
Rep: Reputation: 30
You must turn on the Active Mode, on your ftp client.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pure-ftpd roofy Linux - Software 6 03-05-2007 05:06 AM
pure-ftpd help. Drolith Linux - Software 3 11-13-2005 02:50 PM
pure-ftpd help hongman Linux - Software 16 04-06-2005 12:18 PM
Pure-ftpd zaicheke Linux - Software 2 08-19-2004 07:20 PM
help with pure-ftpd blank Linux - General 3 03-31-2002 11:54 AM


All times are GMT -5. The time now is 10:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration