LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-10-2008, 11:31 AM   #1
thunderheights
LQ Newbie
 
Registered: Jan 2008
Location: Kentucky
Posts: 22

Rep: Reputation: 0
Smile Puppy used to turn off computer via power-off....but now just halts system...(solved)


HI!
I've read several threads similar to my problem...but no resolution.
When I hit Power-off computer...system halts...but computer does not shutdown. Have to turn off power manually. NO, it's not that hard to do.. but something's not working right and I want to fix it. It used to turn the computer off. I've apparently messed up something! All other OS turn off computer fine.

puppy linux 2.12

sh-3.00# fdisk -l

Disk /dev/hda: 30.6 GB, 30614814720 bytes
255 heads, 63 sectors/track, 3722 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 2550 20482843+ c W95 FAT32 (LBA)
/dev/hda2 2551 3060 4096575 83 Linux
/dev/hda3 3061 3570 4096575 83 Linux
/dev/hda4 3571 3722 1220940 82 Linux swap / Solaris

Thanks

Last edited by thunderheights; 07-05-2008 at 12:11 AM. Reason: s
 
Old 02-10-2008, 01:24 PM   #2
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
Does your board use APM or ACPI? Have you done any changes in the BIOS configuration lately?

Please post the output of:
Code:
ps aux | grep apm
Code:
ps aux | grep acpi
 
Old 02-10-2008, 05:07 PM   #3
thunderheights
LQ Newbie
 
Registered: Jan 2008
Location: Kentucky
Posts: 22

Original Poster
Rep: Reputation: 0
ps aux | grep apm....nothing

5610 root 584 S grep acpi
 
Old 02-10-2008, 06:03 PM   #4
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
Without you answering the questions that were asked that doesn't really tell us much. That said, you don't seem to be running either the APM or ACPI daemons, which is possibly the cause of your problem. If your board is APM, try loading the apm module:
Code:
modprobe apm
If it loads fine (check with lsmod), try shutting-down again.

If your board is ACPI, try manually starting acpid, which on most distros would go like:
Code:
/etc/init.d/acpid start
Then try shutting-down again.
 
Old 02-11-2008, 02:28 PM   #5
thunderheights
LQ Newbie
 
Registered: Jan 2008
Location: Kentucky
Posts: 22

Original Poster
Rep: Reputation: 0
Sorry I had trouble at first ...

sh-3.00# ps aux | grep apm
7045 root SW [kapmd]
7127 root 580 S grep apm
sh-3.00# ps aux | grep acpi
7143 root 580 S grep acpi
sh-3.00#
 
Old 02-11-2008, 06:39 PM   #6
ehawk
Senior Member
 
Registered: Jul 2003
Posts: 1,257

Rep: Reputation: 48
How about entering "poweroff" at the command line? May need su or sudo to get root privileges.
 
Old 02-12-2008, 02:27 PM   #7
thunderheights
LQ Newbie
 
Registered: Jan 2008
Location: Kentucky
Posts: 22

Original Poster
Rep: Reputation: 0
win32sux,
I followed your instructions and shutdown problems are no more!
Thank You!
 
Old 02-12-2008, 02:50 PM   #8
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
Quote:
Originally Posted by thunderheights View Post
win32sux,
I followed your instructions and shutdown problems are no more!
Thank You!
That's great, but keep in mind that you'd still need to make adjustments to your startup scripts for the change to be permanent. Like, say that loading the apm module did the trick, you'd need to add said module to the list of modules to be loaded at startup. Or say that running the acpid init script did the trick, you'd need to figure-out why the script isn't getting run at startup in the first place.
 
Old 02-13-2008, 08:12 PM   #9
thunderheights
LQ Newbie
 
Registered: Jan 2008
Location: Kentucky
Posts: 22

Original Poster
Rep: Reputation: 0
your right...I'm still having trouble...when shutting down, I get the message..
shutting down / : recources busy or unavailable...and in the tmp file I get lots of missing mods txt files...any ideas?

Last edited by thunderheights; 02-13-2008 at 08:22 PM.
 
Old 02-13-2008, 08:27 PM   #10
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
I still have no clue which of the procedures allowed you box to shutdown properly. Additionally, it would be great if you could clarify whether or not the busy resources error appears only when you carry-out the procedure. I don't understand what you mean with "mods txt". Please try to be as verbose as possible when you post replies.

Last edited by win32sux; 02-13-2008 at 08:28 PM.
 
Old 02-14-2008, 11:58 AM   #11
thunderheights
LQ Newbie
 
Registered: Jan 2008
Location: Kentucky
Posts: 22

Original Poster
Rep: Reputation: 0
Sorry...I'm still new and half the time have no idea what I'm doing...must be a slow learner...but I do appreciate the time spent helping me...
lsmod produced :

rivafb 52672 0
vgastate 9904 1 rivafb
snd_via82xx 27720 0
gameport 14904 1 snd_via82xx
snd_ac97_codec 90448 1 snd_via82xx
snd_ac97_bus 2128 1 snd_ac97_codec
snd_pcm 77592 2 snd_via82xx,snd_ac97_codec
snd_timer 23540 1 snd_pcm
snd_page_alloc 10008 2 snd_via82xx,snd_pcm
snd_mpu401_uart 8112 1 snd_via82xx
snd_rawmidi 24064 1 snd_mpu401_uart
snd_seq_device 7996 1 snd_rawmidi
snd 51396 8 snd_mixer_oss,snd_via82xx,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_devic e
soundcore 9408 1 snd
parport_pc 32100 1
parport 35080 2 lp,parport_pc
via_agp 9648 1
agpgart 34608 1 via_agp
uhci_hcd 23356 0
usbcore 126116 3 usb_storage,uhci_hcd
nls_iso8859_1 3984 0
nls_cp437 5648 0
sh-3.00#
*

Last edited by thunderheights; 02-18-2008 at 04:50 PM.
 
Old 02-14-2008, 12:00 PM   #12
thunderheights
LQ Newbie
 
Registered: Jan 2008
Location: Kentucky
Posts: 22

Original Poster
Rep: Reputation: 0
sorry..this post was too long

Last edited by thunderheights; 02-18-2008 at 04:51 PM.
 
Old 02-14-2008, 12:00 PM   #13
thunderheights
LQ Newbie
 
Registered: Jan 2008
Location: Kentucky
Posts: 22

Original Poster
Rep: Reputation: 0
file too long

Last edited by thunderheights; 02-18-2008 at 04:52 PM.
 
Old 02-14-2008, 12:16 PM   #14
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
Next time please use code tags when you decide to post stuff like this. It makes things easier for everybody. That said, the questions I asked you in my previous post are still up in the air.

After a quick look at your init script, it would seem you'd just need to add the appropriate line in /etc/rc.d/rc.modules in order for your apm module to be automatically loaded. That is, of course, if you are on an APM board (which we don't really know since it's one of the questions we've never received and answer for).
 
Old 02-18-2008, 05:14 PM   #15
thunderheights
LQ Newbie
 
Registered: Jan 2008
Location: Kentucky
Posts: 22

Original Poster
Rep: Reputation: 0
ok! found the problems!
puppy linux not shutting down...just halting system.
opened /boot/grub/menulst and
added..."PMEDIA=idehd acpi=force" to the end of kernel boot line..so it looked like this..
kernel /boot/vmlinuz root=/dev/hda2 ro vga=normal PMEDIA=idehd acpi=force
rebooted...shutdown problem fixed..
as for the missingmods.txt files...

SP212 - Unofficial Service Pack for Puppy 212

this fixes a minor bug ... files called missingmods*.txt are being created in /tmp
and are not being deleted
you can download the fix here:
http://www.murga-linux.com/puppy/viewtopic.php?&t=12907
Thanks for all the help...and advice on posting!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there any way to turn off the computer power without pushing the button? Necronomicom Slackware 11 02-27-2006 04:50 AM
Press power button can't turn down the computer shadkong Linux - Hardware 2 05-04-2005 10:50 PM
System halts but doesnt power down laptop Boomba Linux - Software 4 02-02-2005 10:42 PM
Computer doesn't turn off when halting system sfbence Linux - Hardware 4 05-23-2004 08:06 PM
kernel halts, system halts, computer commits suicide stupid_guy Linux - Newbie 10 06-07-2003 06:44 PM


All times are GMT -5. The time now is 11:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration