LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Puppy On Hard Drive Fails To Boot After Power Cut (http://www.linuxquestions.org/questions/linux-newbie-8/puppy-on-hard-drive-fails-to-boot-after-power-cut-876025/)

Pupski 04-19-2011 10:50 PM

Puppy On Hard Drive Fails To Boot After Power Cut
 
Hi Everyone,

I'm very new to Linux and recently setup a desktop PC with Puppy 5.2.5. only. I chose to have a permanent install on the hard drive and loaded additional PETS and utilities as I thought needed for my use. Last night after immediately booting up the PC I had a power cut lasting a few minutes. When power returned and I repowered the PC, I found during Puppy's boot sequence it reported an error and remained in what appeared to be a console mode - did not carry through and load my desktop. So I inserted the Puppy CD and booted from that but I'm afraid I'm not familiar enough with Linux to understand how I can get back my original desktop setup and run once again from my hard drive without having to go back to scratch.

Does anyone have any words of wisdom to help me out of my situation?

Many thanks.

rokytnji 04-20-2011 01:14 AM

Full or frugal install?

First thing I would try. Boot up live Puppy CD. Open gparted. Unmount partition where Puppy is installed with right click on partition with gparted. Then right click again and do a check. Hit apply. Let it do a fsck check on partition. Exit gparted when done. Shutdown. Eject CD without saving changes. See if your installed Puppy boots up.

If it boots up and is a frugal install.

go to /mnt/home and copy and paste personal pupsave.sfs to a pendrive or cd or internal fat32 partition so in case it corrupts. You can delete old corrupt personalpupsave.sfs and reinsert saved good personalpupsave.sfs off of backup. I do this with all frugal installs of Puppy Linux. Saves losing changes.

http://puppylinux.org/main/Manual-English.htm

http://www.murga-linux.com/puppy/viewtopic.php?t=54231

http://www.murga-linux.com/puppy/vie...83950d5daa6f28

http://wellminded.com/puppy/pupsearch.html

Pupski 04-20-2011 04:58 AM

Thanks for the quick reply Rokytnji.

My install is a full and not frugal. I'll give your advice a go later this evening and let you know the outcome.

colorpurple21859 04-20-2011 05:33 AM

No need to use the cd, at the prompt type
Quote:

startx
you will get some sort of prompt about do you want to run xorgwizard, say no. If that doesn't work type
Quote:

xorgwizard
at the prompt. This is normal for unexpected power loss in puppy.

Pupski 04-20-2011 06:17 AM

Many thanks Colorpurple21859. startx did the trick and returned my desktop - phew!

Pupski 04-20-2011 06:24 AM

Sorry Rokytnji a no go. I followed your advice on gparted but when rebooted I was still left with # _ (blinking). Subsequently colorpurple21859 advice came in and worked - enter "startx" at prompt. Appreciate your effort to help though! I'm very glad to see quick assistance is at hand on this forum.


All times are GMT -5. The time now is 08:24 PM.