LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-17-2011, 08:30 PM   #1
WARemick
LQ Newbie
 
Registered: May 2011
Location: New Hampshire
Distribution: Puppy Lucid 5.2.5
Posts: 1

Rep: Reputation: Disabled
Puppy Lucid 5.2.5 Full -clean- install grub loader fails.


I have a problem trying to install a working grub to my new install. I think I am following the proper setup but as always I get an error 15 file not found. My layout is this... on a 40gig hard drive I have 5meg for grub as /dev/sda1 (set as boot).. next is 5meg for swap .. Last is the rest for my puppy linux install. I am aware that (hd0,0) is /dev/sda1 and (hd0,2) is /dev/sda3 but my editing of the menu.lst seems not to work. Please help out a noob, any help is GREATLY needed.
Thanks, BillR.

This is my menu.lst... and I did install grub to MBR and without .. still a no-go.
--------------------------------------------------------------------------------------
# GRUB configuration file '/boot/grub/menu.lst'.
# generated by 'grubconfig'. Tue May 17 04:25:05 2011
#
# The backup copy of the MBR for drive '/dev/sda' is
# here '/boot/grub/mbr.sda.7939'. You can restore it like this.
# dd if=/boot/grub/mbr.sda.7939 of=/dev/sda bs=512 count=1
#
# Start GRUB global section
#timeout 30
color light-gray/blue black/light-gray
# End GRUB global section
# Linux bootable partition config begins
title Linux (on /dev/sda1)
root (hd0,0)
kernel /boot/vmlinuz root=/dev/sda1 ro vga=normal
# Linux bootable partition config ends
# Linux bootable partition config begins
title Linux (on /dev/sda3)
root (hd0,2)
kernel /boot/vmlinuz root=/dev/sda3 ro vga=normal
# Linux bootable partition config ends
# Linux bootable partition config begins
title Linux (on /dev/sdb1)
root (hd1,0)
kernel /boot/vmlinuz root=/dev/sdb1 ro vga=normal
# Linux bootable partition config ends
title Install GRUB to floppy disk (on /dev/fd0)
pause Insert a formatted floppy disk and press enter.
root (hd0,0)
setup (fd0)
pause Press enter to continue.
title Install GRUB to Linux partition (on /dev/sda1)
root (hd0,0)
setup (hd0,0)
pause Press enter to continue.
title - For help press 'c', then type: 'help'
root (hd0)
title - For usage examples, type: 'cat /boot/grub/usage.txt'
root (hd0)

Last edited by WARemick; 05-18-2011 at 04:35 AM. Reason: additional info. requested
 
Old 05-17-2011, 08:48 PM   #2
Mr. Bill
Member
 
Registered: Mar 2011
Location: Maryland, USA
Distribution: Xubuntu 14.04 - 64
Posts: 182

Rep: Reputation: 14
You didn't really need a separate partition for grub, but it does need to go on the MBR of a boot partition. Also, it should've detected Puppy during grub installation. Did you try booting before editing menu.lst? It would help if you could post menu.lst so we can try find your problem.
 
1 members found this post helpful.
Old 05-25-2011, 07:30 PM   #3
Mr. Bill
Member
 
Registered: Mar 2011
Location: Maryland, USA
Distribution: Xubuntu 14.04 - 64
Posts: 182

Rep: Reputation: 14
In the future, please post requested info in a new post. We don't receive notifications for edits.

Grub is seeking a bootable kernel on all 3 partitions. You need to completely remove the entries for the grub and swap partitions from menu.lst. Puppy will find and mount the swap partition while booting.

Last edited by Mr. Bill; 05-25-2011 at 07:33 PM.
 
Old 05-25-2011, 08:32 PM   #4
Mr. Bill
Member
 
Registered: Mar 2011
Location: Maryland, USA
Distribution: Xubuntu 14.04 - 64
Posts: 182

Rep: Reputation: 14
Upon closer inspection, I noticed something you didn't mention:

Quote:
title Linux (on /dev/sdb1)
Do you have a second physical hdd installed? If so, what is on it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No grub files in full install of Puppy 5.2 psionl0 Puppy 3 01-30-2011 01:26 PM
[SOLVED] Grub boot loader with puppy linux jcmahne Linux - Newbie 6 11-02-2010 06:51 AM
LXer: Puppy 5.1 codename Lucid is out- Now is compatible with Ubuntu 10.04 Lucid Lynx package LXer Syndicated Linux News 0 08-15-2010 02:20 PM
puppy 5.01 grub loader afullmetalwar Linux - Software 2 06-03-2010 12:53 PM
Grub does not see windows partition after full Puppy install. Pearci Linux - Newbie 6 06-04-2008 07:02 PM


All times are GMT -5. The time now is 07:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration