LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Puppy Linux: > Boot fails, Grub stage 1.5, error 15. (http://www.linuxquestions.org/questions/linux-newbie-8/puppy-linux-boot-fails-grub-stage-1-5-error-15-a-746783/)

johnbartley 08-11-2009 12:43 PM

Puppy Linux: > Boot fails, Grub stage 1.5, error 15. [SOLVED]
 
Boot fails, Grub stage 1.5, error 15.
Installed puppy (tried both Lighthouse Pup 4.4.2-c and MiPup 2.6) to hard drive after trying both Kubuntu and Debian 5 (installed AOK).

I can boot from a Super Grub Disk boot floppy if I select Linux >2 then the menu.lst

Confirmed contents of /boot/grub/menu.lst as:
title Puppy Linux 442 full install
root (hd0,0)
kernel /boot/vmlinuz root=/dev/sda1 pmedia=atahd

vmlinuz is in /boot, BTW

have only one hd and puppy is on first partition.

Kernel 2.6.28.5

Your kind assistance would be appreciated.

linus72 08-11-2009 12:48 PM

Welcome to LQ johnbartley!

Mmmm, your menu.lst looks right...

Puppy installed grub, you installed grub, or grub was already installed via Kbuntu?

Which pup is installed to hd now/?
Lighthouse?
Lighthouse is cool huh?

I did the frugal install of lighthouse "by hand" into my ubutnu partition.

Also, can you tell us your machine specs?

johnbartley 08-11-2009 02:29 PM

Quote:

Originally Posted by linus72 (Post 3639561)
Welcome to LQ johnbartley!

Mmmm, your menu.lst looks right...

Puppy installed grub, you installed grub, or grub was already installed via Kbuntu?

wiped the first partition with gparted then reinstalled Full from Puppy-Lighthouse.



Quote:

Which pup is installed to hd now/?
Lighthouse?
Yes

Quote:

Lighthouse is cool huh?

I did the frugal install of lighthouse "by hand" into my ubutnu partition.

Also, can you tell us your machine specs?
1.2GHz Celeron, 20GB 5400rpm PATA HD, 256MB RAM.

Cool, is what works.

johnbartley 08-12-2009 05:55 PM

Solved
 
Found the version of gparted (0.45) borks when used with a partition created wuth Intrepid Ibex (*buntu 9.04), which sets inode=256 . Blew away the hard drive, reformatted, changed the inode to 128. Works fine now with no changes to menu.lst .


All times are GMT -5. The time now is 02:04 AM.