LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   PS/2 Keyboard not working after being "detected" by slackware 12.1 install disk (http://www.linuxquestions.org/questions/linux-newbie-8/ps-2-keyboard-not-working-after-being-detected-by-slackware-12-1-install-disk-675473/)

bushbaby 10-10-2008 06:12 AM

PS/2 Keyboard not working after being "detected" by slackware 12.1 install disk
 
Keyboard works when I hit enter after "boot:"
then slackware detects my keyboard as
"Input: AT Translated Set 2 keyboard as /class/input/input2"
Next line is "Creating /dev/mapper/control character device with major:10 minor:62" (not sure if this line is keyboard-related)
and asks me to accept US keyboard layout or type 1 to change layout.
At this point my keyboard no longer works.

I have tried
1. editing Bios settings to disable/enable usb input but no effect.
2. other keyboards - all ps/2.
3. checking keyboard works on windows - current os on pc. It does.

Any help would be much appreciated.
Is there a way of telling slackware which keyboard-type to use and over-ride the auto-detect facility?

Nightfish 10-10-2008 06:20 AM

well there's no need for bios if window$ get's it.
can you press numlock? does it change? or is your keyboard inert?

Fedora Development

bushbaby 10-10-2008 06:35 AM

None of the buttons on the keyboard do anything after detection.

brianL 10-10-2008 06:50 AM

Might be better if you asked for this to be moved to the Slackware forum.

bushbaby 10-10-2008 08:33 AM

Quote:

Originally Posted by brianL (Post 3306031)
Might be better if you asked for this to be moved to the Slackware forum.


Yes. How do i contact a moderator?

bushbaby 10-10-2008 08:37 AM

Sorted.
Well the immediate problem anyway.

I was using a usb mouse and wondered if this was an issue.
I tried adding a ps/2 adapter to the mouse usb and hey presto! Keyboard now correctly identified as "Input: AT Translated Set 2 keyboard as /class/input/input1" and works fine.

brianL 10-10-2008 10:01 AM

Glad it's sorted out. If you had had to ask for it to be moved, use the Report button below.


All times are GMT -5. The time now is 07:58 PM.