LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-02-2009, 01:38 PM   #1
harksaw
LQ Newbie
 
Registered: Nov 2009
Posts: 19

Rep: Reputation: 2
Programs open up on wrong screen


I have a TV screen and a regular computer monitor - for some reason programs keep opening up on the TV screen rather than the monitor, even though I have the monitor selected as the "Primary Display" on the 'Nvidia X Server Settings" program.

I believe it's a KDE thing, but I don't know what setting to change.

I'm on Slackware 13, KDE 4.2.4. TIA!
 
Old 12-02-2009, 07:17 PM   #2
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Rep: Reputation: 90
Maybe you just need to reverse the connections on the video card?
 
Old 12-04-2009, 01:50 PM   #3
harksaw
LQ Newbie
 
Registered: Nov 2009
Posts: 19

Original Poster
Rep: Reputation: 2
Is there no way to do this in software?
 
Old 12-04-2009, 02:09 PM   #4
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 720Reputation: 720Reputation: 720Reputation: 720Reputation: 720Reputation: 720Reputation: 720
It happened to me a few times, I too just swap the connectors on the back of the computer.
 
Old 12-07-2009, 10:18 AM   #5
harksaw
LQ Newbie
 
Registered: Nov 2009
Posts: 19

Original Poster
Rep: Reputation: 2
I've switched my two connectors and I still have the same problem - stuff often opens up on the wrong screen. It's actually happening more often now that I've switched them. It's very annoying when I try to launch a full screen game and it goes on my TV and blacks out my monitor.

I"m using KDE - I can't find anything in the settings that controls which screen new programs open up on.
 
Old 12-07-2009, 11:40 AM   #6
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Rep: Reputation: 90
Quote:
Originally Posted by harksaw View Post
I've switched my two connectors and I still have the same problem - stuff often opens up on the wrong screen. It's actually happening more often now that I've switched them. It's very annoying when I try to launch a full screen game and it goes on my TV and blacks out my monitor.

I"m using KDE - I can't find anything in the settings that controls which screen new programs open up on.
How many video cards do you have? Two or one with two connections? What kind of connections are on the card(s) and what kind are you using?
It kind of sounds like a driver problem, I think you're on the right track. But we need to make things a bit more clear first. What kind of settings do you have in the bios for video? Did you install a new video card after an OS install? Did the card(s) give any type of trouble before you hooked up the tv?
 
Old 12-07-2009, 01:08 PM   #7
harksaw
LQ Newbie
 
Registered: Nov 2009
Posts: 19

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by SharpyWarpy View Post
How many video cards do you have? Two or one with two connections?
One with two connections

Quote:
What kind of connections are on the card(s) and what kind are you using?
Two DVI connectors, one of which has a converter to HDMI that goes to my TV.

Quote:
What kind of settings do you have in the bios for video?
I'll check . .

Quote:
Did you install a new video card after an OS install?
No.
Quote:
Did the card(s) give any type of trouble before you hooked up the tv?
No
 
Old 12-07-2009, 08:04 PM   #8
SharpyWarpy
Member
 
Registered: Feb 2003
Location: Florida
Distribution: Fedora 18
Posts: 862

Rep: Reputation: 90
I can't help with KDE, I use Gnome. But I think it has more to do with the nvidia drivers. Where did you get them? Did you download them from the Nvidia site?
 
Old 12-09-2009, 12:36 AM   #9
harksaw
LQ Newbie
 
Registered: Nov 2009
Posts: 19

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by SharpyWarpy View Post
I can't help with KDE, I use Gnome. But I think it has more to do with the nvidia drivers. Where did you get them? Did you download them from the Nvidia site?
They are the nvidia 190.42 drivers downloaded off of nvidia's website.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"screen" not working properly ( .screen folder in wrong place) ledow Slackware 4 01-11-2009 03:54 PM
Fluxbox on Ubuntu - I can't do anything but open the menu. Can't open programs. IMNOboist Linux - Desktop 1 12-14-2008 02:48 AM
Wrong Screen Alignment sloteel SUSE / openSUSE 7 11-11-2007 09:40 AM
All windows and programs open in very top left corner of screen rcgoodfellow Linux - Software 1 04-27-2007 12:11 PM
Arent alloved to install programs, something wrong uro Linux - Newbie 7 04-09-2006 11:18 AM


All times are GMT -5. The time now is 10:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration