LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-23-2006, 07:42 PM   #1
Ab3n
Member
 
Registered: Sep 2004
Location: Colorado, USA
Distribution: CentOS 5
Posts: 144

Rep: Reputation: 15
ProFTPD won't let me browse files


Hey all,

I have recently set up a proftpd server on a slack 10.2 machine, but whenever I connect to it over the internet (via smartftp) it gives me this error once I have successfully logged in:


Code:
220 ProFTPD 1.2.10 Server (Joe's FTP Server) [192.168.2.140]
    USER chris
331 Password required for chris.
    PASS (hidden)
230 User chris logged in.
    SYST
215 UNIX Type: L8
    FEAT
211-Features:
 MDTM
 REST STREAM
 SIZE
211 End
    PWD
257 "/home/chris" is current directory.
    TYPE I
200 Type set to I
    PASV
227 Entering Passive Mode (192,168,2,140,128,68).
    Opening data connection to 192.168.2.140 Port: 32836
    LIST -aL
    A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    Timeout (40s).
    Active Help: http://www.smartftp.com/support/kb/index.php/74
    Client closed the connection.
    Automatic failover of data connection mode from "Passive Mode (PASV)" to "Active Mode (PORT)".
Any Help?
 
Old 01-24-2006, 12:52 PM   #2
xhi
Senior Member
 
Registered: Mar 2005
Location: USA::Pennsylvania
Distribution: Slackware
Posts: 1,065

Rep: Reputation: 45
is passive mode enabled on the server?
 
Old 01-24-2006, 01:06 PM   #3
Ab3n
Member
 
Registered: Sep 2004
Location: Colorado, USA
Distribution: CentOS 5
Posts: 144

Original Poster
Rep: Reputation: 15
I honestly have no idea...how do you check that and how would I change it? Is it in the proftpd.conf?

Last edited by Ab3n; 01-24-2006 at 01:39 PM.
 
Old 03-09-2006, 02:24 PM   #4
Ab3n
Member
 
Registered: Sep 2004
Location: Colorado, USA
Distribution: CentOS 5
Posts: 144

Original Poster
Rep: Reputation: 15
I've added this to the end of my proftpd.conf:

Code:
PassivePorts 10000 10050
I entered this command on the server:

Code:
iptables -A INPUT -p tcp --dport 10000:10100 -j ACCEPT
I've also added them to my port forwarding list on the router...unfortunately it still only allows me to connect through active mode when outside the network...any help?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I browse files on a VPN connection? joekm Linux - Networking 1 11-28-2005 03:38 PM
browse linux files from windows. FLOODS Linux - Networking 2 05-03-2004 09:11 PM
Can browse network but can't download files mcgiv Linux - Networking 5 09-30-2003 11:05 AM
how to browse files from command promt snoop24 Linux - Newbie 2 09-15-2003 11:28 AM
browse ntfs files on redhat 9.0 Bigmike Linux - Networking 1 08-03-2003 08:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration