LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-09-2004, 02:48 PM   #1
tumana
Member
 
Registered: Mar 2004
Location: Belgium
Posts: 102

Rep: Reputation: 15
proftpd: proftpd startup failed


I am running Mandrake 10.0 after very recently having purchased it. Mandrake 9.2 seamed to have worked with this issue, but 10 is giving me some problems.

I installed Mandrake 10 for the first time yesterday. One of the several problems is that I can't seem to configure my ProFTP daemon. I've edited the /etc/proftpd.conf file, checked my folder permissions, I even installed Webmin to see if their user interface might point something out I forgot with the text editor.

After making configuration changes, I tried restarting the proftpd service using
Code:
service -f proftpd
but I got the following error:
Code:
Shutting down proftpd:                                          [FAILED]
Starting proftpd:  - getaddrinfo 'delta2' error: Name or service not known
 - error: unable to determine IP address of 'delta2'
 - error: no valid servers configured
 - Fatal: error processing configuration file '/etc/proftpd.conf'
                                                                [FAILED]
I know I have an IP address because I can surf the web and ifconfig tells me I have one. I'm also obviously logged on as root.

I get the same stuff in my boot.log file
Code:
Jun  9 13:56:34 delta2 proftpd:  - getaddrinfo 'delta2' error: Name or service not known
Jun  9 13:56:34 delta2 proftpd:  - error: unable to determine IP address of 'delta2'
Jun  9 13:56:34 delta2 proftpd:  - error: no valid servers configured
Jun  9 13:56:34 delta2 proftpd:  - Fatal: error processing configuration file '/etc/proftpd.conf'
Jun  9 13:56:34 delta2 proftpd: proftpd startup failed
Can someone please help? Thanks in advance.

ian
 
Old 06-09-2004, 03:24 PM   #2
Donboy
Member
 
Registered: Aug 2003
Location: Little Rock, Arkansas
Distribution: RH, Fedora, Suse, AIX
Posts: 736

Rep: Reputation: 31
Might help seeing your config file. Also, you may want to be sure the config file is in unix format and not Windows format. You can check by doing...

Code:
vi -b /etc/proftpd.conf
and see if there are any ^M characters showing up at the end of each line.
 
Old 06-09-2004, 04:04 PM   #3
tumana
Member
 
Registered: Mar 2004
Location: Belgium
Posts: 102

Original Poster
Rep: Reputation: 15
First off, thanks for the reply.

I tried opening proftpd.conf in binary mode and there were no ^M characters. Here is the config file:

Code:
# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName                      "Delta2 FTP Server"
ServerType                      standalone
DefaultServer                   on

# Allow FTP resuming.
# Remember to set to off if you have an incoming ftp for upload.
AllowStoreRestart               on

# Port 21 is the standard FTP port.
Port                            21

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask                           022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
MaxInstances 10

# Set the user and group under which the server will run.
User                            nobody
Group                           nogroup

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
#DefaultRoot ~

# Normally, we want files to be overwriteable.
<Directory />
  AllowOverwrite                on
</Directory>

# Needed for NIS.

PersistentPasswd              off

# Default root can be used to put users in a chroot environment.
# As an example if you have a user foo and you want to put foo in /home/foo
# chroot environment you would do this:
#
# DefaultRoot /home/foo foo
DefaultRoot /var/ftp/pub testuser
<Global>
DeleteAbortedStores on
HiddenStor on
RootLogin off
DisplayGoAway ""Too many concurrent connections.""
MaxLoginAttempts 3
UseFtpUsers on
</Global>
The only thing that bugs me are these lines:
Code:
# Set the user and group under which the server will run.
User                            nobody
Group                           nogroup
There is no user/group called nobody/nogroup. I remember not having to set a special user/group with my last installation (9.2), so I didn't touch these lines. I left them as they were.

Thanks,
ian
 
Old 06-09-2004, 04:41 PM   #4
Donboy
Member
 
Registered: Aug 2003
Location: Little Rock, Arkansas
Distribution: RH, Fedora, Suse, AIX
Posts: 736

Rep: Reputation: 31
Yeah, you'll need to make those. Mine were already made when I installed, so I can see where that's easy to overlook... but yeah, I think you really need them. But I don't know if that's really your problem.. the errors you got seem to suggest that the OS doesn't recognize the service name.
 
Old 06-09-2004, 04:43 PM   #5
tumana
Member
 
Registered: Mar 2004
Location: Belgium
Posts: 102

Original Poster
Rep: Reputation: 15
Should I just create them like a create a normal user? Should they have more permissions than the normal users?

ian
 
Old 06-09-2004, 05:28 PM   #6
tumana
Member
 
Registered: Mar 2004
Location: Belgium
Posts: 102

Original Poster
Rep: Reputation: 15
Well, I went to create a user and group that matched the proftpd.conf file and they already exist! Not that I can see them, but the Mandrake user interface told me a user with that name already exists.

I guess that's not my problem.

ian
 
Old 06-09-2004, 06:16 PM   #7
Donboy
Member
 
Registered: Aug 2003
Location: Little Rock, Arkansas
Distribution: RH, Fedora, Suse, AIX
Posts: 736

Rep: Reputation: 31
What's the contents of your /etc/hosts file? You must have your hostname associated with the IP address you're using for this machine.
 
Old 06-10-2004, 02:14 AM   #8
tumana
Member
 
Registered: Mar 2004
Location: Belgium
Posts: 102

Original Poster
Rep: Reputation: 15
Ha! You're kidding me! The only thing in there is
Code:
127.0.0.1                  localhost
Should I put
Code:
my_ip_address         my_hostname
I'll go ahead and try it. Hope this works.

ian
 
Old 06-10-2004, 02:39 AM   #9
tumana
Member
 
Registered: Mar 2004
Location: Belgium
Posts: 102

Original Poster
Rep: Reputation: 15
Code:
Shutting down proftpd:                                [  OK  ]
Starting proftpd:                                     [  OK  ]
You are a genius!!! It's people like you that make this community work. I afferoed you, by the way.

You have a great day!
ian
 
Old 06-10-2004, 06:25 AM   #10
Donboy
Member
 
Registered: Aug 2003
Location: Little Rock, Arkansas
Distribution: RH, Fedora, Suse, AIX
Posts: 736

Rep: Reputation: 31
No problem. Glad it worked. Thanks very much!
 
Old 05-11-2009, 07:17 AM   #11
enzo24
LQ Newbie
 
Registered: May 2009
Posts: 1

Rep: Reputation: 0
Thanks for the tip ! It did the job for me !
 
Old 06-04-2009, 01:28 AM   #12
bletro
LQ Newbie
 
Registered: Jun 2009
Posts: 1

Rep: Reputation: 0
Thanks Donboy!
Even though I had my FQDN in my hosts file it still didn't work, I had to fill in my short name. (Just a tip)
 
Old 10-16-2009, 02:24 AM   #13
snokendrutt
LQ Newbie
 
Registered: Oct 2009
Posts: 1

Rep: Reputation: 0
Lightbulb Alternative TIP

Quote:
Originally Posted by bletro View Post
Thanks Donboy!
Even though I had my FQDN in my hosts file it still didn't work, I had to fill in my short name. (Just a tip)
I used
Quote:
proftpd.conf
# Bind to Default Adress
DefaultAddress 192.168.0.1
SocketBindTight on
Worked nice for me... Not sure you need SocketBindTight


Last edited by snokendrutt; 10-16-2009 at 02:25 AM.
 
Old 07-21-2010, 10:47 PM   #14
godsoul
LQ Newbie
 
Registered: Jul 2010
Posts: 1

Rep: Reputation: 0
Your questions try this:

vi /etc/hosts

127.0.0.1 delta2
 
Old 06-17-2012, 11:06 AM   #15
SuperBiBi
LQ Newbie
 
Registered: Jun 2012
Posts: 1

Rep: Reputation: Disabled
Smile thanks too much

in /etc/hosts add this:

<your-ip-address> <server-name>

thanks too much, it saves my time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
proftpd chown as root failed john8675309 Linux - Software 2 12-06-2005 04:53 PM
[PROFTPD] Ldap and proftpd authentication wesleywest Linux - Software 1 02-22-2005 09:51 AM
Disabling the chroot in proftpd and enabling root logins on ssh/proftpd jon_k Linux - Software 1 06-16-2004 10:27 AM
proftpd --- need help? could someone post a working proftpd.conf i could look at ZooRoPa Linux - Networking 1 04-02-2003 06:56 PM
How do I disable proftpd on startup amp2000 Linux - General 9 02-12-2002 03:47 PM


All times are GMT -5. The time now is 12:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration