LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-10-2009, 10:38 AM   #1
Deluka
Member
 
Registered: Jul 2009
Location: Belguim
Distribution: Fedora 11
Posts: 42

Rep: Reputation: 16
proftpd not starting at start-up


Hey there
Already thanks for reading this and maybe you can help me
Got a bit a weird problem with my fresh install of fedora 11.
Installed Apache and everything works "out of the box"
Installed proftpd but i always have to start the service manual using #service proftpd start. From what if been reading everything is in place.
This is what i got in chkconfig
proftpd 0 off 1 off 2 on 3 on 4 on 5 on 6 off
Some idea's and help would be welcome.
 
Old 07-10-2009, 03:24 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,671

Rep: Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562
Remove proftpd from runlevel 2. I guess it's trying to start at runlevel 2 where there is no networking and it fails. Runlevels 3,5 are enough for the proftpd service.

Regards
 
Old 07-11-2009, 01:23 AM   #3
Deluka
Member
 
Registered: Jul 2009
Location: Belguim
Distribution: Fedora 11
Posts: 42

Original Poster
Rep: Reputation: 16
Still not kicking in

Hello Bathory
Trying turning the runlevels 2 and now even 4 to off but still no go.
Still got a fail add boot time. Other network depending daemons startup fine at the systems boot.
 
Old 07-11-2009, 02:22 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,671

Rep: Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562
Could you post the error you get?
Also check proftpd.conf and make sure you have:
Code:
ServerType standalone
 
Old 07-11-2009, 03:15 AM   #5
Deluka
Member
 
Registered: Jul 2009
Location: Belguim
Distribution: Fedora 11
Posts: 42

Original Poster
Rep: Reputation: 16
proftpd uses 32-bit capabilities

Found this message in the message log

warning: `proftpd' uses 32-bit capabilities (legacy support in use)

Bit odd because i'm using a 32bit version of the latest fedora
Been looking around and seems libcap library is the cause of this error.
Still pretty new to Linux but if this is the case, why those proftpd start up manuel.
The ServerType is set to standalone
And what is this libcap ? tryed to install it using yum but it can't seem to find it.

Last edited by Deluka; 07-11-2009 at 03:33 AM.
 
Old 07-11-2009, 03:48 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,671

Rep: Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562
This is just a warning, I don't think that because of this, proftpd does not start on system boot.
If you don't have libcap and want to use it to see if it solves your problem, you can get the package for FC 10
 
Old 07-11-2009, 03:57 AM   #7
Deluka
Member
 
Registered: Jul 2009
Location: Belguim
Distribution: Fedora 11
Posts: 42

Original Poster
Rep: Reputation: 16
Found out that i have already version lipcap-2.16.2.fc11.i586 installed on my system.
Indeed proftpd those not seem to need it to work since i can start the daemon by using service proftpd start.
Really a strange problem in my books.
 
Old 07-11-2009, 04:05 AM   #8
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,671

Rep: Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562
In fact. That is why I told you to remove it from runlevel2, because it looks like proftpd tries to start when no network is up.
Try to remove and then re-add proftpd in services:
Code:
chkconfig --del proftpd
chkconfig --levels 35 proftpd on
Also consider running proftpd through xinetd if you have it installed.
 
Old 07-11-2009, 04:22 AM   #9
Deluka
Member
 
Registered: Jul 2009
Location: Belguim
Distribution: Fedora 11
Posts: 42

Original Poster
Rep: Reputation: 16
Well removed it the first time you told me to.
Now removed it completely out of chkconfig and re-added it.
Its now enabled on levels 3 and 5.
I tried to use xinetd on my old system but had to do the same thing.
Start it manually.
 
Old 07-11-2009, 04:27 AM   #10
micxz
Senior Member
 
Registered: Sep 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
bathory: Could you simply put a sym link in the appropriate rc#.d (# being runlevel) dir.
Or is this what chkconfig/insserv does?
 
Old 07-11-2009, 08:09 AM   #11
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,671

Rep: Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562
@OP
Running proftpd through xinetd is a bit different. You must stop proftpd if it's running, edit proftpd.conf and use
Code:
ServerType   inetd
Then you must add a file named proftpd in /etc/xinetd.d/ directory, containing the following:
Code:
service ftp
{
flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/proftpd
log_on_failure += USERID
disable = no
}
Just check if the path /usr/sbin/proftpd is correct and restart xinetd.

@micxz
This is what chkconfig is supposed to do, i.e. create the symlinks to the appropriate rc#.d directories.
 
Old 07-11-2009, 11:45 AM   #12
Deluka
Member
 
Registered: Jul 2009
Location: Belguim
Distribution: Fedora 11
Posts: 42

Original Poster
Rep: Reputation: 16
Talking It works

Hello Bathory.
Done what you told me to do and ProFtpd works like it suppose to.
It now kicks in everytime a client logs in.
Removed the entery in chkconfig and no more errors when booting.

There is just 1 more thing i need to ask.
When i open the services panel i have 2 entry's for FtpPro.
One where the service is disabled and stopped and one has a exclamation mark.
Telling me "Getting information about this service failed".
If you could help or point me to a threat handling this
 
Old 07-11-2009, 12:28 PM   #13
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,671

Rep: Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562Reputation: 1562
Quote:
When i open the services panel i have 2 entry's for FtpPro.
One where the service is disabled and stopped and one has a exclamation mark.
Telling me "Getting information about this service failed".
I guess the fact that you have 2 proftpd entries was the reason for the proftpd startup problem.
I don't know why you get the "Getting information about this service failed" message, but it could happen if there is a pid file left after you disable proftpd from startup services.
 
Old 07-11-2009, 01:14 PM   #14
Deluka
Member
 
Registered: Jul 2009
Location: Belguim
Distribution: Fedora 11
Posts: 42

Original Poster
Rep: Reputation: 16
Well the entry with the exclamation mark appeared when i added the file to the xinetd dir. Its more a cosmetic problem then anything else. Going to take a look around and post the fix here if i find it.

But thx for all off the help

Last edited by Deluka; 07-11-2009 at 01:52 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ProFTPD- > "Starting proftpd: [FAILED]" FC6 Webmin germansoccer6113 Linux - Server 2 01-07-2009 11:19 AM
proftpd starting error tamilm Linux - Networking 1 10-09-2008 10:13 AM
proftpd not starting DigiCrime Linux - Server 0 05-29-2008 01:29 PM
proftpd not starting GlupFire Linux - Networking 4 04-14-2008 12:27 PM
Starting proftpd on boot (/etc/rc.d?) IssacT Slackware 3 08-25-2005 07:05 PM


All times are GMT -5. The time now is 07:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration