LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-21-2003, 03:28 AM   #1
funnyusa
LQ Newbie
 
Registered: Jun 2003
Posts: 13

Rep: Reputation: 0
Proftpd --- can't FXP please help


ok here is my proftpd.conf:
--------------------------
[root@ensim home]# cat /etc/proftpd.conf
# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use. It establishes a single server
# and a single anonymous login. It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName "Funnyusa.net - Funnyusa.org ProFTPD"
ServerType Standalone
DefaultServer on
DefaultRoot ~

# Define this if you want to prevent your server from displaying what FTP
# server and version you are using.
ServerIdent on "Funnyusa.net-Funnyusa.org ProFTPD FTP Server ready."

#Time out parameters
TimeoutIdle 100
TimeoutNoTransfer 150
TimeoutLogin 50

# Port 21 is the standard FTP port.
Port 21

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances 12

# Set the user and group that the server normally runs at.

User funnyusa
Group private

SystemLog /var/log/proftpd.system.log
TransferLog /var/log/proftpd.transfer.log

# Allow resume on both upload and download
AllowStoreRestart on
AllowRetrieveRestart on
DeleteAbortedStores on
HiddenStor off


MaxClientsPerHost 2 "Sorry, only %m per host"
MaxClients 12 "Sorry but we only allow %m ftp connection"

<Limit READ DIRS>
IgnoreHidden off
#IgnoreHidden on
</Limit>

# To disable use of system-wide password file
PersistentPasswd off

<Global>
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# Setting this to 'on' makes PAM the final authority on what gets
# authenticated. Turning this off will tell PAM to allow other
# authentication modules compiled into ProFTPD a chance at the user.
AuthPAMAuthoritative On

# This is the PAM configuration file that will be referenced when
# authenticating. It can be set globally and/or per VirtualHost.
# The default is 'ftp'. Note: all PAM configuration files must be in
# /etc/pam.d
AuthPAMConfig ftp

# Don't let people pass % characters to the server and to protect against DoS attacks (Bugzilla ID 1066)
# DenyFilter (\*.*/)|%

# Allow FXP

AllowForeignAddress on

<Limit SITE_CHMOD>
AllowAll
</Limit>

RequireValidShell on
</Global>

<Limit LOGIN>
Order deny,Allow
Deny from 67.107.2.135, 4.61.187.200
Allow from all
</Limit>

# Normally, we want files to be overwriteable.

<Directory /home/ftp>

AllowOverwrite on
HideNoAccess on
HideUser root
HideGroup root
</Directory>


<Anonymous /home/upload>

User funnyusa
Group private
AnonRequirePassword on #(or off)
RequireValidShell off #(or off)

# Deny login for users with shellaccess
<Limit WRITE>
DenyAll
</Limit>

<Limit LOGIN>

AllowAll

</Limit>

<Directory /home/upload>
<Limit STOR CWD APPE READ RMD DELE MKD>
AllowAll
</Limit>
</Directory>
</Anonymous>

===============================

the annonymous account would not work, when I connect it said incorrect user/password..

And the main ftp for non-annoy, I can access, i can upload but can't FXP? anyone know why? is it because IPtables and IPchain? btw, do i have to run iptables and ipchain at the same time or just one at the time? because I see they are both running now
thanks
 
Old 06-21-2003, 04:05 AM   #2
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
I don't quite follow your question. Are you trying to get any FTP working or is it just the anonymous FTP that isn't working and needs to, if that the case then what's listed in /etc/ftpusers ?

cheers

Jamie...
 
Old 06-21-2003, 09:46 AM   #3
funnyusa
LQ Newbie
 
Registered: Jun 2003
Posts: 13

Original Poster
Rep: Reputation: 0
my question is why my ftp are not able to using FXP. I am able to use admin account to upload from my computer to the ftp but not able to use function FXP to transfer file from other FTP to my FTP
---------------
here is what in my /etc/ftpusers
----------

[root@ensim root]# cat /etc/ftpusers
root
bin
daemon
adm
lp
sync
shutdown
halt
mail
news
uucp
operator
games
gopher
nobody
mailnull
rpm
xfs
rpc
rpcuser
nscd
ident
radvd
vcsa
named
majordomo
 
Old 06-24-2003, 03:02 AM   #4
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
Ah right, now I follow, but I can' t really help I've never used FXP myself and am not sure what might be causing the problem. I've always just used SSH to connect to the remote machine and used straight (s)ftp from there.

cheers

Jamie...
 
Old 06-24-2003, 12:12 PM   #5
funnyusa
LQ Newbie
 
Registered: Jun 2003
Posts: 13

Original Poster
Rep: Reputation: 0
someone know why? please help
 
Old 07-28-2003, 11:25 AM   #6
guc
Member
 
Registered: Jul 2003
Posts: 34

Rep: Reputation: 15
funnyusa did you find the reason ?
 
Old 07-29-2003, 01:26 AM   #7
funnyusa
LQ Newbie
 
Registered: Jun 2003
Posts: 13

Original Poster
Rep: Reputation: 0
yeah I got a reason why now, my computer has zonealarm firewall, I try on a comp with no firewall , working just fine, a friend told me that fxp can't pass 2 firewall , so ..
 
Old 08-21-2003, 09:28 PM   #8
t0c
LQ Newbie
 
Registered: Aug 2003
Location: Toronto, Canada
Distribution: RedHat 9
Posts: 5

Rep: Reputation: 0
Are u behind a NAT or a firewall?? cause if you are u might want to check with those. And if you are enable MasqueradeAddress <publicIP>. As well as set the passive ports using PassivePorts <startingport> <endingport> and foward that range of ports to your computer. Might be useful if you paste the log from the client ftp. Now I never had problems using ZA Pro on the client ftp (meaning I ftpd from servers to another with ZA enabled) so that was never a prob 2 me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FXP Client reilly Debian 4 09-06-2005 05:17 AM
FXP in Linux w0lv3rin3 Linux - Software 6 07-23-2005 12:26 PM
configuring proftpd for fxp notolerance Linux - Software 0 02-09-2004 11:10 AM
NCFTPD and FXP t0c Linux - Software 0 08-21-2003 09:21 PM
fxp + smp voodoo *BSD 1 09-13-2002 07:16 AM


All times are GMT -5. The time now is 03:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration