LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-05-2003, 09:27 AM   #1
Tank
LQ Newbie
 
Registered: May 2003
Posts: 7

Rep: Reputation: 0
Proftpd


I am using Mandrake 8.2 and trying to config proftpd.

From the start I am lost with proftpd, I can't seem to get any user to login to the ftp server either remotely or locally login to proftpd.

I need to find a real basic help doc on its setup, I do not want to do anything fancy, just be able to give one or 2 users ability to ftp files to the /var/www directory..

Any Suggestions or help would be appreciated


Tank - the old guy
 
Old 05-05-2003, 09:43 AM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Well, 2 things:

This application is heavily documented over at it's homepage www.proftpd.org

I have my proftpd.conf file available for viewing:
http://masterc.no-ip.org/share/proftpd.conf

You mainly want to look at setting up a DefaultRoot entry that looks like:
DefaultRoot /var/www

This will automatically set them in that directory when they login.

You should be aware that if you enable users to use FTP on your machine, and you have ssh installed that they can use that as well (under normal circumstances).

Cool
 
Old 05-05-2003, 04:06 PM   #3
Tank
LQ Newbie
 
Registered: May 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks, I will try your config file
 
Old 05-05-2003, 04:33 PM   #4
Tank
LQ Newbie
 
Registered: May 2003
Posts: 7

Original Poster
Rep: Reputation: 0
I tried your file, my server does not like the "standalone" ..

I can't read it it errors to fast, but the proftpd server failed to start and echoed something about the command line argument standalone
 
Old 05-05-2003, 08:29 PM   #5
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Mine is just an example, you'll actually want to compare it with the documentation on the proftpd.org website and find one to suit your needs.

The standalone however shoudn't be causing you errors, more importantly, you should be able to view those errors in your /var/log/syslog or /var/log/messages file. Look also at your /var/log/proftpd.log file for errors specific to proftpd itself.

Cool
 
Old 05-06-2003, 07:58 AM   #6
Tank
LQ Newbie
 
Registered: May 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Lights are coming on, I can now login anonmyous but am having a PAM password issue.

I remember reading about PAM on the porftd.org site.. I will read it again..


Thanks for your help
 
Old 05-06-2003, 09:54 AM   #7
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
You're welcome, and if things don't give that final "crank" to turn the wheels, let me know. I'll be happy to explain things a bit further for you if necessary.

Cool
 
Old 05-07-2003, 11:13 AM   #8
Tank
LQ Newbie
 
Registered: May 2003
Posts: 7

Original Poster
Rep: Reputation: 0
I traced the login problem to PAM

I am having trouble with PAM, in the log file I get an invalid password for the user.

Is this PAM config directing to another file call ftpusers?


#%PAM-1.0

auth required /lib/security/pam_listfile.so item=user sense=deny file=/etc/ftpusers onerr=succeed
auth required /lib/security/pam_pwdb.so shadow nullok
# This is disabled because anonymous logins will fail otherwise,
# unless you give the 'ftp' user a valid shell, or /bin/false and add
# /bin/false to /etc/shells.
#auth required /lib/security/pam_shells.so
account required /lib/security/pam_pwdb.so
session required /lib/security/pam_pwdb.so
 
Old 05-07-2003, 01:52 PM   #9
Tank
LQ Newbie
 
Registered: May 2003
Posts: 7

Original Poster
Rep: Reputation: 0
No one but anonymous can login.. that ftpusers file does not exist on my system..

???
 
Old 05-07-2003, 02:42 PM   #10
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
/etc/ftpusers does not exist? That's ok, just odd. You can create it, inside you will need to define which users should not/cannot login via ftp; those such as root and bin should be listed.

As for the pam error, how are you creating your users? I am not that familiar with PAM to troubleshoot with it, however it may be that you need to use pam to add the users to a pam file somewhere. See if you've got man pam, or search www.google.com/linux for more info on PAM to see if you can find out if that's your problem.

Cool
 
Old 05-08-2003, 08:07 AM   #11
Tank
LQ Newbie
 
Registered: May 2003
Posts: 7

Original Poster
Rep: Reputation: 0
This is a journey!

I have no ftpusers file BUT I have a ftpaccess file and that seems to control who has access via ftp? I can add a line to it and then the user can ftp to the default directory in the proftpd.conf.

The only thing now is the user can not wite to the directories, I chmod the directories with a 775 and made 775 the value in proftpd.conf

any ideas?
 
Old 05-08-2003, 01:52 PM   #12
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
That's a Directory call I believe, look for a section like this:
<Directory /path>
</Directory>

Inside there add:
<Limit WRITE>
AllowAll
</Limit WRITE>
This will allow the users to write in that directory. If you want them to have all rights, you can take away the <Limit WRITE> directives, and just have AllowAll inside the directory brackets, like this:
<Directory /home/username/*>
AllowAll
</Directory>

HTH

Cool
 
Old 05-14-2003, 10:26 AM   #13
warlock
LQ Newbie
 
Registered: May 2003
Location: Norway
Posts: 4

Rep: Reputation: 0
Sorry to interupt but how looks the ftpuser file inside
 
Old 05-14-2003, 11:02 AM   #14
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Quote:
Originally posted by Tank
This is a journey!

I have no ftpusers file BUT I have a ftpaccess file and that seems to control who has access via ftp? I can add a line to it and then the user can ftp to the default directory in the proftpd.conf.

The only thing now is the user can not wite to the directories, I chmod the directories with a 775 and made 775 the value in proftpd.conf

any ideas?
According to this post, one does not exist

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
proftpd: proftpd startup failed tumana Linux - Newbie 14 06-17-2012 12:06 PM
[PROFTPD] Ldap and proftpd authentication wesleywest Linux - Software 1 02-22-2005 10:51 AM
Disabling the chroot in proftpd and enabling root logins on ssh/proftpd jon_k Linux - Software 1 06-16-2004 11:27 AM
proftpd help strider17 Linux - Newbie 2 02-08-2004 12:44 PM
proftpd --- need help? could someone post a working proftpd.conf i could look at ZooRoPa Linux - Networking 1 04-02-2003 07:56 PM


All times are GMT -5. The time now is 10:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration