LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-18-2008, 01:47 AM   #1
Tooz
LQ Newbie
 
Registered: Feb 2008
Posts: 14

Rep: Reputation: 0
Problems with My FAT32


Hello. My FAT32 is recognized just fine with windows, and I can place things there, but when I try to mount my FAT32 drive in Mandriva, it gives me this error...

mount: wrong fs type, bad option, bad superblock on /dev/sda7,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

so I put dmesg | tail in the command prompt (that's the only thing I know, sorry ), and I get this

VFS: Can't find a valid FAT filesystem on dev sda7.
FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
FAT: bogus number of reserved sectors
VFS: Can't find a valid FAT filesystem on dev sda7.
FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
FAT: bogus number of reserved sectors
VFS: Can't find a valid FAT filesystem on dev sda7.
FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
FAT: bogus number of reserved sectors
VFS: Can't find a valid FAT filesystem on dev sda7.

Can somebody tell me whats going on?! I Googled it, but I didn't get much. Thank you for any assistance.

Last edited by Tooz; 02-18-2008 at 02:20 AM. Reason: I forgot to mention that windows works with the FAT32
 
Old 02-18-2008, 02:31 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
What command did you enter in to try to mount it? What is the output of "sudo file -s /dev/sda7"?
 
Old 02-18-2008, 02:40 AM   #3
Tooz
LQ Newbie
 
Registered: Feb 2008
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jschiwal View Post
What command did you enter in to try to mount it? What is the output of "sudo file -s /dev/sda7"?
Sorry, I'm really new to the bash script. I don't know know what to put in front of sudo file -s /dev/sad7 because it just gives "command not found." As for mounting the drive, I entered mount /dev/sda7. On the side bar in the desktop UI, it has this Storage Media, and then if you click on the drive, there will be an option to mount. It gave me the same output as in the terminal.
 
Old 02-18-2008, 03:15 AM   #4
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 75
What is the output of running
Code:
sudo fdisk -l
 
Old 02-18-2008, 03:35 AM   #5
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Is sounds like you don't have the "file" package installed, or /usr/bin/ isn't in roots path.
Open up a terminal and enter "which file". If it isn't found, install it.
This command will analyse a file, based on it's contents, and tell you what it is. Using "sudo" runs the command as root allowing you to read a raw device (/dev/hda7). The -s option will analyse the start of the actual device instead of just saying it is a special file.
For example, this is a look at the first partition on my laptop:
Code:
sudo file -s /dev/sda1
root's password:
/dev/sda1: x86 boot sector, code offset 0x52, OEM-ID "NTFS    ", sectors/cluster 8, reserved sectors 0, Media descriptor 0xf8, heads 255, hidden sectors 63, dos < 4.0 BootSector (0x80)
The "sudo fdisk -l" command will list all of your partitions. It will also print out the "type" byte in the partition table. A thumb drive plugged into my laptop will look like this:
Code:
Disk /dev/sdb: 128 MB, 128450048 bytes
8 heads, 32 sectors/track, 979 cylinders
Units = cylinders of 256 * 512 = 131072 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1         979      125263+   6  FAT16
If the partition were corrupted or not formatted however, fdisk -l will give false information. It gets its info from the partition table, not from the partition itself.

Last edited by jschiwal; 02-18-2008 at 03:36 AM.
 
Old 02-18-2008, 09:33 AM   #6
Tooz
LQ Newbie
 
Registered: Feb 2008
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jschiwal View Post
Is sounds like you don't have the "file" package installed, or /usr/bin/ isn't in roots path.
Open up a terminal and enter "which file". If it isn't found, install it.
This command will analyse a file, based on it's contents, and tell you what it is. Using "sudo" runs the command as root allowing you to read a raw device (/dev/hda7). The -s option will analyse the start of the actual device instead of just saying it is a special file.
For example, this is a look at the first partition on my laptop:
Code:
sudo file -s /dev/sda1
root's password:
/dev/sda1: x86 boot sector, code offset 0x52, OEM-ID "NTFS    ", sectors/cluster 8, reserved sectors 0, Media descriptor 0xf8, heads 255, hidden sectors 63, dos < 4.0 BootSector (0x80)
The "sudo fdisk -l" command will list all of your partitions. It will also print out the "type" byte in the partition table. A thumb drive plugged into my laptop will look like this:
Code:
Disk /dev/sdb: 128 MB, 128450048 bytes
8 heads, 32 sectors/track, 979 cylinders
Units = cylinders of 256 * 512 = 131072 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1         979      125263+   6  FAT16
If the partition were corrupted or not formatted however, fdisk -l will give false information. It gets its info from the partition table, not from the partition itself.
To entering the which file, I did get that it was installed, but I still have to problems...sudo (or anything following it) is not recognized as a valid command, so I'm guessing I have to be root to enter it..but the problem with that is I can't enter the root password at the terminal line because I can't type. To your second request, I received this:
Code:
Disk /dev/sda: 250.0 GB, 250059350016 bytes
240 heads, 63 sectors/track, 32301 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes
Disk identifier: 0x0b7895a2

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        8804    66558208+   7  HPFS/NTFS
/dev/sda2            8805       32301   177637320    5  Extended
/dev/sda5            8805       11809    22717768+  83  Linux
/dev/sda6           11810       12095     2162128+  82  Linux swap / Solaris
/dev/sda7           12096       32301   152757328+   b  W95 FAT32
 
Old 02-18-2008, 09:42 AM   #7
bitpicker
Member
 
Registered: Jul 2003
Location: Germany
Distribution: Xubuntu, Ubuntu
Posts: 416
Blog Entries: 14

Rep: Reputation: 35
As you are using Mandriva you can forget about sudo, but you need to become root to use certain commands.

What is the content of your /etc/fstab file?

Robin
 
Old 02-18-2008, 09:56 AM   #8
Tooz
LQ Newbie
 
Registered: Feb 2008
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bitpicker View Post
As you are using Mandriva you can forget about sudo, but you need to become root to use certain commands.

What is the content of your /etc/fstab file?

Robin
Code:
/dev/sda5 / ext2 relatime 1 1
/dev/sda1 /media/hd ntfs umask=0022,nls=utf8,sync,ro 0 0
none /proc proc defaults 0 0
/dev/sda6 swap swap defaults 0 0
What is very odd is that under the storage media, it does not see the sd7 drive anymore, nor can I mount it from the terminal...but the device manager does see it as a partition??? I think it has to do with the mount point, because whenever I see it, it does have a mount point, and whenever I don't see it, it does not have a mount point. And I do not know what mount point to give it.
 
Old 02-18-2008, 10:43 AM   #9
bitpicker
Member
 
Registered: Jul 2003
Location: Germany
Distribution: Xubuntu, Ubuntu
Posts: 416
Blog Entries: 14

Rep: Reputation: 35
It doesn't turn up in your fstab. Is it a device which is always connected to the PC? If so, then it should have an entry in fstab. With no such entry a simple mount command as the one you quoted above is not sufficient. Newer hardware detection can create mount points and mount drives automatically on the fly, but it seems this isn't working in your case.

The mount point you use for the system is up to you. Just create a directory in /mnt or /media for your device (must be root to do that). Then try mounting the device with the following command, which assumes you are using the mount point /mnt/mydevice:

Code:
mount -t vfat /dev/sda7 /mnt/mydevice
This should do the trick. For a permanently attached vfat device, add the following line to your fstab as root:

Code:
/dev/sda7     /mnt/mydevice      vfat     users,auto   0 0
That should mount the device on each boot, if you ask me.

Robin
 
Old 02-18-2008, 12:29 PM   #10
Tooz
LQ Newbie
 
Registered: Feb 2008
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks bitpicker! It looks like it worked finally with mount -t vfat /dev/sda7 /mnt. The only problem now is that i can't write on it on Linux because i don't know how to login as root, but it receives files just fine from windows (can someone help me with this?) Thanks again anyone who tried to help out...
 
Old 02-18-2008, 03:02 PM   #11
bitpicker
Member
 
Registered: Jul 2003
Location: Germany
Distribution: Xubuntu, Ubuntu
Posts: 416
Blog Entries: 14

Rep: Reputation: 35
How is it you don't know how to login as root? You just have to issue the command su then type in the root password.

You really shouldn't mount the disk to /mnt, use a subdirectory of /mnt. There may be other mounted systems or mount attempts to subdirectories of /mnt which won't work if you make this FAT 32 disk take that place.

You really have to figure out how to become root because using this computer without ever having root access is nigh impossible.

The line I gave you for fstab should make the FAT 32 disk writeable for users, too, but you need to be root to add it to fstab.

Robin
 
Old 02-19-2008, 07:32 AM   #12
Tooz
LQ Newbie
 
Registered: Feb 2008
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bitpicker View Post
How is it you don't know how to login as root? You just have to issue the command su then type in the root password.

You really shouldn't mount the disk to /mnt, use a subdirectory of /mnt. There may be other mounted systems or mount attempts to subdirectories of /mnt which won't work if you make this FAT 32 disk take that place.

You really have to figure out how to become root because using this computer without ever having root access is nigh impossible.

The line I gave you for fstab should make the FAT 32 disk writeable for users, too, but you need to be root to add it to fstab.

Robin
Oh, alright, thank you for the help. I think I'll be able to figure everything out from this point. Thanks again.
 
Old 02-22-2008, 01:35 PM   #13
Tooz
LQ Newbie
 
Registered: Feb 2008
Posts: 14

Original Poster
Rep: Reputation: 0
I'm still a little confused about the root login....I can login to it in the console, I can't at the login screen, and I can't seem to save things when I'm logged into it in Konsole, but I am trying to save something outside of console. I looked over the KWrite manual, but I'm still having this problem.
 
Old 02-22-2008, 07:31 PM   #14
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 75
If you want to use kwrite to edit files as root, enter ALT-F2 in the resulting dialogue box enter the command "kdesu kwrite" and then click on run. Many distros disable logging in as root into a GUI by default because this encourage people to work as root all the time which is considered a security risk and any mistakes made can cause irreversible damage or loss of data.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with shared FAT32 partition Heithgaldr Linux - General 4 02-26-2007 08:31 PM
Problems mounting Fat32 macmichael01 SUSE / openSUSE 5 06-25-2005 12:45 PM
FAT32 partition problems Daliz Linux - Software 2 02-15-2004 03:57 AM
FAT32 and Grub Problems... jankerz Linux - Newbie 3 12-07-2003 01:37 AM
mounted fat32 problems curos Linux - Newbie 2 08-04-2003 12:31 PM


All times are GMT -5. The time now is 03:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration